Upgrade to 1.43.

Remove some patches which have been committed upstream.
This commit is contained in:
Thierry Thomas 2004-11-01 18:41:03 +00:00
parent d2277d095f
commit f97f524d7a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120601
5 changed files with 11 additions and 43 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= freefem++
PORTVERSION= 1.42
PORTVERSION= 1.43
CATEGORIES= math science
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/freefem/ \
http://mule.ann.jussieu.fr/~hecht/ftp/freefem/
@ -45,7 +45,7 @@ LIBBLAS= -lf2c -lf77blas -latlas -lgslcblas
LIBARPACK= -larpack -lalapack ${LIBBLAS}
DOCS= AUTHORS BUGS COPYING HISTORY README TODO DOC/manual.pdf
BADSAMPLES= load/load.link.orig load/myfunction.o tutorial/Makefile.in.orig
BADSAMPLES= load/myfunction.o tutorial/Makefile.in.orig
.include <bsd.port.pre.mk>

View File

@ -1,2 +1,2 @@
MD5 (freefem++-1.42.tar.gz) = 659bcd4e143fa091c02451b0aab6c281
SIZE (freefem++-1.42.tar.gz) = 4535380
MD5 (freefem++-1.43.tar.gz) = 6c1e5be2f2fbf70af458dfb65b821f85
SIZE (freefem++-1.43.tar.gz) = 11951306

View File

@ -1,26 +0,0 @@
--- examples++-load/load.link.orig Wed Jun 30 14:17:01 2004
+++ examples++-load/load.link Sun Jul 11 00:30:37 2004
@@ -9,18 +9,18 @@
Darwin)
export MACOSX_DEPLOYMENT_TARGET=10.3
SHARED="-bundle -undefined dynamic_lookup" ;;
- Linux|CYGWIN*)
+ Linux|FreeBSD|CYGWIN*)
SHARED="-shared " ;;
*)
echo "sorry unknown achitecture "`uname`
exit 1
esac
- echo g++ -c $INC $PIC $1.cpp
- g++ -c $INC $PIC $1.cpp
+ echo $CXX -c $INC $PIC $1.cpp
+ $CXX -c $INC $PIC $1.cpp
- echo g++ $SHARED $1.o -o $1.so
- g++ $SHARED $1.o -o $1.so
+ echo $CXX $SHARED $1.o -o $1.so
+ $CXX $SHARED $1.o -o $1.so
else
echo "sorry file $1.cpp does not exist"

View File

@ -1,13 +0,0 @@
--- ./src/femlib/MatriceCreuse_tpl.hpp.orig Mon Aug 30 17:06:00 2004
+++ ./src/femlib/MatriceCreuse_tpl.hpp Wed Sep 8 22:18:17 2004
@@ -11,7 +11,9 @@
// on MacOS9 under MWERKS
// cblas_ddot macos-9 is not
#ifdef HAVE_CBLAS_H
-#include <cblas.h>
+extern "C" {
+#include <cblas.h>
+}
#define WITHBLAS 1
#elif HAVE_VECLIB_CBLAS_H
#include <vecLib/cblas.h>

View File

@ -48,6 +48,7 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/load/load.link
%%PORTDOCS%%%%EXAMPLESDIR%%/load/myfunction.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/load/myfunction.so
%%PORTDOCS%%%%EXAMPLESDIR%%/makeref.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/essai.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/regtests.sh
%%PORTDOCS%%%%EXAMPLESDIR%%/mpi/schwarz-b.edp
@ -56,11 +57,14 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/other/lap3-cpu.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/other/speedtest.sh
%%PORTDOCS%%%%EXAMPLESDIR%%/parareal.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/ref.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/regtests.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/regtests.m4
%%PORTDOCS%%%%EXAMPLESDIR%%/testFE.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/testadp.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/teste.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/FE.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/FEComplex.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/LapDG2.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/Laplace.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/LaplaceP1.edp
@ -94,6 +98,7 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/freeboundary-weak.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/freeboundary.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/gnuplot.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/makeref.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/medit.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/mesh.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/movemesh.edp
@ -110,9 +115,11 @@ bin/FreeFem++-nw
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-gc.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-no-overlap.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/schwarz-overlap.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/sparse-cmatrix.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/sparse-matrix.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/sphere.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/tablefunction.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/tt.edp
%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/xyf
%%PORTDOCS%%%%EXAMPLESDIR%%/wafer-heating-laser-axi.edp
%%PORTDOCS%%@dirrm %%DOCSDIR%%