A qmail-queue replacement to filter mail traffic and more.
It supports: * Antivirus executing * body filtering * subject filtering * attachment blocking * quarantine * white/black list * single line logging for qmail and many features. PR: ports/83590 Submitted by: Ozkan KIRIK <ozkan@enderunix.org> Approved by: flz (mentor)
This commit is contained in:
parent
fb21a8d1b7
commit
f932907ab2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139689
@ -421,6 +421,7 @@
|
||||
SUBDIR += qpopper
|
||||
SUBDIR += qscan
|
||||
SUBDIR += qsf
|
||||
SUBDIR += qsheff
|
||||
SUBDIR += qtools
|
||||
SUBDIR += queue-fix
|
||||
SUBDIR += queue-repair
|
||||
|
66
mail/qsheff/Makefile
Normal file
66
mail/qsheff/Makefile
Normal file
@ -0,0 +1,66 @@
|
||||
# New ports collection makefile for: qsheff
|
||||
# Date created: 14 Jul 2005
|
||||
# Whom: Ozkan KIRIK <ozkan@enderunix.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qsheff
|
||||
PORTVERSION= 1.0.r1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.enderunix.org/qsheff/
|
||||
DISTNAME= ${PORTNAME}-1.0-r1
|
||||
|
||||
MAINTAINER= ozkan@enderunix.org
|
||||
COMMENT= A qmail-queue replacement to filter mail traffic
|
||||
|
||||
RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-queue:${PORTSDIR}/mail/qmail \
|
||||
${LOCALBASE}/bin/ripmime:${PORTSDIR}/mail/ripmime
|
||||
|
||||
USE_REINPLACE= YES
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
PORTDOCS= spamass-qsheff.en.html README COPYING AUTHORS ChangeLog \
|
||||
INSTALL UPGRADE THANKS TODO
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
OPTIONS= CLAMAV "Integrate with Clam AntiVirus" on
|
||||
|
||||
.if exists(${LOCALBASE}/qmail/bin/qmail-queue)
|
||||
QMAIL_DIR?= ${LOCALBASE}/qmail
|
||||
.else
|
||||
QMAIL_DIR?= /var/qmail
|
||||
.endif
|
||||
|
||||
PREFIX?= ${QMAIL_DIR}
|
||||
|
||||
CONFIGURE_ARGS+= --with-qmaildir=${QMAIL_DIR}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITHOUT_CLAMAV)
|
||||
RUN_DEPENDS+= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav
|
||||
.endif
|
||||
.if !defined(WITHOUT_FPROT) & defined(WITHOUT_CLAMAV)
|
||||
RUN_DEPENDS+= ${LOCALBASE}/bin/f-prot:${PORTSDIR}/security/f-prot
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if defined(NOPORTDOCS)
|
||||
@${REINPLACE_CMD} -e 's|\(install-data-am: \)install-qsheffdocDATA|\1|g' \
|
||||
-e 's| contribute$$||g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
.if defined(WITHOUT_CLAMAV)
|
||||
@${REINPLACE_CMD} -e 's|enable_virus_prog = 1|enable_virus_prog = 0|g' \
|
||||
${WRKSRC}/etc/qsheff.conf-default
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
mail/qsheff/distinfo
Normal file
2
mail/qsheff/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (qsheff-1.0-r1.tar.gz) = fa9e21cbf2a9014beb05d8a7e55a46d8
|
||||
SIZE (qsheff-1.0-r1.tar.gz) = 105460
|
11
mail/qsheff/files/patch-Makefile.in
Normal file
11
mail/qsheff/files/patch-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.in.orig Wed Jul 20 08:33:16 2005
|
||||
+++ Makefile.in Wed Jul 20 08:33:21 2005
|
||||
@@ -734,8 +734,6 @@
|
||||
mkdir -p /var/tmp/qsheffq
|
||||
touch /var/log/qsheff.log
|
||||
chmod 755 /var/tmp/qsheffq /var/spool/qsheffq
|
||||
- if [ -x @QMAILDIR@/bin/qmail-queue ]; then cp -pf @QMAILDIR@/bin/qmail-queue @QMAILDIR@/bin/qmail-queue.orig; rm -f @QMAILDIR@/bin/qmail-queue; fi
|
||||
- ln -s @QMAILDIR@/bin/qmail-qsheff @QMAILDIR@/bin/qmail-queue
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
9
mail/qsheff/files/pkg-message.in
Normal file
9
mail/qsheff/files/pkg-message.in
Normal file
@ -0,0 +1,9 @@
|
||||
|
||||
ATTENTION:
|
||||
|
||||
To start to use qmail-qsheff you need to overwrite qmail-queue program.
|
||||
Make a backup before do it.
|
||||
|
||||
> cp %%PREFIX%%/bin/qmail-queue %%PREFIX%%/bin/qmail-queue.orig
|
||||
> cp %%PREFIX%%/bin/qmail-qsheff %%PREFIX%%/bin/qmail-queue
|
||||
|
19
mail/qsheff/pkg-descr
Normal file
19
mail/qsheff/pkg-descr
Normal file
@ -0,0 +1,19 @@
|
||||
A qmail-queue replacement to filter mail traffic and more.
|
||||
It supports:
|
||||
* Antivirus executing
|
||||
* body filtering
|
||||
* subject filtering
|
||||
* attachment blocking
|
||||
* quarantine
|
||||
* white/black list
|
||||
* single line logging for qmail and many features.
|
||||
|
||||
Project Page:
|
||||
WWW: http://www.enderunix.org/qsheff
|
||||
|
||||
Author:
|
||||
|
||||
Baris SIMSEK
|
||||
simsek@enderunix.org
|
||||
EnderUNIX SDT @ Turkey
|
||||
http://www.enderunix.org/simsek/
|
24
mail/qsheff/pkg-plist
Normal file
24
mail/qsheff/pkg-plist
Normal file
@ -0,0 +1,24 @@
|
||||
@comment $FreeBSD$
|
||||
bin/qsheff
|
||||
@unexec if cmp -s %D/etc/qsheff/qsheff.attach %D/etc/qsheff/qsheff.attach-default; then rm -f %D/etc/qsheff/qsheff.attach; fi
|
||||
etc/qsheff/qsheff.attach-default
|
||||
@exec [ -f %B/qsheff.attach ] || cp %B/%f %B/qsheff.attach
|
||||
@unexec if cmp -s %D/etc/qsheff/qsheff.conf %D/etc/qsheff/qsheff.conf-default; then rm -f %D/etc/qsheff/qsheff.conf; fi
|
||||
etc/qsheff/qsheff.conf-default
|
||||
@unexec if cmp -s %D/etc/qsheff/qsheff.rules %D/etc/qsheff/qsheff.rules-default; then rm -f %D/etc/qsheff/qsheff.rules; fi
|
||||
etc/qsheff/qsheff.rules-default
|
||||
@exec [ -f %B/qsheff.rules ] || cp %B/%f %B/qsheff.attach
|
||||
@unexec if cmp -s %D/etc/qsheff/qsheff.wblist %D/etc/qsheff/qsheff.wblist-default; then rm -f %D/etc/qsheff/qsheff.wblist; fi
|
||||
etc/qsheff/qsheff.wblist-default
|
||||
@exec [ -f %B/qsheff.wblist ] || cp %B/%f %B/qsheff.attach
|
||||
%%DATADIR%%/developer.notes
|
||||
%%DATADIR%%/eicar.com.txt
|
||||
%%DATADIR%%/sample-OK.msg
|
||||
%%DATADIR%%/sample-SPAM.msg
|
||||
%%DATADIR%%/sample-VIRUS.msg
|
||||
%%DATADIR%%/uninstall.sh
|
||||
@unexec rmdir %D/etc/qsheff 2>/dev/null || true
|
||||
@dirrm %%DATADIR%%
|
||||
@unexec echo "ATTENTION:"
|
||||
@unexec echo "1) Remember to restore your qmail-queue program on %%PREFIX%%/bin"
|
||||
@unexec echo "2) Quarantina directory (/var/spool/qsheffq) not removed. You can remove it manually."
|
Loading…
Reference in New Issue
Block a user