- Remove FreeBSD 4.x stuff.

- Update WWW to lastest version of Ubuntu.
- Update to ubuntulooks_0.9.12-4 that comes with three patches to fix bugs,
  bump the PORTREVISION.

	* patch-01_fix_listview_arrows_drawing: fix all listview columns
	  having an arrow drawing (Ubuntu: #71339)
	* patch-01_fix_tick_box_drawing: - undo patch from bug #57749, it
	  make tick box being not correctly centered (Ubuntu: #58610)
	* patch-gtkrc: use 'gtk-icon-sizes = "panel-menu=24,24"'
	  (Ubuntu: #43398)

Approved by:	Phillip N. <pneumann@gmail.com> (maintainer)
This commit is contained in:
Jeremy Messenger 2007-06-15 12:37:01 +00:00
parent 0c0b19e3a2
commit f9205d3f3e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=193578
5 changed files with 113 additions and 9 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= ubuntulooks
PORTVERSION= 0.9.12
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= x11-themes
MASTER_SITES= http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntulooks/
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@ -23,10 +23,4 @@ USE_GMAKE= yes
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= does not compile
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,13 @@
diff -Nur ubuntulooks-0.9.12/engine/src/ubuntulooks_style.c ubuntulooks-0.9.12.new/engine/src/ubuntulooks_style.c
--- ubuntulooks-0.9.12/engine/src/ubuntulooks_style.c 2006-08-23 12:38:26.000000000 +0200
+++ engine/src/ubuntulooks_style.c 2007-02-12 17:28:36.000000000 +0100
@@ -1084,6 +1084,9 @@
sanitize_size (window, &width, &height);
+ if (arrow_type == (GtkArrowType)4)
+ return;
+
if (DETAIL ("arrow"))
{
WidgetParameters params;

View File

@ -0,0 +1,87 @@
diff -Nur ubuntulooks-0.9.12/engine/src/ubuntulooks_draw.c ubuntulooks-0.9.12.new/engine/src/ubuntulooks_draw.c
--- ubuntulooks-0.9.12/engine/src/ubuntulooks_draw.c 2006-09-01 18:57:20.000000000 +0200
+++ engine/src/ubuntulooks_draw.c 2006-10-09 16:26:29.000000000 +0200
@@ -1837,14 +1837,6 @@
cairo_pattern_t *pattern;
gboolean draw_bullet = (checkbox->shadow_type == GTK_SHADOW_IN);
- /* sanitize size to be rectangular */
- if (width > height) {
- x += (width - height) / 2;
- width = height;
- } else if (height > width) {
- y += (height - width) / 2;
- height = width;
- }
cairo_set_line_width (cr, 1.0);
@@ -1947,8 +1939,6 @@
}
- cairo_translate (cr, x, y);
- cairo_scale (cr, width / 13.0, height / 13.0);
/* To offset this checkmark, one should probably use a translation */
if (draw_bullet)
{
@@ -1961,7 +1951,7 @@
cairo_translate (cr, -2, -2);
}
- cairo_move_to (cr, 4, 8);
+ cairo_move_to (cr, x + 4, y + 8);
cairo_rel_line_to (cr, 5, 4);
cairo_rel_curve_to (cr, 1.4, -5, -1, -1, 5.7, -12.5);
cairo_rel_curve_to (cr, -4, 4, -4, 4, -6.7, 9.3);
@@ -1975,7 +1965,10 @@
}
else if (checkbox->shadow_type == GTK_SHADOW_ETCHED_IN)
{
- cairo_rectangle (cr, 4.0, 6.0, 6, 2);
+ int c_x = x + (width/2) - 2;
+ int c_y = y + (height/2);
+
+ cairo_rectangle (cr, c_x, c_y, 6, 2);
cairo_set_source_rgb (cr, colors->text[widget->state_type].r,
colors->text[widget->state_type].g,
colors->text[widget->state_type].b);
@@ -1993,15 +1986,7 @@
CairoColor border, top, bottom;
cairo_pattern_t *pattern;
gboolean draw_bullet = (checkbox->shadow_type == CL_SHADOW_IN || checkbox->shadow_type == CL_SHADOW_ETCHED_IN);
- /* sanitize size to be rectangular */
- if (width > height) {
- x += (width - height) / 2;
- width = height;
- } else if (height > width) {
- y += (height - width) / 2;
- height = width;
- }
-
+
cairo_set_line_width (cr, 1.0);
if (checkbox->in_menu)
@@ -2085,11 +2070,9 @@
cairo_stroke (cr);
// draw the bullet
- cairo_translate (cr, x, y);
- cairo_scale (cr, width / 13.0, height / 13.0);
if (draw_bullet)
{
- cairo_arc (cr, 6.5, 6.5, 2.5, 0, 2 * M_PI);
+ cairo_arc (cr, x+width/2., y+height/2., 2.5, 0, 2 * M_PI);
if (widget->disabled)
{
cairo_set_source_rgb (cr, colors->text[widget->state_type].r,
@@ -2098,7 +2081,7 @@
}
else
{
- pattern = cairo_pattern_create_radial (5.25, 5.25, 0.1, 5.25, 5.25, 4);
+ pattern = cairo_pattern_create_radial (x+width/2. - 1.25, y+height/2. - 1.25, 0.1, x+width/2. - 1.25, y+height/2. - 1.25, 4);
cairo_pattern_add_color_stop_rgb (pattern, 0.0, 0.4, 0.4, 0.4);
cairo_pattern_add_color_stop_rgb (pattern, 1.0, colors->text[widget->state_type].r,
colors->text[widget->state_type].g,

View File

@ -0,0 +1,10 @@
--- themes/Human/gtk-2.0/gtkrc.orig Fri Jun 8 00:06:54 2007
+++ themes/Human/gtk-2.0/gtkrc Fri Jun 8 00:07:19 2007
@@ -7,6 +7,7 @@
#
# Feel free to modify and share!
+gtk-icon-sizes = "panel-menu=24,24"
style "clearlooks-default"
{

View File

@ -1,3 +1,3 @@
This is a GTK+ 2.x engine from Ubuntu Dapper. It features a modern look.
WWW: http://packages.ubuntu.com/dapper/source/ubuntulooks
WWW: http://packages.ubuntu.com/feisty/source/ubuntulooks