Deorbit x11-wm/wmii-devel' in favor of updated x11-wm/wmii'.

Encouraged by:	sat (maintainer)
This commit is contained in:
Alexey Dokuchaev 2008-01-29 14:33:11 +00:00
parent dfb3e1c45f
commit f8bae2f0aa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=206382
8 changed files with 1 additions and 134 deletions

1
MOVED
View File

@ -3359,3 +3359,4 @@ devel/p5-gearmand|devel/p5-Gearman-Server|2008-01-20|Replaced by p5-Gearman-Serv
database/mysqltoolkit|database/maatkit|2008-01-21|project was renamed
games/sturmbahnfahrer|games/stormbaancoureur|2008-01-27|project was renamed
net/cactid|net-mgmt/cacti-spine|2008-01-27|project was renamed
x11-wm/wmii-devel|x11-wm/wmii|2008-01-29|Development version no longer necessary

View File

@ -135,7 +135,6 @@
SUBDIR += wmcp
SUBDIR += wmg
SUBDIR += wmii
SUBDIR += wmii-devel
SUBDIR += wmthemeinstall
SUBDIR += xcompmgr
SUBDIR += xfce

View File

@ -1,39 +0,0 @@
# New ports collection makefile for: wmii-devel
# Date created: 2 June 2005
# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= wmii
PORTVERSION= 3.5.${CHANGESET}
PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= CENKES
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= A dynamic minimalist window manager
LIB_DEPENDS= ixp.0:${PORTSDIR}/devel/libixp
RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu \
${LOCALBASE}/9/bin/rc:${PORTSDIR}/devel/9base
CHANGESET= 2010
CONFLICTS= wmii-3.[0-46-9]* wmii-3.5.1*
USE_XLIB= yes
USE_BZIP2= yes
MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${X11BASE}/lib" \
X11INC="${X11BASE}/include" CC="${CC}" \
MANPREFIX="${MANPREFIX}/man"
MAN1= wmii.1 wmiiloop.1 wmiir.1 wmiiwm.1
post-patch:
@${REINPLACE_CMD} -e '/-[LI]/s|PREFIX|LOCALBASE|g;/^[CL].*FLAGS/s|=|+=|' ${WRKSRC}/config.mk
@${REINPLACE_CMD} -e '/cp -f wmiiwm/s|cp -f|${INSTALL_PROGRAM}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|$$PLAN9|${LOCALBASE}/9|' ${WRKSRC}/wmii9rc
@${REINPLACE_CMD} -e 's|$$PLAN9|${LOCALBASE}/9|;1s|/.*|${LOCALBASE}/9/bin/rc -v|' ${WRKSRC}/rc/rc.wmii
@${REINPLACE_CMD} -e '/strlcat/d' ${WRKSRC}/wmii.h
@${FIND} ${WRKSRC}/ -name \*.bak -delete
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (wmii-3.5.2010.tar.bz2) = 2218f15c3a96aa0496ebef5abc27350d
SHA256 (wmii-3.5.2010.tar.bz2) = d2d278e7fec3315fad025d3c42d64d710f750b35e77784038d2f987d4efd0938
SIZE (wmii-3.5.2010.tar.bz2) = 57284

View File

@ -1,70 +0,0 @@
--- ./util.c.orig Sun Mar 4 19:55:23 2007
+++ ./util.c Sun Mar 4 19:55:30 2007
@@ -79,67 +79,3 @@
return s;
return "<nil>";
}
-
-/*
- * Copyright (c) 1998 Todd C. Miller <Todd.Miller@courtesan.com>
- * All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- * 3. The name of the author may not be used to endorse or promote products
- * derived from this software without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES,
- * INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
- * AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
- * THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
- * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-/*
- * Appends src to string dst of size siz (unlike strncat, siz is the
- * full size of dst, not space left). At most siz-1 characters
- * will be copied. Always NUL terminates (unless siz <= strlen(dst)).
- * Returns strlen(src) + MIN(siz, strlen(initial dst)).
- * If retval >= siz, truncation occurred.
- */
-uint
-strlcat(char *dst, const char *src, unsigned int siz) {
- const char *s;
- char *d;
- unsigned int n, dlen;
-
- n = siz;
- s = src;
- d = dst;
-
- /* Find the end of dst and adjust bytes left but don't go past end */
- while (n-- != 0 && *d != '\0')
- d++;
- dlen = d - dst;
- n = siz - dlen;
-
- if (n == 0)
- return(dlen + strlen(s));
- while (*s != '\0') {
- if (n != 1) {
- *d++ = *s;
- n--;
- }
- s++;
- }
- *d = '\0';
-
- return(dlen + (s - src)); /* count does not include NUL */
-}

View File

@ -1,9 +0,0 @@
WMII is a dynamic window manager for X11. It supports classic and dynamic
window management with extended keyboard, mouse, and filesystem based remote
control. It replaces the workspace paradigm with a new tagging approach.
Its minimalist philosophy attempts to not exceed 10.000 lines of code
(including all shipped utilities and libraries), to enforce simplicity and
clarity.
WWW: http://www.suckless.org/wiki/wmii

View File

@ -1,10 +0,0 @@
bin/wmii
bin/wmii9menu
bin/wmii9rc
bin/wmiiloop
bin/wmiir
bin/wmiiwm
etc/wmii-3.5/rc.wmii
etc/wmii-3.5/welcome
etc/wmii-3.5/wmiirc
@dirrm etc/wmii-3.5

View File

@ -17,8 +17,6 @@ LIB_DEPENDS= ixp.1:${PORTSDIR}/devel/libixp
RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu \
${LOCALBASE}/9/bin/rc:${PORTSDIR}/devel/9base
CONFLICTS= wmii-3.5.*
USE_ICONV= yes
USE_XLIB= yes