Update to 1.6.0.
This commit is contained in:
parent
df8b044cb1
commit
f8933e5fc6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72081
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= netatalk
|
||||
PORTVERSION= 1.5.5
|
||||
PORTVERSION= 1.6.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= netatalk
|
||||
|
||||
MAINTAINER= marcus@FreeBSD.org
|
||||
|
||||
.if defined(WITH_CNID)
|
||||
.if !defined(WITHOUT_CNID)
|
||||
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
|
||||
.endif
|
||||
.if defined(WITH_SRVLOC)
|
||||
@ -44,19 +44,18 @@ CONFIGURE_ARGS+= --enable-srvloc=${LOCALBASE}
|
||||
# Quark Express save issues.
|
||||
CONFIGURE_ARGS+= --with-flock-locks
|
||||
.endif
|
||||
.if defined(WITH_CNID)
|
||||
# Configure EXPERIMENTAL CNID DID support. This is an attmept to make
|
||||
# DIDs more persistent by using a Berkeley database to store the DID values.
|
||||
# This should hopefully allow aliases to work between restarts of afpd.
|
||||
# This has been tested on MacOS 9.2.x and OS X.
|
||||
CONFIGURE_ARGS+= --with-did=cnid \
|
||||
--with-db3=${LOCALBASE}
|
||||
PLIST_SUB+= NETATALKCNID=""
|
||||
.if !defined(WITHOUT_CNID)
|
||||
# Configure old LAST DID support. By default, the new CNID persistent DID
|
||||
# calculation scheme is used. However, if you wish to revert back to the old
|
||||
# 1.5.x default scheme, specify WITHOUT_CNID
|
||||
CONFIGURE_ARGS+= --with-did=last
|
||||
PLIST_SUB+= NETATALKCNID="@comment "
|
||||
.else
|
||||
# This method of DID calculation is not persistent, but has been tested to
|
||||
# work with MacOS X (10.0.3-10.1.3) as well as MacOS 7-9.2.2.
|
||||
CONFIGURE_ARGS+= --with-did=last
|
||||
PLIST_SUB+= NETATALKCNID="@comment "
|
||||
CONFIGURE_ARGS+= --with-did=cnid \
|
||||
--with-db3=${LOCALBASE}
|
||||
PLIST_SUB+= NETATALKCNID=""
|
||||
.endif
|
||||
.if defined (WITH_TIMELORD)
|
||||
CONFIGURE_ARGS+= --enable-timelord
|
||||
@ -82,7 +81,7 @@ MAN3= atalk_aton.3 nbp_name.3
|
||||
MAN4= atalk.4
|
||||
MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
|
||||
netatalk.conf.5 papd.conf.5
|
||||
MAN8= afpd.8 atalkd.8 pap.8 papd.8 papstatus.8 psf.8 timelord.8
|
||||
MAN8= afpd.8 atalkd.8 papd.8 papstatus.8 psf.8 timelord.8
|
||||
|
||||
post-extract:
|
||||
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/netatalk.sh \
|
||||
|
@ -1 +1 @@
|
||||
MD5 (netatalk-1.5.5.tar.bz2) = 93ec251d47f355c99daad19de0b40eb2
|
||||
MD5 (netatalk-1.6.0.tar.bz2) = c141aa6712fed7a51b989b0aa80977c7
|
||||
|
@ -1,17 +0,0 @@
|
||||
--- config/Makefile.in.orig Mon Dec 17 14:30:53 2001
|
||||
+++ config/Makefile.in Mon Dec 17 14:31:45 2001
|
||||
@@ -264,12 +264,8 @@
|
||||
install-config-files: $(CONFFILES) $(GENFILES)
|
||||
$(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
|
||||
for f in $(CONFFILES) $(GENFILES); do \
|
||||
- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
|
||||
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
|
||||
- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir); \
|
||||
- else \
|
||||
- echo "not overwriting $$f"; \
|
||||
- fi; \
|
||||
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
|
||||
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
|
||||
done
|
||||
|
||||
@USE_PAM_TRUE@install-data-local: install-config-files $(PAMFILES)
|
@ -1,13 +1,24 @@
|
||||
--- config/Makefile.in.orig Mon Oct 7 17:06:54 2002
|
||||
+++ config/Makefile.in Mon Oct 7 17:07:13 2002
|
||||
@@ -292,10 +292,6 @@
|
||||
--- config/Makefile.in.orig Mon Nov 25 22:12:52 2002
|
||||
+++ config/Makefile.in Sun Dec 15 16:57:43 2002
|
||||
@@ -244,19 +244,11 @@
|
||||
install-config-files: $(CONFFILES) $(GENFILES)
|
||||
$(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
|
||||
for f in $(CONFFILES) $(GENFILES); do \
|
||||
- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
|
||||
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
|
||||
- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir); \
|
||||
- else \
|
||||
- echo "not overwriting $$f"; \
|
||||
- fi; \
|
||||
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
|
||||
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
|
||||
done
|
||||
|
||||
@USE_PAM_TRUE@install-data-local: install-config-files $(PAMFILES)
|
||||
-@USE_PAM_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pamdir)
|
||||
-@USE_PAM_TRUE@ for f in $(PAMFILES); do \
|
||||
-@USE_PAM_TRUE@ $(INSTALL_DATA) $$f $(DESTDIR)$(pamdir)/netatalk; \
|
||||
-@USE_PAM_TRUE@ for f in $(PAMFILES); do \
|
||||
-@USE_PAM_TRUE@ $(INSTALL_DATA) $$f $(DESTDIR)$(pamdir)/netatalk || echo "WARNING: Can't install PAM files"; \
|
||||
-@USE_PAM_TRUE@ done
|
||||
|
||||
@USE_PAM_FALSE@install-data-local: install-config-files
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig Sun Sep 1 12:50:59 2002
|
||||
+++ configure Wed Oct 2 22:19:05 2002
|
||||
@@ -1499,10 +1499,6 @@
|
||||
--- configure.orig Mon Nov 25 22:08:45 2002
|
||||
+++ configure Sun Dec 15 16:59:28 2002
|
||||
@@ -1543,10 +1543,6 @@
|
||||
|
||||
# The aliases save the names the user supplied, while $host etc.
|
||||
# will get canonicalized.
|
||||
@ -8,10 +8,10 @@
|
||||
- test "$program_prefix$program_suffix$program_transform_name" = \
|
||||
- NONENONEs,x,x, &&
|
||||
- program_prefix=${target_alias}-
|
||||
am__api_version="1.6"
|
||||
am__api_version="1.4"
|
||||
# Find a good install program. We prefer a C program (faster),
|
||||
# so one script is as good as another. But avoid the broken or
|
||||
@@ -12706,13 +12702,13 @@
|
||||
@@ -12252,13 +12248,13 @@
|
||||
savedldflags="$LDFLAGS"
|
||||
CFLAGS="$CFLAGS -I$db3dir"
|
||||
LDFLAGS="-L$db3libdir $LDFLAGS"
|
||||
@ -28,7 +28,7 @@
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -12759,7 +12755,7 @@
|
||||
@@ -12299,7 +12295,7 @@
|
||||
|
||||
db3found=yes
|
||||
DB3_CFLAGS="-I$db3dir"
|
||||
|
@ -107,10 +107,12 @@ include/atalk/aep.h
|
||||
include/atalk/afp.h
|
||||
include/atalk/asp.h
|
||||
include/atalk/atp.h
|
||||
include/atalk/boolean.h
|
||||
include/atalk/cnid.h
|
||||
include/atalk/compat.h
|
||||
include/atalk/ddp.h
|
||||
include/atalk/dsi.h
|
||||
include/atalk/logger.h
|
||||
include/atalk/nbp.h
|
||||
include/atalk/netddp.h
|
||||
include/atalk/pap.h
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= netatalk
|
||||
PORTVERSION= 1.5.5
|
||||
PORTVERSION= 1.6.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= netatalk
|
||||
|
||||
MAINTAINER= marcus@FreeBSD.org
|
||||
|
||||
.if defined(WITH_CNID)
|
||||
.if !defined(WITHOUT_CNID)
|
||||
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
|
||||
.endif
|
||||
.if defined(WITH_SRVLOC)
|
||||
@ -44,19 +44,18 @@ CONFIGURE_ARGS+= --enable-srvloc=${LOCALBASE}
|
||||
# Quark Express save issues.
|
||||
CONFIGURE_ARGS+= --with-flock-locks
|
||||
.endif
|
||||
.if defined(WITH_CNID)
|
||||
# Configure EXPERIMENTAL CNID DID support. This is an attmept to make
|
||||
# DIDs more persistent by using a Berkeley database to store the DID values.
|
||||
# This should hopefully allow aliases to work between restarts of afpd.
|
||||
# This has been tested on MacOS 9.2.x and OS X.
|
||||
CONFIGURE_ARGS+= --with-did=cnid \
|
||||
--with-db3=${LOCALBASE}
|
||||
PLIST_SUB+= NETATALKCNID=""
|
||||
.if !defined(WITHOUT_CNID)
|
||||
# Configure old LAST DID support. By default, the new CNID persistent DID
|
||||
# calculation scheme is used. However, if you wish to revert back to the old
|
||||
# 1.5.x default scheme, specify WITHOUT_CNID
|
||||
CONFIGURE_ARGS+= --with-did=last
|
||||
PLIST_SUB+= NETATALKCNID="@comment "
|
||||
.else
|
||||
# This method of DID calculation is not persistent, but has been tested to
|
||||
# work with MacOS X (10.0.3-10.1.3) as well as MacOS 7-9.2.2.
|
||||
CONFIGURE_ARGS+= --with-did=last
|
||||
PLIST_SUB+= NETATALKCNID="@comment "
|
||||
CONFIGURE_ARGS+= --with-did=cnid \
|
||||
--with-db3=${LOCALBASE}
|
||||
PLIST_SUB+= NETATALKCNID=""
|
||||
.endif
|
||||
.if defined (WITH_TIMELORD)
|
||||
CONFIGURE_ARGS+= --enable-timelord
|
||||
@ -82,7 +81,7 @@ MAN3= atalk_aton.3 nbp_name.3
|
||||
MAN4= atalk.4
|
||||
MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
|
||||
netatalk.conf.5 papd.conf.5
|
||||
MAN8= afpd.8 atalkd.8 pap.8 papd.8 papstatus.8 psf.8 timelord.8
|
||||
MAN8= afpd.8 atalkd.8 papd.8 papstatus.8 psf.8 timelord.8
|
||||
|
||||
post-extract:
|
||||
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/netatalk.sh \
|
||||
|
@ -1 +1 @@
|
||||
MD5 (netatalk-1.5.5.tar.bz2) = 93ec251d47f355c99daad19de0b40eb2
|
||||
MD5 (netatalk-1.6.0.tar.bz2) = c141aa6712fed7a51b989b0aa80977c7
|
||||
|
@ -1,17 +0,0 @@
|
||||
--- config/Makefile.in.orig Mon Dec 17 14:30:53 2001
|
||||
+++ config/Makefile.in Mon Dec 17 14:31:45 2001
|
||||
@@ -264,12 +264,8 @@
|
||||
install-config-files: $(CONFFILES) $(GENFILES)
|
||||
$(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
|
||||
for f in $(CONFFILES) $(GENFILES); do \
|
||||
- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
|
||||
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
|
||||
- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir); \
|
||||
- else \
|
||||
- echo "not overwriting $$f"; \
|
||||
- fi; \
|
||||
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
|
||||
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
|
||||
done
|
||||
|
||||
@USE_PAM_TRUE@install-data-local: install-config-files $(PAMFILES)
|
@ -1,13 +1,24 @@
|
||||
--- config/Makefile.in.orig Mon Oct 7 17:06:54 2002
|
||||
+++ config/Makefile.in Mon Oct 7 17:07:13 2002
|
||||
@@ -292,10 +292,6 @@
|
||||
--- config/Makefile.in.orig Mon Nov 25 22:12:52 2002
|
||||
+++ config/Makefile.in Sun Dec 15 16:57:43 2002
|
||||
@@ -244,19 +244,11 @@
|
||||
install-config-files: $(CONFFILES) $(GENFILES)
|
||||
$(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
|
||||
for f in $(CONFFILES) $(GENFILES); do \
|
||||
- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
|
||||
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
|
||||
- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir); \
|
||||
- else \
|
||||
- echo "not overwriting $$f"; \
|
||||
- fi; \
|
||||
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
|
||||
+ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
|
||||
done
|
||||
|
||||
@USE_PAM_TRUE@install-data-local: install-config-files $(PAMFILES)
|
||||
-@USE_PAM_TRUE@ $(mkinstalldirs) $(DESTDIR)$(pamdir)
|
||||
-@USE_PAM_TRUE@ for f in $(PAMFILES); do \
|
||||
-@USE_PAM_TRUE@ $(INSTALL_DATA) $$f $(DESTDIR)$(pamdir)/netatalk; \
|
||||
-@USE_PAM_TRUE@ for f in $(PAMFILES); do \
|
||||
-@USE_PAM_TRUE@ $(INSTALL_DATA) $$f $(DESTDIR)$(pamdir)/netatalk || echo "WARNING: Can't install PAM files"; \
|
||||
-@USE_PAM_TRUE@ done
|
||||
|
||||
@USE_PAM_FALSE@install-data-local: install-config-files
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig Sun Sep 1 12:50:59 2002
|
||||
+++ configure Wed Oct 2 22:19:05 2002
|
||||
@@ -1499,10 +1499,6 @@
|
||||
--- configure.orig Mon Nov 25 22:08:45 2002
|
||||
+++ configure Sun Dec 15 16:59:28 2002
|
||||
@@ -1543,10 +1543,6 @@
|
||||
|
||||
# The aliases save the names the user supplied, while $host etc.
|
||||
# will get canonicalized.
|
||||
@ -8,10 +8,10 @@
|
||||
- test "$program_prefix$program_suffix$program_transform_name" = \
|
||||
- NONENONEs,x,x, &&
|
||||
- program_prefix=${target_alias}-
|
||||
am__api_version="1.6"
|
||||
am__api_version="1.4"
|
||||
# Find a good install program. We prefer a C program (faster),
|
||||
# so one script is as good as another. But avoid the broken or
|
||||
@@ -12706,13 +12702,13 @@
|
||||
@@ -12252,13 +12248,13 @@
|
||||
savedldflags="$LDFLAGS"
|
||||
CFLAGS="$CFLAGS -I$db3dir"
|
||||
LDFLAGS="-L$db3libdir $LDFLAGS"
|
||||
@ -28,7 +28,7 @@
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -12759,7 +12755,7 @@
|
||||
@@ -12299,7 +12295,7 @@
|
||||
|
||||
db3found=yes
|
||||
DB3_CFLAGS="-I$db3dir"
|
||||
|
@ -107,10 +107,12 @@ include/atalk/aep.h
|
||||
include/atalk/afp.h
|
||||
include/atalk/asp.h
|
||||
include/atalk/atp.h
|
||||
include/atalk/boolean.h
|
||||
include/atalk/cnid.h
|
||||
include/atalk/compat.h
|
||||
include/atalk/ddp.h
|
||||
include/atalk/dsi.h
|
||||
include/atalk/logger.h
|
||||
include/atalk/nbp.h
|
||||
include/atalk/netddp.h
|
||||
include/atalk/pap.h
|
||||
|
Loading…
Reference in New Issue
Block a user