- Fix warnings in urlview.c [1]

- Add LICENSE
- Add stage support

PR:		ports/180681
Submitted by:	Anton Shterenlikht <mexas@bris.ac.uk> (maintainer) [1]
This commit is contained in:
Danilo Egea Gondolfo 2013-11-25 15:06:59 +00:00
parent 4aca91442b
commit f8438495a8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=334855
2 changed files with 23 additions and 10 deletions

View File

@ -15,19 +15,23 @@ MASTER_SITES= ftp://ftp.mutt.org/mutt/contrib/ \
MAINTAINER= mexas@bris.ac.uk
COMMENT= URL extractor/launcher
GNU_CONFIGURE= yes
MAN1= urlview.1
PLIST_FILES= bin/urlview \
etc/urlview.conf.sample
LICENSE= GPLv2
GNU_CONFIGURE= yes
PLIST_FILES= bin/urlview \
etc/urlview.conf.sample \
man/man1/urlview.1.gz
MAKE_ENV= DESTDIR=${STAGEDIR}
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
-e 's/url_handler.sh/firefox/' \
${WRKSRC}/*
post-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/urlview ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/urlview.man ${STAGEDIR}${MAN1PREFIX}/man/man1/urlview.1
${INSTALL_DATA} ${WRKSRC}/sample.urlview \
${PREFIX}/etc/urlview.conf.sample
${STAGEDIR}${PREFIX}/etc/urlview.conf.sample
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- urlview.c.orig Wed Nov 9 15:34:39 2005
+++ urlview.c Wed Nov 9 15:35:06 2005
--- urlview.c.orig 2013-07-19 22:44:59.000000000 +0100
+++ urlview.c 2013-07-19 22:45:22.000000000 +0100
@@ -46,6 +46,8 @@
#include <rx/rxposix.h>
#endif
@ -7,5 +7,14 @@
+#include "quote.h"
+
#define DEFAULT_REGEXP "(((https?|ftp|gopher)://|(mailto|file|news):)[^' \t<>\"]+|(www|web|w3)\\.[-a-z0-9.]+)[^' \t.,;<>\"\\):]"
#define DEFAULT_COMMAND "url_handler.sh %s"
#define DEFAULT_COMMAND "firefox %s"
#define SYSTEM_INITFILE "/usr/local/etc/urlview.conf"
@@ -61,7 +63,7 @@
MOTION
};
-extern int mutt_enter_string (unsigned char *buf, size_t buflen, int y, int x,
+extern int mutt_enter_string (char *buf, size_t buflen, int y, int x,
int flags);
void search_forward (char *search, int urlcount, char **url, int *redraw, int *current, int *top)