audio/libmusicbrainz5: Update to snapshot from 2015-07-06 (e29cc9a)

- The main purpose of this intermediate update is to eliminate unwanted debug
  information emitted when running console applications.
- Backport commit 36262d6 to eliminate wildcards for dependencies in
  CMakeLists.txt which CMake complains about (CMP0058). As a result, we can
  switch to an outsource build.

While here:
- Update LICENSE (LGPL21+) and add LICENSE_FILE
- Remake/rename patches with 'make makepatch'

Changes:	https://github.com/metabrainz/libmusicbrainz/compare/release-5.1.0...e29cc9a
PR:		250567
Submitted by:	Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
Jason E. Hale 2020-10-30 10:32:26 +00:00
parent 5344516e0c
commit f84239c0e0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=553677
6 changed files with 34 additions and 26 deletions

View File

@ -1,20 +1,21 @@
# $FreeBSD$
PORTNAME= libmusicbrainz
PORTVERSION= 5.1.0
PORTREVISION= 3
DISTVERSIONPREFIX= release-
DISTVERSION= 5.1.0-19
DISTVERSIONSUFFIX= -ge29cc9a
CATEGORIES= audio
PKGNAMESUFFIX= 5
MAINTAINER= jhale@FreeBSD.org
COMMENT= MusicBrainz client library for audio metadata lookup
LICENSE= LGPL21
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
LIB_DEPENDS= libneon.so:www/neon
USES= cmake:insource compiler:c++11-lang gnome iconv:build pathfix
USES= cmake compiler:c++11-lang gnome iconv:build pathfix
USE_GNOME= libxml2
USE_LDCONFIG= yes

View File

@ -1,2 +1,3 @@
SHA256 (metabrainz-libmusicbrainz-release-5.1.0_GH0.tar.gz) = 6e1dc7158d884748287eb14159c4e2866eb4f4e5559765c7c17621c4a3c802c8
SIZE (metabrainz-libmusicbrainz-release-5.1.0_GH0.tar.gz) = 78005
TIMESTAMP = 1603483215
SHA256 (metabrainz-libmusicbrainz-release-5.1.0-19-ge29cc9a_GH0.tar.gz) = 59ea04531607e0e1f552da150b263ee8cd55ccbc8c96f6f3cd7d2d7dab63db28
SIZE (metabrainz-libmusicbrainz-release-5.1.0-19-ge29cc9a_GH0.tar.gz) = 78950

View File

@ -1,5 +1,10 @@
--- include/musicbrainz5/HTTPFetch.h.orig 2016-08-06 17:10:23.956575000 +0200
+++ include/musicbrainz5/HTTPFetch.h 2016-08-06 17:26:10.934640000 +0200
Add visibility to C++ exceptions to prevent crashes with applications
using libkcddb.
PR: 211630
--- include/musicbrainz5/HTTPFetch.h.orig 2015-07-06 20:45:19 UTC
+++ include/musicbrainz5/HTTPFetch.h
@@ -29,11 +29,23 @@
#include <string>
#include <vector>
@ -25,7 +30,7 @@
{
public:
CExceptionBase(const std::string& ErrorMessage, const std::string& Exception)
@@ -60,7 +72,7 @@
@@ -60,7 +72,7 @@ namespace MusicBrainz5
* Exception thrown when an error occurs connecting to web service
*/
@ -34,7 +39,7 @@
{
public:
CConnectionError(const std::string& ErrorMessage)
@@ -73,7 +85,7 @@
@@ -73,7 +85,7 @@ namespace MusicBrainz5
* Exception thrown when a connection to the web service times out
*/
@ -43,7 +48,7 @@
{
public:
CTimeoutError(const std::string& ErrorMessage)
@@ -86,7 +98,7 @@
@@ -86,7 +98,7 @@ namespace MusicBrainz5
* Exception thrown when an authentication error occurs
*/
@ -52,7 +57,7 @@
{
public:
CAuthenticationError(const std::string& ErrorMessage)
@@ -99,7 +111,7 @@
@@ -99,7 +111,7 @@ namespace MusicBrainz5
* Exception thrown when an error occurs fetching data
*/
@ -61,7 +66,7 @@
{
public:
CFetchError(const std::string& ErrorMessage)
@@ -112,7 +124,7 @@
@@ -112,7 +124,7 @@ namespace MusicBrainz5
* Exception thrown when an invalid request is made
*/
@ -70,7 +75,7 @@
{
public:
CRequestError(const std::string& ErrorMessage)
@@ -125,7 +137,7 @@
@@ -125,7 +137,7 @@ namespace MusicBrainz5
* Exception thrown when the requested resource is not found
*/

View File

@ -1,4 +1,4 @@
--- src/CMakeLists.txt.orig 2014-11-13 13:12:24 UTC
--- src/CMakeLists.txt.orig 2015-07-06 20:45:19 UTC
+++ src/CMakeLists.txt
@@ -5,6 +5,7 @@ INCLUDE_DIRECTORIES(
${CMAKE_CURRENT_BINARY_DIR}/../include
@ -8,3 +8,13 @@
)
SET(_sources Alias.cc Annotation.cc Artist.cc ArtistCredit.cc Attribute.cc CDStub.cc Collection.cc
@@ -36,7 +37,8 @@ ADD_CUSTOM_COMMAND(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.cc ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.h ${CMAKE_CURRENT_BINARY_DIR}/../include/musicbrainz5/mb5_c.h
COMMAND make-c-interface ${CMAKE_CURRENT_SOURCE_DIR} cinterface.xml ${CMAKE_CURRENT_BINARY_DIR} mb5_c.cc mb5_c.h
COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.h ${CMAKE_CURRENT_BINARY_DIR}/../include/musicbrainz5/mb5_c.h
- DEPENDS make-c-interface cinterface.xml *.inc
+ DEPENDS make-c-interface cinterface.xml c-int-medium-defines.inc c-int-query-source.inc c-int-source-funcs.inc
+ c-int-medium-source.inc c-int-release-defines.inc c-int-query-defines.inc c-int-release-source.inc
)
ADD_CUSTOM_TARGET(src_gen DEPENDS mb5_c.h)

View File

@ -1,11 +0,0 @@
--- src/c-int-source-funcs.inc.orig 2014-11-13 13:12:24 UTC
+++ src/c-int-source-funcs.inc
@@ -157,7 +157,7 @@ std::string GetMapValue(std::map<std::st
if (o) \
{ \
try { \
- ((MusicBrainz5::C##TYPE1 *)o)->Set##PROP1(str); \
+ ((MusicBrainz5::C##TYPE1 *)o)->Set##PROP1(str ? str : ""); \
} \
catch (...) { \
} \

View File

@ -38,6 +38,8 @@ include/musicbrainz5/NameCredit.h
include/musicbrainz5/NameCreditList.h
include/musicbrainz5/NonMBTrack.h
include/musicbrainz5/NonMBTrackList.h
include/musicbrainz5/Offset.h
include/musicbrainz5/OffsetList.h
include/musicbrainz5/PUID.h
include/musicbrainz5/PUIDList.h
include/musicbrainz5/Query.h