- Install additional files for salome
- Portlint PR: ports/152394 Submitted by: Stas Timokhin <devel@stasyan.com> Approved by: Stephen Montgomery-Smith <stephen@missouri.edu> (maintainer)
This commit is contained in:
parent
bb8e8e0f48
commit
f78028c250
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=265192
@ -7,14 +7,18 @@
|
||||
|
||||
PORTNAME= netgen
|
||||
PORTVERSION= 4.9.13
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= SF/netgen-mesher/netgen-mesher/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= stephen@missouri.edu
|
||||
COMMENT= An automatic 3D tetrahedral mesh generator
|
||||
|
||||
LIB_DEPENDS= tix8184:${PORTSDIR}/x11-toolkits/tix \
|
||||
jpeg.11:${PORTSDIR}/graphics/jpeg \
|
||||
togl.1:${PORTSDIR}/graphics/togl
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USE_GMAKE= yes
|
||||
USE_TK= 84
|
||||
USE_TK_BUILD= 84
|
||||
@ -25,9 +29,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} -I${TK_LIBDIR}/Togl-1.7
|
||||
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
|
||||
CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR} --enable-jpeglib
|
||||
LIB_DEPENDS+= tix8184:${PORTSDIR}/x11-toolkits/tix \
|
||||
jpeg.11:${PORTSDIR}/graphics/jpeg \
|
||||
togl.1:${PORTSDIR}/graphics/togl
|
||||
|
||||
FETCH_BEFORE_ARGS+= -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
@ -67,6 +68,10 @@ pre-configure:
|
||||
${WRKSRC}/ng/ngappinit.cpp
|
||||
|
||||
post-install:
|
||||
# copy some additional headers for build cad/salome-netgenplugin
|
||||
${MKDIR} ${DATADIR}/include
|
||||
${SH} ${FILESDIR}/netgen_copy_include_for_salome ${WRKSRC} ${PREFIX}
|
||||
${LN} ${PREFIX}/lib/libnglib.so ${PREFIX}/lib/libnglib.so.1
|
||||
${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,2 @@
|
||||
MD5 (netgen-4.9.13.tar.gz) = 2d56642ca673106837bcd08ff9913d57
|
||||
SHA256 (netgen-4.9.13.tar.gz) = a5f188bb0fafc0536389314efb8fe6d294b93512b54f2b67c9a3e5431c3b0412
|
||||
SIZE (netgen-4.9.13.tar.gz) = 1829916
|
||||
|
39
cad/netgen/files/netgen_copy_include_for_salome
Normal file
39
cad/netgen/files/netgen_copy_include_for_salome
Normal file
@ -0,0 +1,39 @@
|
||||
#!/bin/sh
|
||||
|
||||
src_dir=$1
|
||||
install_dir=$2
|
||||
|
||||
if ! test -d $src_dir/libsrc ; then
|
||||
echo "No dir $src_dir/libsrc ... Bye"
|
||||
exit 1
|
||||
fi
|
||||
if ! test -d $install_dir/share/netgen ; then
|
||||
echo "No dir $install_dir/share/netgen ... Bye"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
dest_dir=$install_dir/share/netgen/include
|
||||
mkdir -p $dest_dir > /dev/null 2>&1
|
||||
cp -af $src_dir/libsrc/csg/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/general/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/geom2d/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/gprim/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/interface/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/linalg/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/meshing/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/stlgeom/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/visualization/*.hpp $dest_dir
|
||||
|
||||
cp -af $src_dir/libsrc/occ/*.hpp $dest_dir
|
||||
cp -af $src_dir/libsrc/occ/*.hxx $dest_dir
|
||||
cp -af $src_dir/libsrc/occ/*.ixx $dest_dir
|
||||
cp -af $src_dir/libsrc/occ/*.jxx $dest_dir
|
||||
cp -af $src_dir/libsrc/occ/*.h $dest_dir
|
||||
|
||||
cp -af $src_dir/libsrc/include/mystdlib.h $dest_dir
|
||||
cp -af $src_dir/libsrc/include/mydefs.hpp $dest_dir
|
||||
# cp -af $src_dir/libsrc/include/parallel.hpp $dest_dir
|
||||
|
||||
rm -f $dest_dir/ngexception.hpp
|
||||
rm -f $dest_dir/paralleltop.hpp
|
||||
rm -f $dest_dir/soldata.hpp
|
9
cad/netgen/files/patch-libsrc_occ_Makefile.am
Normal file
9
cad/netgen/files/patch-libsrc_occ_Makefile.am
Normal file
@ -0,0 +1,9 @@
|
||||
--- libsrc/occ/Makefile.am.orig 2010-11-08 10:10:46.000000000 +0600
|
||||
+++ libsrc/occ/Makefile.am 2010-11-08 10:10:57.000000000 +0600
|
||||
@@ -1,5 +1,4 @@
|
||||
-noinst_HEADERS = occgeom.hpp occmeshsurf.hpp \
|
||||
-Partition_Inter2d.hxx Partition_Loop2d.hxx Partition_Loop.hxx \
|
||||
+noinst_HEADERS = Partition_Inter2d.hxx Partition_Loop2d.hxx Partition_Loop.hxx \
|
||||
Partition_Inter3d.hxx Partition_Loop3d.hxx Partition_Spliter.hxx \
|
||||
Partition_Inter2d.ixx Partition_Loop2d.ixx Partition_Loop.ixx \
|
||||
Partition_Inter3d.ixx Partition_Loop3d.ixx Partition_Spliter.ixx \
|
@ -22,6 +22,7 @@ include/parallelinterface.hpp
|
||||
include/soldata.hpp
|
||||
lib/libnglib.la
|
||||
lib/libnglib.so
|
||||
lib/libnglib.so.1
|
||||
%%DOCSDIR%%/ng4.pdf
|
||||
%%DATADIR%%/boxcyl.geo
|
||||
%%DATADIR%%/circle_on_cube.geo
|
||||
@ -62,5 +63,141 @@ lib/libnglib.so
|
||||
%%DATADIR%%/twobricks.geo
|
||||
%%DATADIR%%/twocubes.geo
|
||||
%%DATADIR%%/twocyl.geo
|
||||
%%DATADIR%%/include/Partition_Inter2d.hxx
|
||||
%%DATADIR%%/include/Partition_Inter2d.ixx
|
||||
%%DATADIR%%/include/Partition_Inter2d.jxx
|
||||
%%DATADIR%%/include/Partition_Inter3d.hxx
|
||||
%%DATADIR%%/include/Partition_Inter3d.ixx
|
||||
%%DATADIR%%/include/Partition_Inter3d.jxx
|
||||
%%DATADIR%%/include/Partition_Loop.hxx
|
||||
%%DATADIR%%/include/Partition_Loop.ixx
|
||||
%%DATADIR%%/include/Partition_Loop.jxx
|
||||
%%DATADIR%%/include/Partition_Loop2d.hxx
|
||||
%%DATADIR%%/include/Partition_Loop2d.ixx
|
||||
%%DATADIR%%/include/Partition_Loop2d.jxx
|
||||
%%DATADIR%%/include/Partition_Loop3d.hxx
|
||||
%%DATADIR%%/include/Partition_Loop3d.ixx
|
||||
%%DATADIR%%/include/Partition_Loop3d.jxx
|
||||
%%DATADIR%%/include/Partition_Spliter.hxx
|
||||
%%DATADIR%%/include/Partition_Spliter.ixx
|
||||
%%DATADIR%%/include/Partition_Spliter.jxx
|
||||
%%DATADIR%%/include/adfront2.hpp
|
||||
%%DATADIR%%/include/adfront3.hpp
|
||||
%%DATADIR%%/include/adtree.hpp
|
||||
%%DATADIR%%/include/algprim.hpp
|
||||
%%DATADIR%%/include/array.hpp
|
||||
%%DATADIR%%/include/autodiff.hpp
|
||||
%%DATADIR%%/include/autoptr.hpp
|
||||
%%DATADIR%%/include/basegeom.hpp
|
||||
%%DATADIR%%/include/bcfunctions.hpp
|
||||
%%DATADIR%%/include/bisect.hpp
|
||||
%%DATADIR%%/include/bitarray.hpp
|
||||
%%DATADIR%%/include/boundarylayer.hpp
|
||||
%%DATADIR%%/include/brick.hpp
|
||||
%%DATADIR%%/include/classifyhpel.hpp
|
||||
%%DATADIR%%/include/clusters.hpp
|
||||
%%DATADIR%%/include/csg.hpp
|
||||
%%DATADIR%%/include/csgeom.hpp
|
||||
%%DATADIR%%/include/csgparser.hpp
|
||||
%%DATADIR%%/include/curve2d.hpp
|
||||
%%DATADIR%%/include/curvedelems.hpp
|
||||
%%DATADIR%%/include/densemat.hpp
|
||||
%%DATADIR%%/include/dynamicmem.hpp
|
||||
%%DATADIR%%/include/edgeflw.hpp
|
||||
%%DATADIR%%/include/explicitcurve2d.hpp
|
||||
%%DATADIR%%/include/extrusion.hpp
|
||||
%%DATADIR%%/include/findip.hpp
|
||||
%%DATADIR%%/include/findip2.hpp
|
||||
%%DATADIR%%/include/flags.hpp
|
||||
%%DATADIR%%/include/gencyl.hpp
|
||||
%%DATADIR%%/include/geom2d.hpp
|
||||
%%DATADIR%%/include/geom2dmesh.hpp
|
||||
%%DATADIR%%/include/geom3d.hpp
|
||||
%%DATADIR%%/include/geometry2d.hpp
|
||||
%%DATADIR%%/include/geomfuncs.hpp
|
||||
%%DATADIR%%/include/geoml.hpp
|
||||
%%DATADIR%%/include/geomobjects.hpp
|
||||
%%DATADIR%%/include/geomobjects2.hpp
|
||||
%%DATADIR%%/include/geomops.hpp
|
||||
%%DATADIR%%/include/geomops2.hpp
|
||||
%%DATADIR%%/include/geomsearch.hpp
|
||||
%%DATADIR%%/include/geomtest3d.hpp
|
||||
%%DATADIR%%/include/global.hpp
|
||||
%%DATADIR%%/include/gprim.hpp
|
||||
%%DATADIR%%/include/hashtabl.hpp
|
||||
%%DATADIR%%/include/hpref_hex.hpp
|
||||
%%DATADIR%%/include/hpref_prism.hpp
|
||||
%%DATADIR%%/include/hpref_pyramid.hpp
|
||||
%%DATADIR%%/include/hpref_quad.hpp
|
||||
%%DATADIR%%/include/hpref_segm.hpp
|
||||
%%DATADIR%%/include/hpref_tet.hpp
|
||||
%%DATADIR%%/include/hpref_trig.hpp
|
||||
%%DATADIR%%/include/hprefinement.hpp
|
||||
%%DATADIR%%/include/identify.hpp
|
||||
%%DATADIR%%/include/improve2.hpp
|
||||
%%DATADIR%%/include/improve3.hpp
|
||||
%%DATADIR%%/include/linalg.hpp
|
||||
%%DATADIR%%/include/localh.hpp
|
||||
%%DATADIR%%/include/manifold.hpp
|
||||
%%DATADIR%%/include/meshclass.hpp
|
||||
%%DATADIR%%/include/meshdoc.hpp
|
||||
%%DATADIR%%/include/meshfunc.hpp
|
||||
%%DATADIR%%/include/meshing.hpp
|
||||
%%DATADIR%%/include/meshing2.hpp
|
||||
%%DATADIR%%/include/meshing3.hpp
|
||||
%%DATADIR%%/include/meshstlsurface.hpp
|
||||
%%DATADIR%%/include/meshsurf.hpp
|
||||
%%DATADIR%%/include/meshtool.hpp
|
||||
%%DATADIR%%/include/meshtype.hpp
|
||||
%%DATADIR%%/include/mpi_interface.hpp
|
||||
%%DATADIR%%/include/msghandler.hpp
|
||||
%%DATADIR%%/include/mvdraw.hpp
|
||||
%%DATADIR%%/include/myadt.hpp
|
||||
%%DATADIR%%/include/mydefs.hpp
|
||||
%%DATADIR%%/include/mystdlib.h
|
||||
%%DATADIR%%/include/mystring.hpp
|
||||
%%DATADIR%%/include/netgenout.hpp
|
||||
%%DATADIR%%/include/occgeom.hpp
|
||||
%%DATADIR%%/include/occmeshsurf.hpp
|
||||
%%DATADIR%%/include/opti.hpp
|
||||
%%DATADIR%%/include/optmem.hpp
|
||||
%%DATADIR%%/include/parthreads.hpp
|
||||
%%DATADIR%%/include/polyhedra.hpp
|
||||
%%DATADIR%%/include/polynomial.hpp
|
||||
%%DATADIR%%/include/profiler.hpp
|
||||
%%DATADIR%%/include/revolution.hpp
|
||||
%%DATADIR%%/include/ruler2.hpp
|
||||
%%DATADIR%%/include/ruler3.hpp
|
||||
%%DATADIR%%/include/seti.hpp
|
||||
%%DATADIR%%/include/singularref.hpp
|
||||
%%DATADIR%%/include/solid.hpp
|
||||
%%DATADIR%%/include/sort.hpp
|
||||
%%DATADIR%%/include/spbita2d.hpp
|
||||
%%DATADIR%%/include/specials.hpp
|
||||
%%DATADIR%%/include/specpoin.hpp
|
||||
%%DATADIR%%/include/spline.hpp
|
||||
%%DATADIR%%/include/spline2d.hpp
|
||||
%%DATADIR%%/include/spline3d.hpp
|
||||
%%DATADIR%%/include/splinegeometry.hpp
|
||||
%%DATADIR%%/include/stack.hpp
|
||||
%%DATADIR%%/include/stlgeom.hpp
|
||||
%%DATADIR%%/include/stlline.hpp
|
||||
%%DATADIR%%/include/stltool.hpp
|
||||
%%DATADIR%%/include/stltopology.hpp
|
||||
%%DATADIR%%/include/surface.hpp
|
||||
%%DATADIR%%/include/symbolta.hpp
|
||||
%%DATADIR%%/include/table.hpp
|
||||
%%DATADIR%%/include/template.hpp
|
||||
%%DATADIR%%/include/topology.hpp
|
||||
%%DATADIR%%/include/transform3d.hpp
|
||||
%%DATADIR%%/include/triapprox.hpp
|
||||
%%DATADIR%%/include/utilities.h
|
||||
%%DATADIR%%/include/validate.hpp
|
||||
%%DATADIR%%/include/vector.hpp
|
||||
%%DATADIR%%/include/vispar.hpp
|
||||
%%DATADIR%%/include/visual.hpp
|
||||
%%DATADIR%%/include/vssolution.hpp
|
||||
%%DATADIR%%/include/writeuser.hpp
|
||||
@dirrm %%DATADIR%%/include
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm %%DOCSDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user