databases/cassandra4: Update to 4.0-beta1

- Update to version 4.0-beta1
 - fix build on aarch64

PR:		248228 248004
Submitted by:	Angelo Polo (maintainer), Ronald Klop (aarch64 fix)
This commit is contained in:
Mikael Urankar 2020-07-26 12:55:20 +00:00
parent 5970c16f33
commit f769e737f1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=543475
6 changed files with 67 additions and 54 deletions

View File

@ -1,15 +1,15 @@
# $FreeBSD$
PORTNAME= cassandra
DISTVERSION= 4.0-alpha4
DISTVERSION= 4.0-beta1
CATEGORIES= databases java
MASTER_SITES= APACHE/cassandra/${DISTVERSION}:apache \
https://repo1.maven.org/maven2/com/github/luben/zstd-jni/1.4.4-9/:maven \
LOCAL/pi:repo
https://repo1.maven.org/maven2/com/github/luben/zstd-jni/1.4.5-4/:maven \
LOCAL/mikael:repo
PKGNAMESUFFIX= 4
DISTNAME= apache-${PORTNAME}-${DISTVERSION}-src
DISTFILES= ${DISTNAME}.tar.gz:apache \
zstd-jni-1.4.4-9-freebsd_amd64.jar:maven \
${ZSTD_DISTFILE} \
apache-${PORTNAME}-${DISTVERSION}-repo.tar.gz:repo
EXTRACT_ONLY= ${DISTNAME}.tar.gz \
apache-${PORTNAME}-${DISTVERSION}-repo.tar.gz
@ -34,7 +34,6 @@ CONFLICTS= cassandra3
JAVA_VERSION= 8 11
JAVA_VENDOR= openjdk
REINPLACE_ARGS= -i ''
SUB_LIST= JAVA_HOME=${JAVA_HOME}
USERS= cassandra
@ -68,7 +67,8 @@ SCRIPT_FILES= cassandra \
sstableutil \
sstableverify
PLIST_SUB= DISTVERSION=${DISTVERSION}
ZSTDJNI_VERSION=${MASTER_SITES:M*\:maven:H:T}
PLIST_SUB= DISTVERSION=${DISTVERSION} ZSTDJNI_VERSION=${ZSTDJNI_VERSION}
OPTIONS_DEFINE= SIGAR DOCS
OPTIONS_DEFAULT= SIGAR
@ -138,14 +138,25 @@ USEJDK11= -Duse.jdk11=true
.if ${ARCH} == amd64
PLIST_SUB+= AMD64ONLY=""
PLIST_SUB+= I386ONLY="@comment "
.elif ${ARCH} == i386
PLIST_SUB+= AMD64ONLY="@comment "
PLIST_SUB+= I386ONLY=""
.else
PLIST_SUB+= AMD64ONLY="@comment "
PLIST_SUB+= I386ONLY="@comment "
.endif
.if ${ARCH} == amd64 || ${ARCH} == i386
ZSTD_DISTFILE= zstd-jni-${MASTER_SITES:M*\:maven:H:T}-freebsd_${ARCH}.jar:maven
.else
ZSTD_DISTFILE=
.endif
post-install:
${LN} -s ${JAVAJARDIR}/netty.jar ${STAGEDIR}${DATADIR}/lib/netty.jar
.if ${ARCH} == amd64
${CP} ${DISTDIR}/zstd-jni-1.4.4-9-freebsd_amd64.jar ${STAGEDIR}${DATADIR}/lib/
.if ${ARCH} == amd64 || ${ARCH} == i386
${CP} ${DISTDIR}/zstd-jni-${ZSTDJNI_VERSION}-freebsd_${ARCH}.jar ${STAGEDIR}${DATADIR}/lib/
.endif
post-install-DOCS-on:

View File

@ -1,7 +1,9 @@
TIMESTAMP = 1587819246
SHA256 (apache-cassandra-4.0-alpha4-src.tar.gz) = 8f62238ac1f19fc2ab91c1f88981a46ded3b5e30ed7421266682cf81942b5856
SIZE (apache-cassandra-4.0-alpha4-src.tar.gz) = 45311406
SHA256 (zstd-jni-1.4.4-9-freebsd_amd64.jar) = 97d20ae4ad56aad81d0f11cc4da21f6036bedc26f9908e4c2cc5998aa2dfcf4d
SIZE (zstd-jni-1.4.4-9-freebsd_amd64.jar) = 521330
SHA256 (apache-cassandra-4.0-alpha4-repo.tar.gz) = 6becab355e49fcddcd8b35e61febf39105d7a42574488ea91775bbd0b34d750b
SIZE (apache-cassandra-4.0-alpha4-repo.tar.gz) = 74348796
TIMESTAMP = 1595420655
SHA256 (apache-cassandra-4.0-beta1-src.tar.gz) = 341bcd561e68c569ba1083d7595476a09c10ac491df0051e7b5e4cc99590a865
SIZE (apache-cassandra-4.0-beta1-src.tar.gz) = 46454540
SHA256 (zstd-jni-1.4.5-4-freebsd_amd64.jar) = cdfcacd3d0b405869fc71c7c73ff861fa5421045f53a6168a0d0b4e8ae7ebfbc
SIZE (zstd-jni-1.4.5-4-freebsd_amd64.jar) = 512671
SHA256 (zstd-jni-1.4.5-4-freebsd_i386.jar) = bb3e6e4081ffbe28648983d3c2f47cd488a29b6bb09b1e9f1219cdf82b3ed648
SIZE (zstd-jni-1.4.5-4-freebsd_i386.jar) = 418462
SHA256 (apache-cassandra-4.0-beta1-repo.tar.gz) = ef9efcff62f4ea567eed01e4f70185068a11f9cb766129ccce0f0f86d45506b1
SIZE (apache-cassandra-4.0-beta1-repo.tar.gz) = 77747125

View File

@ -1,4 +1,4 @@
--- build.xml.orig 2020-04-10 22:29:25 UTC
--- build.xml.orig 2020-07-17 21:24:30 UTC
+++ build.xml
@@ -23,6 +23,7 @@
<property file="build.properties" />
@ -7,8 +7,8 @@
+ <property name="pycmd" value="python"/>
<!-- default version and SCM information -->
<property name="base.version" value="4.0-alpha4"/>
@@ -75,14 +76,14 @@
<property name="base.version" value="4.0-beta1"/>
@@ -74,14 +75,14 @@
<condition property="version" value="${base.version}">
<isset property="release"/>
</condition>
@ -25,7 +25,7 @@
<property name="maven-ant-tasks.url"
value="https://repo.maven.apache.org/maven2/org/apache/maven/maven-ant-tasks" />
<!-- details of how and which Maven repository we publish to -->
@@ -241,7 +242,7 @@
@@ -246,7 +247,7 @@
</path>
<path id="cassandra.classpath.test">
<file file="${build.dir}/${final.name}.jar"/> <!-- we need the jar for tests and benchmarks (multi-version jar) -->
@ -34,15 +34,7 @@
<include name="**/*.jar" />
<exclude name="**/*-sources.jar"/>
<exclude name="**/ant-*.jar"/>
@@ -262,6 +263,7 @@
bottom="Copyright &amp;copy; 2009-2020 The Apache Software Foundation"
useexternalfile="yes" encoding="UTF-8"
maxmemory="256m">
+ <arg value="${jdk11-javac-exports}"/>
<filesets/>
</javadoc>
</sequential>
@@ -379,8 +381,7 @@
@@ -391,8 +392,7 @@
<artifact:dependencies pathId="wikitext.classpath">
<dependency groupId="com.datastax.wikitext" artifactId="wikitext-core-ant" version="1.3"/>
<dependency groupId="org.fusesource.wikitext" artifactId="textile-core" version="1.3"/>
@ -52,7 +44,7 @@
</artifact:dependencies>
<taskdef classpathref="wikitext.classpath" resource="wikitexttasks.properties" />
<wikitext-to-html markupLanguage="Textile">
@@ -393,6 +394,8 @@
@@ -405,6 +405,8 @@
<target name="gen-doc" depends="maven-ant-tasks-init" description="Generate documentation" unless="ant.gen-doc.skip">
<exec executable="make" osfamily="unix" dir="${doc.dir}">
<arg value="html"/>
@ -61,7 +53,7 @@
</exec>
<exec executable="cmd" osfamily="dos" dir="${doc.dir}">
<arg value="/c"/>
@@ -435,10 +438,6 @@
@@ -447,10 +449,6 @@
description="Initialize Maven ANT Tasks">
<typedef uri="antlib:org.apache.maven.artifact.ant" classpathref="maven-ant-tasks.classpath" />
@ -72,7 +64,7 @@
<macrodef name="install">
<attribute name="pomFile"/>
<attribute name="file"/>
@@ -842,16 +841,14 @@
@@ -865,16 +863,14 @@
filesetId="build-dependency-jars"
cacheDependencyRefs="true"
dependencyRefsBuildFile="${build.dir}/build-dependencies.xml">
@ -91,7 +83,7 @@
</artifact:dependencies>
<copy todir="${build.dir.lib}/jars">
<fileset refid="build-dependency-jars"/>
@@ -864,7 +861,7 @@
@@ -887,7 +883,7 @@
<!-- code coverage tools -->
<artifact:dependencies pomRefId="coverage-deps-pom"
filesetId="coverage-dependency-jars">
@ -100,7 +92,7 @@
</artifact:dependencies>
<copy todir="${build.dir.lib}/jars">
<fileset refid="coverage-dependency-jars"/>
@@ -893,8 +890,7 @@
@@ -916,8 +912,7 @@
sourcesFilesetId="test-dependency-sources"
cacheDependencyRefs="true"
dependencyRefsBuildFile="${build.dir}/test-dependencies.xml">
@ -110,7 +102,7 @@
</artifact:dependencies>
<copy todir="${test.lib}/jars">
<fileset refid="test-dependency-jars"/>
@@ -1217,6 +1213,86 @@
@@ -1227,6 +1222,87 @@
</copy>
</target>
@ -150,6 +142,7 @@
+ <fileset dir="pylib">
+ <include name="**" />
+ <exclude name="**/*.pyc" />
+ <exclude name="Dockerfile.ubuntu.*" />
+ </fileset>
+ </copy>
+ <copy todir="${dist.dir}/">
@ -197,7 +190,15 @@
<!-- creates release tarballs -->
<target name="artifacts" depends="_artifacts-init"
description="Create Cassandra release artifacts">
@@ -1923,8 +1999,8 @@
@@ -1347,6 +1423,7 @@
<target name="_build-test">
<javac
fork="true"
+ memorymaximumsize="512M"
compiler="modern"
debug="true"
debuglevel="${debuglevel}"
@@ -1938,8 +2015,8 @@
<exec executable="nproc" outputproperty="cores.count" os="Linux,SunOS,Solaris" failifexecutionfails="false">
<arg value="--all"/>
</exec>
@ -208,7 +209,7 @@
<arg value="-n"/>
<arg value="hw.ncpu"/>
</exec>
@@ -1944,6 +2020,11 @@
@@ -1959,6 +2036,11 @@
<exec executable="sysctl" outputproperty="mem.size" os="Mac,Mac OS X,Darwin" failifexecutionfails="false">
<arg value="-n"/>
<arg value="hw.memsize"/>

View File

@ -1,6 +1,6 @@
--- conf/cassandra.yaml.orig 2020-01-30 17:34:31 UTC
--- conf/cassandra.yaml.orig 2020-07-17 21:24:30 UTC
+++ conf/cassandra.yaml
@@ -76,7 +76,7 @@ max_hints_delivery_threads: 2
@@ -73,7 +73,7 @@ max_hints_delivery_threads: 2
# Directory where Cassandra should store hints.
# If not set, the default directory is $CASSANDRA_HOME/data/hints.
@ -9,7 +9,7 @@
# How often hints should be flushed from the internal buffers to disk.
# Will *not* trigger fsync.
@@ -203,13 +203,13 @@ partitioner: org.apache.cassandra.dht.Murmur3Partition
@@ -200,13 +200,13 @@ partitioner: org.apache.cassandra.dht.Murmur3Partition
# directories are specified, Cassandra will spread data evenly across
# them by partitioning the token ranges.
# If not set, the default directory is $CASSANDRA_HOME/data/data.
@ -26,7 +26,7 @@
# Enable / disable CDC functionality on a per-node basis. This modifies the logic used
# for write path allocation rejection (standard: never reject. cdc: reject Mutation
@@ -220,7 +220,7 @@ cdc_enabled: false
@@ -217,7 +217,7 @@ cdc_enabled: false
# segment contains mutations for a CDC-enabled table. This should be placed on a
# separate spindle than the data directories. If not set, the default directory is
# $CASSANDRA_HOME/data/cdc_raw.
@ -35,7 +35,7 @@
# Policy for data disk failures:
#
@@ -312,20 +312,12 @@ key_cache_save_period: 14400
@@ -309,20 +309,12 @@ key_cache_save_period: 14400
# Row cache implementation class name. Available implementations:
#
@ -57,7 +57,7 @@
#
# Default value is 0, to disable row caching.
row_cache_size_in_mb: 0
@@ -372,7 +364,7 @@ counter_cache_save_period: 7200
@@ -369,7 +361,7 @@ counter_cache_save_period: 7200
# saved caches
# If not set, the default directory is $CASSANDRA_HOME/data/saved_caches.

View File

@ -1,6 +1,6 @@
--- src/java/org/apache/cassandra/service/StartupChecks.java.orig 2020-01-30 17:34:32 UTC
--- src/java/org/apache/cassandra/service/StartupChecks.java.orig 2020-07-17 21:24:30 UTC
+++ src/java/org/apache/cassandra/service/StartupChecks.java
@@ -262,7 +262,14 @@ public class StartupChecks
@@ -276,7 +276,14 @@ public class StartupChecks
{
public void execute()
{

View File

@ -16,8 +16,8 @@
%%DATADIR%%/lib/apache-cassandra-%%DISTVERSION%%.jar
%%DATADIR%%/lib/asm-7.1.jar
%%DATADIR%%/lib/caffeine-2.3.5.jar
%%DATADIR%%/lib/cassandra-driver-core-3.6.0-shaded.jar
%%DATADIR%%/lib/cassandra-driver-internal-only-3.21.0.post0-05fb2c8d.zip
%%DATADIR%%/lib/cassandra-driver-core-3.9.0-shaded.jar
%%DATADIR%%/lib/cassandra-driver-internal-only-3.23.0.post0-1a184b99.zip
%%DATADIR%%/lib/chronicle-bytes-1.16.3.jar
%%DATADIR%%/lib/chronicle-core-1.16.4.jar
%%DATADIR%%/lib/chronicle-queue-4.16.3.jar
@ -36,9 +36,9 @@
%%DATADIR%%/lib/high-scale-lib-1.0.6.jar
%%DATADIR%%/lib/hppc-0.8.1.jar
%%DATADIR%%/lib/j2objc-annotations-1.3.jar
%%DATADIR%%/lib/jackson-annotations-2.9.5.jar
%%DATADIR%%/lib/jackson-core-2.9.5.jar
%%DATADIR%%/lib/jackson-databind-2.9.5.jar
%%DATADIR%%/lib/jackson-annotations-2.9.10.jar
%%DATADIR%%/lib/jackson-core-2.9.10.jar
%%DATADIR%%/lib/jackson-databind-2.9.10.4.jar
%%DATADIR%%/lib/jamm-0.3.2.jar
%%DATADIR%%/lib/javax.inject.jar
%%DATADIR%%/lib/jbcrypt-0.3m.jar
@ -95,7 +95,7 @@
%%DATADIR%%/lib/licenses/metrics-core-3.1.5.txt
%%DATADIR%%/lib/licenses/metrics-jvm-3.1.5.txt
%%DATADIR%%/lib/licenses/metrics-logback-3.1.5.txt
%%DATADIR%%/lib/licenses/netty-tcnative-2.0.25.txt
%%DATADIR%%/lib/licenses/netty-tcnative-2.0.31.txt
%%DATADIR%%/lib/licenses/psjava-0.1.19.txt
%%DATADIR%%/lib/licenses/reporter-config-base-3.0.3.txt
%%DATADIR%%/lib/licenses/reporter-config3-3.0.3.txt
@ -114,7 +114,7 @@
%%DATADIR%%/lib/metrics-logback-3.1.5.jar
%%DATADIR%%/lib/mxdump-0.14.jar
%%DATADIR%%/lib/netty.jar
%%DATADIR%%/lib/netty-tcnative-boringssl-static-2.0.25.Final.jar
%%DATADIR%%/lib/netty-tcnative-boringssl-static-2.0.31.Final.jar
%%DATADIR%%/lib/psjava-0.1.19.jar
%%DATADIR%%/lib/reporter-config-base-3.0.3.jar
%%DATADIR%%/lib/reporter-config3-3.0.3.jar
@ -129,7 +129,8 @@
%%DATADIR%%/lib/snowball-stemmer-1.3.0.581.1.jar
%%DATADIR%%/lib/ST4-4.0.8.jar
%%DATADIR%%/lib/stream-2.5.2.jar
%%AMD64ONLY%%%%DATADIR%%/lib/zstd-jni-1.4.4-9-freebsd_amd64.jar
%%AMD64ONLY%%%%DATADIR%%/lib/zstd-jni-%%ZSTDJNI_VERSION%%-freebsd_amd64.jar
%%I386ONLY%%%%DATADIR%%/lib/zstd-jni-%%ZSTDJNI_VERSION%%-freebsd_i386.jar
%%DATADIR%%/LICENSE.txt
%%DATADIR%%/NEWS.txt
%%DATADIR%%/NOTICE.txt
@ -160,8 +161,6 @@
%%DATADIR%%/pylib/cqlshlib/tracing.py
%%DATADIR%%/pylib/cqlshlib/util.py
%%DATADIR%%/pylib/cqlshlib/wcwidth.py
%%DATADIR%%/pylib/Dockerfile.ubuntu.py2
%%DATADIR%%/pylib/Dockerfile.ubuntu.py3
%%DATADIR%%/pylib/README.asc
%%DATADIR%%/pylib/requirements.txt
%%DATADIR%%/pylib/setup.py