www/gitlab-ce: use grpc 1.42

Using grpc 1.43.2 shows error message:
time="2022-02-05T08:23:37.521Z" level=info msg="Assertion failed: (0), function upb_fielddef_type, file /wrkdirs/usr/ports/devel/grpc/work/grpc-1.43.2/third_party/upb/upb/def.c, line 407." supervisor.args="[bundle exec bin/ruby-cd /usr/local/www/gitlab-ce /usr/local/share/gitaly/ruby/bin/gitaly-ruby 2915 /usr/local/www/gitlab-ce/tmp/sockets/private/internal/ruby.1]" supervisor.name=gitaly-ruby.1
This commit is contained in:
Matthias Fechner 2022-02-05 08:44:22 +01:00
parent 1737af6ba4
commit f7529adec2
10 changed files with 397 additions and 4 deletions

View File

@ -935,6 +935,7 @@
SUBDIR += grpc
SUBDIR += grpc130
SUBDIR += grpc134
SUBDIR += grpc142
SUBDIR += grv
SUBDIR += gsettings-desktop-schemas
SUBDIR += gsoap

View File

@ -38,7 +38,7 @@ USE_LDCONFIG= yes
PLIST_SUB= SHLIB_MAJOR=${PORTVERSION:R} \
SHLIB_MINOR=${PORTVERSION:E}
CONFLICTS_INSTALL= grpc130 grpc134
CONFLICTS_INSTALL= grpc130 grpc134 grpc142
.include <bsd.port.pre.mk>

View File

@ -36,7 +36,7 @@ CMAKE_ON= BUILD_SHARED_LIBS
USE_LDCONFIG= yes
STRIP=
CONFLICTS_INSTALL= grpc grpc134
CONFLICTS_INSTALL= grpc grpc134 grpc142
PLIST_SUB= PORTVERSION=${PORTVERSION}

View File

@ -35,7 +35,7 @@ CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17 \
CMAKE_ON= BUILD_SHARED_LIBS
USE_LDCONFIG= yes
CONFLICTS_INSTALL= grpc grpc130
CONFLICTS_INSTALL= grpc grpc130 grpc142
PLIST_SUB= PORTVERSION=${PORTVERSION}

60
devel/grpc142/Makefile Normal file
View File

@ -0,0 +1,60 @@
# Created by: vanilla@
PORTNAME= grpc
PORTVERSION= 1.42.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
PKGNAMESUFFIX= 142
MAINTAINER= mfechner@FreeBSD.org
COMMENT= HTTP/2-based RPC framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libabsl_base.so:devel/abseil \
libbenchmark.so:devel/benchmark \
libcares.so:dns/c-ares \
libgflags.so:devel/gflags \
libprotobuf.so:devel/protobuf \
libre2.so:devel/re2
USES= cmake compiler:c++17-lang cpe localbase:ldflags pkgconfig ssl
USE_GITHUB= yes
CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17 \
-DgRPC_ABSL_PROVIDER=package \
-DgRPC_BENCHMARK_PROVIDER=package \
-DgRPC_CARES_PROVIDER=package \
-DgRPC_GFLAGS_PROVIDER=package \
-DgRPC_PROTOBUF_PROVIDER=package \
-DgRPC_RE2_PROVIDER=package \
-DgRPC_SSL_PROVIDER=package \
-DgRPC_ZLIB_PROVIDER=package
CMAKE_ON= BUILD_SHARED_LIBS
USE_LDCONFIG= yes
PLIST_SUB= SHLIB_MAJOR=${PORTVERSION:R} \
SHLIB_MINOR=${PORTVERSION:E}
CONFLICTS_INSTALL= grpc130 grpc134 grpc
.include <bsd.port.pre.mk>
# Remove openssl from grpc.pc because we do not ship openssl.pc in base system
.if ${SSL_DEFAULT} == base
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
.endif
post-patch:
# Clean up bundled libraries
@${RM} -r ${WRKSRC}/third_party/abseil-cpp/
@${RM} -r ${WRKSRC}/third_party/benchmark/
@${RM} -r ${WRKSRC}/third_party/boringssl-with-bazel/
@${RM} -r ${WRKSRC}/third_party/cares/
@${RM} -r ${WRKSRC}/third_party/protobuf/
@${RM} -r ${WRKSRC}/third_party/re2/
@${RM} -r ${WRKSRC}/third_party/zlib/
.include <bsd.port.post.mk>

3
devel/grpc142/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1644045994
SHA256 (grpc-grpc-v1.42.0_GH0.tar.gz) = b2f2620c762427bfeeef96a68c1924319f384e877bc0e084487601e4cc6e434c
SIZE (grpc-grpc-v1.42.0_GH0.tar.gz) = 8460322

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2021-11-16 23:39:48 UTC
+++ CMakeLists.txt
@@ -17280,7 +17280,7 @@ generate_pkgconfig(
"gRPC"
"high performance general RPC framework"
"${gRPC_CORE_VERSION}"
- "gpr openssl absl_base absl_bind_front absl_cord absl_core_headers absl_flat_hash_map absl_hash absl_inlined_vector absl_memory absl_optional absl_status absl_statusor absl_str_format absl_strings absl_synchronization absl_time absl_utility absl_variant"
+ "gpr absl_base absl_bind_front absl_cord absl_core_headers absl_flat_hash_map absl_hash absl_inlined_vector absl_memory absl_optional absl_status absl_statusor absl_str_format absl_strings absl_synchronization absl_time absl_utility absl_variant"
"-lgrpc -laddress_sorting -lre2 -lupb -lcares -lz"
""
"grpc.pc")

6
devel/grpc142/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
gRPC is a modern, open source, high-performance remote procedure call (RPC)
framework that can run anywhere, enables client and server applications to
communicate transparently, and simplifies the building of connected systems.
WWW: https://grpc.io/
WWW: https://github.com/grpc/grpc

311
devel/grpc142/pkg-plist Normal file
View File

@ -0,0 +1,311 @@
bin/grpc_cpp_plugin
bin/grpc_csharp_plugin
bin/grpc_node_plugin
bin/grpc_objective_c_plugin
bin/grpc_php_plugin
bin/grpc_python_plugin
bin/grpc_ruby_plugin
include/grpc++/alarm.h
include/grpc++/channel.h
include/grpc++/client_context.h
include/grpc++/completion_queue.h
include/grpc++/create_channel.h
include/grpc++/create_channel_posix.h
include/grpc++/ext/health_check_service_server_builder_option.h
include/grpc++/ext/proto_server_reflection_plugin.h
include/grpc++/generic/async_generic_service.h
include/grpc++/generic/generic_stub.h
include/grpc++/grpc++.h
include/grpc++/health_check_service_interface.h
include/grpc++/impl/call.h
include/grpc++/impl/channel_argument_option.h
include/grpc++/impl/client_unary_call.h
include/grpc++/impl/codegen/async_stream.h
include/grpc++/impl/codegen/async_unary_call.h
include/grpc++/impl/codegen/byte_buffer.h
include/grpc++/impl/codegen/call.h
include/grpc++/impl/codegen/call_hook.h
include/grpc++/impl/codegen/channel_interface.h
include/grpc++/impl/codegen/client_context.h
include/grpc++/impl/codegen/client_unary_call.h
include/grpc++/impl/codegen/completion_queue.h
include/grpc++/impl/codegen/completion_queue_tag.h
include/grpc++/impl/codegen/config.h
include/grpc++/impl/codegen/config_protobuf.h
include/grpc++/impl/codegen/core_codegen.h
include/grpc++/impl/codegen/core_codegen_interface.h
include/grpc++/impl/codegen/create_auth_context.h
include/grpc++/impl/codegen/grpc_library.h
include/grpc++/impl/codegen/metadata_map.h
include/grpc++/impl/codegen/method_handler_impl.h
include/grpc++/impl/codegen/proto_utils.h
include/grpc++/impl/codegen/rpc_method.h
include/grpc++/impl/codegen/rpc_service_method.h
include/grpc++/impl/codegen/security/auth_context.h
include/grpc++/impl/codegen/serialization_traits.h
include/grpc++/impl/codegen/server_context.h
include/grpc++/impl/codegen/server_interface.h
include/grpc++/impl/codegen/service_type.h
include/grpc++/impl/codegen/slice.h
include/grpc++/impl/codegen/status.h
include/grpc++/impl/codegen/status_code_enum.h
include/grpc++/impl/codegen/string_ref.h
include/grpc++/impl/codegen/stub_options.h
include/grpc++/impl/codegen/sync_stream.h
include/grpc++/impl/codegen/time.h
include/grpc++/impl/grpc_library.h
include/grpc++/impl/method_handler_impl.h
include/grpc++/impl/rpc_method.h
include/grpc++/impl/rpc_service_method.h
include/grpc++/impl/serialization_traits.h
include/grpc++/impl/server_builder_option.h
include/grpc++/impl/server_builder_plugin.h
include/grpc++/impl/server_initializer.h
include/grpc++/impl/service_type.h
include/grpc++/resource_quota.h
include/grpc++/security/auth_context.h
include/grpc++/security/auth_metadata_processor.h
include/grpc++/security/credentials.h
include/grpc++/security/server_credentials.h
include/grpc++/server.h
include/grpc++/server_builder.h
include/grpc++/server_context.h
include/grpc++/server_posix.h
include/grpc++/support/async_stream.h
include/grpc++/support/async_unary_call.h
include/grpc++/support/byte_buffer.h
include/grpc++/support/channel_arguments.h
include/grpc++/support/config.h
include/grpc++/support/error_details.h
include/grpc++/support/slice.h
include/grpc++/support/status.h
include/grpc++/support/status_code_enum.h
include/grpc++/support/string_ref.h
include/grpc++/support/stub_options.h
include/grpc++/support/sync_stream.h
include/grpc++/support/time.h
include/grpc/byte_buffer.h
include/grpc/byte_buffer_reader.h
include/grpc/census.h
include/grpc/compression.h
include/grpc/event_engine/endpoint_config.h
include/grpc/event_engine/event_engine.h
include/grpc/event_engine/internal/memory_allocator_impl.h
include/grpc/event_engine/memory_allocator.h
include/grpc/event_engine/port.h
include/grpc/fork.h
include/grpc/grpc.h
include/grpc/grpc_posix.h
include/grpc/grpc_security.h
include/grpc/grpc_security_constants.h
include/grpc/impl/codegen/atm.h
include/grpc/impl/codegen/atm_gcc_atomic.h
include/grpc/impl/codegen/atm_gcc_sync.h
include/grpc/impl/codegen/atm_windows.h
include/grpc/impl/codegen/byte_buffer.h
include/grpc/impl/codegen/byte_buffer_reader.h
include/grpc/impl/codegen/compression_types.h
include/grpc/impl/codegen/connectivity_state.h
include/grpc/impl/codegen/fork.h
include/grpc/impl/codegen/gpr_slice.h
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/grpc_types.h
include/grpc/impl/codegen/log.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/propagation_bits.h
include/grpc/impl/codegen/slice.h
include/grpc/impl/codegen/status.h
include/grpc/impl/codegen/sync.h
include/grpc/impl/codegen/sync_abseil.h
include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
include/grpc/load_reporting.h
include/grpc/slice.h
include/grpc/slice_buffer.h
include/grpc/status.h
include/grpc/support/alloc.h
include/grpc/support/atm.h
include/grpc/support/atm_gcc_atomic.h
include/grpc/support/atm_gcc_sync.h
include/grpc/support/atm_windows.h
include/grpc/support/cpu.h
include/grpc/support/log.h
include/grpc/support/log_windows.h
include/grpc/support/port_platform.h
include/grpc/support/string_util.h
include/grpc/support/sync.h
include/grpc/support/sync_abseil.h
include/grpc/support/sync_custom.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
include/grpc/support/sync_windows.h
include/grpc/support/thd_id.h
include/grpc/support/time.h
include/grpc/support/workaround_list.h
include/grpcpp/alarm.h
include/grpcpp/channel.h
include/grpcpp/client_context.h
include/grpcpp/completion_queue.h
include/grpcpp/create_channel.h
include/grpcpp/create_channel_binder.h
include/grpcpp/create_channel_posix.h
include/grpcpp/ext/channelz_service_plugin.h
include/grpcpp/ext/health_check_service_server_builder_option.h
include/grpcpp/ext/proto_server_reflection_plugin.h
include/grpcpp/generic/async_generic_service.h
include/grpcpp/generic/generic_stub.h
include/grpcpp/grpcpp.h
include/grpcpp/health_check_service_interface.h
include/grpcpp/impl/call.h
include/grpcpp/impl/channel_argument_option.h
include/grpcpp/impl/client_unary_call.h
include/grpcpp/impl/codegen/async_generic_service.h
include/grpcpp/impl/codegen/async_stream.h
include/grpcpp/impl/codegen/async_unary_call.h
include/grpcpp/impl/codegen/byte_buffer.h
include/grpcpp/impl/codegen/call.h
include/grpcpp/impl/codegen/call_hook.h
include/grpcpp/impl/codegen/call_op_set.h
include/grpcpp/impl/codegen/call_op_set_interface.h
include/grpcpp/impl/codegen/callback_common.h
include/grpcpp/impl/codegen/channel_interface.h
include/grpcpp/impl/codegen/client_callback.h
include/grpcpp/impl/codegen/client_context.h
include/grpcpp/impl/codegen/client_interceptor.h
include/grpcpp/impl/codegen/client_unary_call.h
include/grpcpp/impl/codegen/completion_queue.h
include/grpcpp/impl/codegen/completion_queue_tag.h
include/grpcpp/impl/codegen/config.h
include/grpcpp/impl/codegen/config_protobuf.h
include/grpcpp/impl/codegen/core_codegen.h
include/grpcpp/impl/codegen/core_codegen_interface.h
include/grpcpp/impl/codegen/create_auth_context.h
include/grpcpp/impl/codegen/delegating_channel.h
include/grpcpp/impl/codegen/grpc_library.h
include/grpcpp/impl/codegen/intercepted_channel.h
include/grpcpp/impl/codegen/interceptor.h
include/grpcpp/impl/codegen/interceptor_common.h
include/grpcpp/impl/codegen/message_allocator.h
include/grpcpp/impl/codegen/metadata_map.h
include/grpcpp/impl/codegen/method_handler.h
include/grpcpp/impl/codegen/method_handler_impl.h
include/grpcpp/impl/codegen/proto_buffer_reader.h
include/grpcpp/impl/codegen/proto_buffer_writer.h
include/grpcpp/impl/codegen/proto_utils.h
include/grpcpp/impl/codegen/rpc_method.h
include/grpcpp/impl/codegen/rpc_service_method.h
include/grpcpp/impl/codegen/security/auth_context.h
include/grpcpp/impl/codegen/serialization_traits.h
include/grpcpp/impl/codegen/server_callback.h
include/grpcpp/impl/codegen/server_callback_handlers.h
include/grpcpp/impl/codegen/server_context.h
include/grpcpp/impl/codegen/server_interceptor.h
include/grpcpp/impl/codegen/server_interface.h
include/grpcpp/impl/codegen/service_type.h
include/grpcpp/impl/codegen/slice.h
include/grpcpp/impl/codegen/status.h
include/grpcpp/impl/codegen/status_code_enum.h
include/grpcpp/impl/codegen/string_ref.h
include/grpcpp/impl/codegen/stub_options.h
include/grpcpp/impl/codegen/sync.h
include/grpcpp/impl/codegen/sync_stream.h
include/grpcpp/impl/codegen/time.h
include/grpcpp/impl/grpc_library.h
include/grpcpp/impl/method_handler_impl.h
include/grpcpp/impl/rpc_method.h
include/grpcpp/impl/rpc_service_method.h
include/grpcpp/impl/serialization_traits.h
include/grpcpp/impl/server_builder_option.h
include/grpcpp/impl/server_builder_plugin.h
include/grpcpp/impl/server_initializer.h
include/grpcpp/impl/service_type.h
include/grpcpp/resource_quota.h
include/grpcpp/security/alts_context.h
include/grpcpp/security/alts_util.h
include/grpcpp/security/auth_context.h
include/grpcpp/security/auth_metadata_processor.h
include/grpcpp/security/authorization_policy_provider.h
include/grpcpp/security/binder_credentials.h
include/grpcpp/security/binder_security_policy.h
include/grpcpp/security/credentials.h
include/grpcpp/security/server_credentials.h
include/grpcpp/security/tls_certificate_provider.h
include/grpcpp/security/tls_credentials_options.h
include/grpcpp/server.h
include/grpcpp/server_builder.h
include/grpcpp/server_context.h
include/grpcpp/server_posix.h
include/grpcpp/support/async_stream.h
include/grpcpp/support/async_unary_call.h
include/grpcpp/support/byte_buffer.h
include/grpcpp/support/channel_arguments.h
include/grpcpp/support/client_callback.h
include/grpcpp/support/client_interceptor.h
include/grpcpp/support/config.h
include/grpcpp/support/error_details.h
include/grpcpp/support/interceptor.h
include/grpcpp/support/message_allocator.h
include/grpcpp/support/method_handler.h
include/grpcpp/support/proto_buffer_reader.h
include/grpcpp/support/proto_buffer_writer.h
include/grpcpp/support/server_callback.h
include/grpcpp/support/server_interceptor.h
include/grpcpp/support/slice.h
include/grpcpp/support/status.h
include/grpcpp/support/status_code_enum.h
include/grpcpp/support/string_ref.h
include/grpcpp/support/stub_options.h
include/grpcpp/support/sync_stream.h
include/grpcpp/support/time.h
include/grpcpp/support/validate_service_config.h
include/grpcpp/xds_server_builder.h
lib/cmake/grpc/gRPCConfig.cmake
lib/cmake/grpc/gRPCConfigVersion.cmake
lib/cmake/grpc/gRPCTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/grpc/gRPCTargets.cmake
lib/cmake/grpc/modules/Findc-ares.cmake
lib/cmake/grpc/modules/Findre2.cmake
lib/libaddress_sorting.so
lib/libaddress_sorting.so.20
lib/libaddress_sorting.so.20.0.0
lib/libgpr.so
lib/libgpr.so.20
lib/libgpr.so.20.0.0
lib/libgrpc++.so
lib/libgrpc++.so.%%SHLIB_MAJOR%%
lib/libgrpc++.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc++_alts.so
lib/libgrpc++_alts.so.%%SHLIB_MAJOR%%
lib/libgrpc++_alts.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc++_error_details.so
lib/libgrpc++_error_details.so.%%SHLIB_MAJOR%%
lib/libgrpc++_error_details.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc++_reflection.so
lib/libgrpc++_reflection.so.%%SHLIB_MAJOR%%
lib/libgrpc++_reflection.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc++_unsecure.so
lib/libgrpc++_unsecure.so.%%SHLIB_MAJOR%%
lib/libgrpc++_unsecure.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc.so
lib/libgrpc.so.20
lib/libgrpc.so.20.0.0
lib/libgrpc_plugin_support.so
lib/libgrpc_plugin_support.so.%%SHLIB_MAJOR%%
lib/libgrpc_plugin_support.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc_unsecure.so
lib/libgrpc_unsecure.so.20
lib/libgrpc_unsecure.so.20.0.0
lib/libgrpcpp_channelz.so
lib/libgrpcpp_channelz.so.%%SHLIB_MAJOR%%
lib/libgrpcpp_channelz.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libupb.so
lib/libupb.so.20
lib/libupb.so.20.0.0
libdata/pkgconfig/gpr.pc
libdata/pkgconfig/grpc++.pc
libdata/pkgconfig/grpc++_unsecure.pc
libdata/pkgconfig/grpc.pc
libdata/pkgconfig/grpc_unsecure.pc
%%DATADIR%%/roots.pem

View File

@ -1,5 +1,6 @@
PORTNAME= grpc
PORTVERSION= 1.42.0
PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= 142
@ -10,7 +11,7 @@ COMMENT= Ruby implementation of gRPC
LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:dns/c-ares \
libgrpc.so:devel/grpc
libgrpc.so:devel/grpc142
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
rubygem-google-protobuf>=3.19<4:devel/rubygem-google-protobuf \
rubygem-googleapis-common-protos-types>=1.0<2:devel/rubygem-googleapis-common-protos-types