- Update to 0.99.

PR:		ports/138188
Submitted by:	Sylvio Cesar <scjamorim___bsd.com.br>
Approved by:	Michael Schout <mschout___gkg.net> (maintainer)
This commit is contained in:
Marcelo Araujo 2009-08-27 13:07:04 +00:00
parent c7713c49dd
commit f7478f8b37
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=240400
4 changed files with 13 additions and 37 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= pam_pwdfile
PORTVERSION= 0.95
PORTREVISION= 1
PORTVERSION= 0.99
CATEGORIES= security
MASTER_SITES= http://cpbotha.net/files/pam_pwdfile/
@ -16,11 +15,18 @@ COMMENT= A pam module for authenticating with flat passwd files
MAKEFILE= ${FILESDIR}/Makefile.bsd
PLIST_FILES= lib/pam_pwdfile.so
PORTDOCS= README INSTALL changelog
post-patch:
${REINPLACE_CMD} -e 's|#include <features.h>||g' ${WRKSRC}/pam_pwdfile.c
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/changelog \
${WRKSRC}/INSTALL ${DOCSDIR}
.for docs in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (pam_pwdfile-0.95.tar.gz) = 1eb2d29567f54c5b5eb482bb0ed9538f
SHA256 (pam_pwdfile-0.95.tar.gz) = 0ff679e65f7136187e355f0d148387b7afe20006fe6c851be98a92cf5997f642
SIZE (pam_pwdfile-0.95.tar.gz) = 7385
MD5 (pam_pwdfile-0.99.tar.gz) = a05b41f0bd1c0de16bec8aad6b1b30a9
SHA256 (pam_pwdfile-0.99.tar.gz) = 973420f203976ac98508bb253b33a23d189cfbaf72143670964470e84085688e
SIZE (pam_pwdfile-0.99.tar.gz) = 16994

View File

@ -1,25 +0,0 @@
--- pam_pwdfile.c.orig Sat Jul 14 23:50:21 2001
+++ pam_pwdfile.c Fri Nov 8 11:25:49 2002
@@ -42,7 +42,6 @@
* OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <features.h>
#include <syslog.h>
#include <stdarg.h>
#include <stdio.h>
@@ -85,10 +84,14 @@
va_list args;
va_start(args, format);
+#ifndef __FreeBSD__
openlog("pam_pwdfile", LOG_CONS|LOG_PID, LOG_AUTH);
+#endif
vsyslog(err, format, args);
va_end(args);
+#ifndef __FreeBSD__
closelog();
+#endif
}
static int lock_fd(int fd) {

View File

@ -1,5 +0,0 @@
%%PORTDOCS%%share/doc/pam_pwdfile/README
%%PORTDOCS%%share/doc/pam_pwdfile/INSTALL
%%PORTDOCS%%share/doc/pam_pwdfile/changelog
%%PORTDOCS%%@dirrm share/doc/pam_pwdfile
lib/pam_pwdfile.so