- Fix build on 4-x alpha
PR: ports/64362 Submitted by: maintainer
This commit is contained in:
parent
279b014f86
commit
f728044365
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104268
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= cppadvio
|
||||
PORTVERSION= 2.6
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel net
|
||||
MASTER_SITES= http://okmij.org/ftp/packages/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
@ -23,10 +23,6 @@ USE_GCC= 2.95
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
|
||||
BROKEN= "Does not compile on alpha 4.x"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@( cd ${WRKSRC}; ${MV} c++ c++.orig; \
|
||||
${SED} -e 's|^ *gcc|${CXX} ${CXXFLAGS}|' c++.orig > c++; ${CHMOD} +x c++ )
|
||||
|
11
devel/cppadvio/files/patch-TCPstream.cc
Normal file
11
devel/cppadvio/files/patch-TCPstream.cc
Normal file
@ -0,0 +1,11 @@
|
||||
--- TCPstream.cc.orig Wed Mar 17 10:34:32 2004
|
||||
+++ TCPstream.cc Wed Mar 17 10:34:50 2004
|
||||
@@ -44,7 +44,7 @@
|
||||
{
|
||||
// Convertion between the host and the network
|
||||
// byte orders
|
||||
-#if !defined(htons) && !defined(linux)
|
||||
+#if !defined(htons) && !defined(linux) && !defined(_MACHINE_ENDIAN_H_)
|
||||
unsigned short htons(unsigned int data); // For a short data item
|
||||
unsigned short ntohs(unsigned int data); // For a short data item
|
||||
unsigned long htonl(unsigned long data); // For a long data item
|
Loading…
Reference in New Issue
Block a user