- Support CC/CFLAGS/MAKE properly

- Support install macros
- Fix install error

PR:		26557
Submitted by:	tkato@prontomail.ne.jp
This commit is contained in:
Ying-Chieh Liao 2001-04-14 11:43:16 +00:00
parent fd41396e56
commit f7268fcb56
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41370
2 changed files with 29 additions and 2 deletions

View File

@ -1,5 +1,5 @@
--- Makefile.orig Wed Feb 7 02:52:54 2001
+++ Makefile Sat Mar 31 03:10:38 2001
--- Makefile.orig Wed Feb 7 03:52:54 2001
+++ Makefile Sat Apr 14 02:34:58 2001
@@ -1,7 +1,4 @@
-PREFIX=/usr/local
-LOCALEDIR=/usr/share/locale
@ -20,3 +20,22 @@
all: chemtool cht
@@ -20,14 +17,14 @@
${CC} ${OBJS} ${SYS_LIBRARIES} -o chemtool
cht: src-cht/cht-1.3.c
- cd src-cht;make
+ cd src-cht;${MAKE}
.c.o:
${CC} ${CFLAGS} ${EXTRA_INCLUDES} -c ${SRCS}
install: chemtool src-cht/cht
- ${CP} chemtool src-cht/cht ${PREFIX}/bin
- ${CP} chemtool.1 ${PREFIX}/man/man1
- for L in `ls locales`; do ${CP} locales/$$L/chemtool.mo ${LOCALEDIR}/$$L/LC_MESSAGES;done
+ ${BSD_INSTALL_PROGRAM} chemtool src-cht/cht ${PREFIX}/bin
+ ${BSD_INSTALL_MAN} chemtool.1 ${PREFIX}/man/man1
+ for L in `ls locales`; do mkdir -p ${LOCALEDIR}/$$L/LC_MESSAGES; ${BSD_INSTALL_DATA} locales/$$L/chemtool.mo ${LOCALEDIR}/$$L/LC_MESSAGES;done
clean:
${RM} *.o *~ src-cht/*.o src-cht/*~ chemtool src-cht/cht

View File

@ -0,0 +1,8 @@
--- src-cht/Makefile.orig Wed Feb 7 03:38:54 2001
+++ src-cht/Makefile Sat Apr 14 02:13:38 2001
@@ -1,4 +1,4 @@
default: cht
cht: cht-1.3.c
- gcc -O cht-1.3.c -lm -o cht
+ ${CC} ${CFLAGS} cht-1.3.c -lm -o cht