Update to handle tk8.4.

PR:		ports/59620
Submitted by:	Jean-Sebastien Roy <js@jeannot.org> (maintainer)
This commit is contained in:
Mark Linimon 2003-12-09 02:22:27 +00:00
parent 5ed6c8fe60
commit f6ffc475db
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95444
6 changed files with 58 additions and 7 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= scilab
PORTVERSION= 2.7
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= math cad parallel
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Scilab/distributions/
EXTRACT_SUFX= .src.tar.gz
@ -19,9 +19,8 @@ LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d \
f77blas.1:${PORTSDIR}/math/atlas \
lapack.3:${PORTSDIR}/math/lapack
BUILD_DEPENDS= pvm:${PORTSDIR}/net/pvm \
wish8.3:${PORTSDIR}/x11-toolkits/tk83
RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83 \
pvm:${PORTSDIR}/net/pvm
wish8.4:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS+= ${BUILD_DEPENDS}
PVM_ROOT= ${LOCALBASE}/lib/pvm
@ -32,9 +31,9 @@ USE_REINPLACE= yes
CONFIGURE_ARGS= --with-tk \
--with-tk-library=${LOCALBASE}/lib \
--with-tk-include=${LOCALBASE}/include/tk8.3 \
--with-tk-include=${LOCALBASE}/include/tk8.4 \
--with-tcl-library=${LOCALBASE}/lib \
--with-tcl-include=${LOCALBASE}/include/tcl8.3 \
--with-tcl-include=${LOCALBASE}/include/tcl8.4 \
--with-pvm-library=${LOCALBASE}/lib \
--with-pvm-include=${LOCALBASE}/include \
--with-xaw3d \

View File

@ -5,7 +5,7 @@
if TK_GetVar("isscipadinterp")=='0' then
TK_EvalStr("interp create scipad")
- TK_EvalStr("load {libtk8.3.so} Tk scipad")
+ TK_EvalStr("load {libtk83.so} Tk scipad")
+ TK_EvalStr("load {libtk84.so} Tk scipad")
TK_EvalStr("scipad eval {wm withdraw .}")
TK_EvalStr("scipad alias ScilabEval ScilabEval")
end

View File

@ -0,0 +1,11 @@
--- Makefile.incl.orig Sun Oct 19 19:20:40 2003
+++ Makefile.incl Sun Oct 19 19:20:51 2003
@@ -75,7 +75,7 @@
#####################
TK_INC_PATH = -I/usr/include
TCL_INC_PATH = -I/usr/include
-TCLTK_LIBS = -L/usr/lib -ltk8.3 -L/usr/lib -ltcl8.3 -ldl
+TCLTK_LIBS = -L/usr/lib -ltk8.4 -L/usr/lib -ltcl8.4 -ldl
#####################
# for WIN32 version

View File

@ -0,0 +1,11 @@
--- examples/callsci/callsciC++/config/Makefile.incl.orig Sun Oct 19 19:25:21 2003
+++ examples/callsci/callsciC++/config/Makefile.incl Sun Oct 19 19:25:33 2003
@@ -75,7 +75,7 @@
#####################
TK_INC_PATH = -I/usr/include
TCL_INC_PATH = -I/usr/include
-TCLTK_LIBS = -L/usr/lib -ltk8.3 -L/usr/lib -ltcl8.3 -ldl
+TCLTK_LIBS = -L/usr/lib -ltk8.4 -L/usr/lib -ltcl8.4 -ldl
#####################
# for WIN32 version

View File

@ -0,0 +1,18 @@
--- routines/graphics/Math.h.orig Sun Nov 23 20:22:11 2003
+++ routines/graphics/Math.h Sun Nov 23 20:22:10 2003
@@ -88,11 +88,15 @@
#if defined(THINK_C)|| defined(WIN32)
#define M_PI 3.14159265358979323846
#else
+#if defined(HAVE_LIMITS_H)
+#include <limits.h>
+#else
#if defined(HAVE_VALUES_H)
#include <values.h>
#else
#ifndef M_PI
#define M_PI 3.14159265358979323846
+#endif
#endif
#endif
#endif

View File

@ -0,0 +1,12 @@
--- macros/util/help.sci.orig Sun Nov 23 21:13:37 2003
+++ macros/util/help.sci Sun Nov 23 21:11:24 2003
@@ -184,7 +184,8 @@
if MSDOS then
tcltk_help(path,key);
else
- unix(SCI+'/tcl/browsehelpexe ' +path+ '&');
+ tcltk_help(path,key);
+// unix(SCI+'/tcl/browsehelpexe ' +path+ '&');
end
else
write(%io(2),mgetl(path))