Update wemux port to include latest bug fixes from another forked version of

it. This new fork also adds manpages.

PR:		230014
This commit is contained in:
Carlo Strub 2018-10-11 11:33:30 +00:00
parent 15c90572a2
commit f6de35e398
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=481814
4 changed files with 16 additions and 87 deletions

View File

@ -4,8 +4,8 @@
PORTNAME= wemux
PORTVERSION= 3.2.0
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.c-s.li/ports/
MAINTAINER= cs@FreeBSD.org
COMMENT= Enhances tmux to make multi-user terminal multiplexing easier
@ -16,14 +16,20 @@ RUN_DEPENDS= tmux:sysutils/tmux \
bash:shells/bash
NO_BUILD= yes
USE_GITHUB= yes
GH_ACCOUNT= zolrath
GH_ACCOUNT= nbraud
GH_TAGNAME= 5de95ad531476773c5c58be48b8bd8bf322eef7e
post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${PORTNAME}
@${REINPLACE_CMD} -e 's|$$(SYSCONFDIR)|${ETCDIR}|g' ${WRKSRC}/wemux.in
@${REINPLACE_CMD} -e 's|$$(SYSCONFDIR)|${ETCDIR}|g' ${WRKSRC}/man/wemux.1.in
@${REINPLACE_CMD} -e 's|$$(SYSCONFDIR)|${DOCDIR}|g' ${WRKSRC}/man/wemux.1.in
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/wemux ${STAGEDIR}${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/wemux.conf.example ${STAGEDIR}${PREFIX}/etc/wemux.conf.example
${INSTALL_SCRIPT} ${WRKSRC}/wemux.in ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/wemux.conf.example ${STAGEDIR}${ETCDIR}/wemux.conf.example
${INSTALL_MAN} ${WRKSRC}/man/wemux.1.in ${STAGEDIR}${MANPREFIX}/man/man1/wemux.1
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1464784732
SHA256 (zolrath-wemux-v3.2.0_GH0.tar.gz) = 8de6607df116b86e2efddfe3740fc5eef002674e551668e5dde23e21b469b06c
SIZE (zolrath-wemux-v3.2.0_GH0.tar.gz) = 13359
TIMESTAMP = 1539251558
SHA256 (nbraud-wemux-v3.2.0-5de95ad531476773c5c58be48b8bd8bf322eef7e_GH0.tar.gz) = 2332688e159cbc8ee629c052c63420f1e6b5d1d841247b779652d3c177da6ee1
SIZE (nbraud-wemux-v3.2.0-5de95ad531476773c5c58be48b8bd8bf322eef7e_GH0.tar.gz) = 13838

View File

@ -1,78 +0,0 @@
--- wemux.orig 2014-03-13 23:47:09.000000000 +0100
+++ wemux 2014-03-13 23:49:01.000000000 +0100
@@ -9,8 +9,8 @@
# in another window (separate cursors) in the hosts tmux session.
#
# To set a user as host add their username to the host_list in the configuration
-# file located at /usr/local/etc/wemux.conf
-# Other configuations options are also located in /usr/local/etc/wemux.conf
+# file located at %%PREFIX%%/etc/wemux.conf
+# Other configuations options are also located in %%PREFIX%%/etc/wemux.conf
#
# For environments with multiple hosts running their own independent servers
# on the same machine wemux can join different servers with the wemux join
@@ -46,7 +46,7 @@
version="3.2.0"
# Setup and Configuration Files.
-# Default settings, modify them in the /usr/local/etc/wemux.conf file:
+# Default settings, modify them in the %%PREFIX%%/etc/wemux.conf file:
host_list=(change_this_in_wemux_conf)
socket_prefix="/tmp/wemux"
options="-u"
@@ -66,8 +66,8 @@
# Set $EDITOR default to vi if not configured on host machine.
editor=${EDITOR:="vi"}
-# Load configuration options from /usr/local/etc/wemux.conf
-[ -f /usr/local/etc/wemux.conf ] && . /usr/local/etc/wemux.conf
+# Load configuration options from %%PREFIX%%/etc/wemux.conf
+[ -f %%PREFIX%%/etc/wemux.conf ] && . %%PREFIX%%/etc/wemux.conf
# Sanitize server name, replace spaces and underscores with dashes.
# Remove all non alpha-numeric characters, convert to lowercase.
@@ -317,7 +317,7 @@
}
# Announce when user attaches/detaches from server.
-# Can be disabled by changing announce_attach to false in /usr/local/etc/wemux.conf
+# Can be disabled by changing announce_attach to false in %%PREFIX%%/etc/wemux.conf
# The first argument specifies the mode the user is attaching in for the message
# All additional arguments get wrapped in the attach/detach messages.
announce_connection() {
@@ -331,7 +331,7 @@
}
# Announces when a user joins/changes their server.
-# Can be disabled by changing announce_server_change to false in /usr/local/etc/wemux.conf
+# Can be disabled by changing announce_server_change to false in %%PREFIX%%/etc/wemux.conf
# Change server name for server, or display server name if no argument is given.
change_server() {
if [ "$allow_server_change" == "true" ]; then
@@ -373,7 +373,7 @@
echo "To check for a newer version visit: http://www.github.com/zolrath/wemux"
}
-# Host mode, used when user is listed in the host_list array in /usr/local/etc/wemux.conf
+# Host mode, used when user is listed in the host_list array in %%PREFIX%%/etc/wemux.conf
host_mode() {
# Start the server if it doesn't exist, otherwise reattach.
start_server() {
@@ -503,7 +503,7 @@
status_users) status_users;;
display_users) display_users;;
version|v) display_version;;
- conf*|c) $editor /usr/local/etc/wemux.conf;;
+ conf*|c) $editor %%PREFIX%%/etc/wemux.conf;;
*) if ! $wemux "$@"; then
echo "To see a list of wemux commands enter 'wemux help'"
exit 127
@@ -512,7 +512,7 @@
fi
}
-# Client Mode, used when user is NOT listed in the host_list in /usr/local/etc/wemux.conf
+# Client Mode, used when user is NOT listed in the host_list in %%PREFIX%%/etc/wemux.conf
client_mode() {
# Mirror mode, allows the user to view wemux server in read only mode.
mirror_mode() {

View File

@ -1,2 +1,3 @@
bin/wemux
@sample etc/wemux.conf.example etc/wemux.conf
@sample %%ETCDIR%%/wemux.conf.example %%ETCDIR%%/wemux.conf
man/man1/wemux.1.gz