- Copy graphics/ogre3d to graphics/ogre3d19 and add mutual conflicts
- Switch all ogre3d consumers to ogre3d19 This allows to update ogre3d to the latest version without breaking existing ports. The plans are also to make it possible for both ogre3d versions to coexist. Approved by: oliver (discussed via private email)
This commit is contained in:
parent
392cafaf3a
commit
f6c4ac8eb8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=500178
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= opendungeons
|
||||
PORTVERSION= 0.7.1
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
@ -23,7 +23,7 @@ LIB_DEPENDS= libboost_atomic.so:devel/boost-libs \
|
||||
libOIS.so:devel/ois \
|
||||
libsfml-audio.so:devel/sfml \
|
||||
libCEGUIBase-0.so:graphics/cegui \
|
||||
libOgreMain.so:graphics/ogre3d
|
||||
libOgreMain.so:graphics/ogre3d19
|
||||
|
||||
USES= cmake pkgconfig
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= stuntrally
|
||||
PORTVERSION= 2.6.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
@ -32,7 +33,7 @@ OPTIONS_SUB= yes
|
||||
|
||||
GAME_DESC= Build the game binary
|
||||
GAME_CMAKE_BOOL= BUILD_GAME
|
||||
GAME_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d \
|
||||
GAME_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19 \
|
||||
libBulletDynamics.so:devel/bullet \
|
||||
libMyGUIEngine.so:x11-toolkits/mygui \
|
||||
libogg.so:audio/libogg \
|
||||
@ -44,7 +45,7 @@ GAME_USES= openal
|
||||
|
||||
EDITOR_DESC= Build the track editor
|
||||
EDITOR_CMAKE_BOOL= BUILD_EDITOR
|
||||
EDITOR_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d \
|
||||
EDITOR_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19 \
|
||||
libBulletDynamics.so:devel/bullet \
|
||||
libMyGUIEngine.so:x11-toolkits/mygui \
|
||||
libogg.so:audio/libogg \
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= vegastrike
|
||||
PORTVERSION= 0.5.1.r1
|
||||
PORTREVISION= 15
|
||||
PORTREVISION= 16
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/
|
||||
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
|
||||
@ -53,7 +53,7 @@ OPTIONS_DEFINE= MESHER DOCS
|
||||
MESHER_DESC= Enable mesher modelling tool
|
||||
|
||||
MESHER_VARS= BIN_FILES+=bin/mesher
|
||||
MESHER_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
|
||||
MESHER_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19
|
||||
MESHER_CONFIGURE_ENABLE= ogre
|
||||
|
||||
post-patch:
|
||||
|
@ -579,6 +579,7 @@
|
||||
SUBDIR += ocrad
|
||||
SUBDIR += ocre
|
||||
SUBDIR += ogre3d
|
||||
SUBDIR += ogre3d19
|
||||
SUBDIR += oidn
|
||||
SUBDIR += okular
|
||||
SUBDIR += open3d
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= cegui
|
||||
PORTVERSION= 0.8.7
|
||||
PORTREVISION= 11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES= graphics devel
|
||||
MASTER_SITES= SF/crayzedsgui/CEGUI%20Mk-2/0.8
|
||||
|
||||
@ -84,7 +84,7 @@ SDL2_CMAKE_ON= -DCEGUI_BUILD_IMAGECODEC_SDL2=ON
|
||||
SDL2_CMAKE_OFF= -DCEGUI_BUILD_IMAGECODEC_SDL2=OFF
|
||||
|
||||
OGRE_DESC= Ogre3D support
|
||||
OGRE_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
|
||||
OGRE_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19
|
||||
OGRE_CMAKE_ON= -DCEGUI_BUILD_RENDERER_OGRE=ON
|
||||
OGRE_CMAKE_OFF= -DCEGUI_BUILD_RENDERER_OGRE=OFF
|
||||
IRRLICHT_DESC= Irrlicht support
|
||||
|
@ -18,6 +18,8 @@ LIB_DEPENDS= libzzip.so:devel/zziplib \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libfreeimage.so:graphics/freeimage
|
||||
|
||||
CONFLICTS= ogre3d19-[0-9]*
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USES= tar:bzip2 cmake pkgconfig compiler:c++11-lib
|
||||
USE_SDL= sdl
|
||||
|
62
graphics/ogre3d19/Makefile
Normal file
62
graphics/ogre3d19/Makefile
Normal file
@ -0,0 +1,62 @@
|
||||
# Created by: Oliver Lehmann <oliver@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ogre3d
|
||||
PORTVERSION= 1.9.0
|
||||
PORTREVISION= 18
|
||||
CATEGORIES= graphics devel
|
||||
MASTER_SITES= https://bitbucket.org/sinbad/ogre/get/
|
||||
DISTNAME= v1-9-0
|
||||
PKGNAMESUFFIX= 19
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Scene-oriented, flexible 3D engine written in C++
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libzzip.so:devel/zziplib \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libfreeimage.so:graphics/freeimage
|
||||
|
||||
CONFLICTS= ogre3d-[0-9]*
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USES= tar:bzip2 cmake pkgconfig compiler:c++11-lib
|
||||
USE_SDL= sdl
|
||||
USE_XORG= xaw xrandr
|
||||
WRKSRC= ${WRKDIR}/sinbad-ogre-dd30349ea667
|
||||
|
||||
OPTIONS_DEFINE= BOOST DOCS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
BOOST_BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
|
||||
BOOST_RUN_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
|
||||
|
||||
BROKEN_aarch64= does not compile: error: class member cannot be redeclared
|
||||
BROKEN_powerpc= does not install
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|include(FindPkgMacros)|return()|g' \
|
||||
${WRKSRC}/CMake/Packages/FindOIS.cmake \
|
||||
${WRKSRC}/CMake/Packages/FindPOCO.cmake \
|
||||
${WRKSRC}/CMake/Packages/FindTBB.cmake
|
||||
@${REINPLACE_CMD} -e 's|\(OGRE_RW_MUTEX[^;]*\)$$|\1;|g' \
|
||||
${WRKSRC}/OgreMain/include/OgreWorkQueue.h
|
||||
@${REINPLACE_CMD} -e 's|\(OGRE_RW_MUTEX.*\);$$|\1|g' \
|
||||
${WRKSRC}/OgreMain/include/Threading/OgreThreadDefinesBoost.h
|
||||
@${REINPLACE_CMD} -e '\
|
||||
s,defined(__x86_64__),& || defined(__powerpc__) || defined(__sparc64__) || defined(__amd64__),' \
|
||||
${WRKSRC}/OgreMain/include/OgrePlatform.h
|
||||
|
||||
post-patch-BOOST-off:
|
||||
@${REINPLACE_CMD} -e 's|Boost|No_Boost|g' \
|
||||
${WRKSRC}/CMake/Dependencies.cmake
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for docfile in README COPYING AUTHORS
|
||||
${INSTALL_DATA} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/ogre3d19/distinfo
Normal file
2
graphics/ogre3d19/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (v1-9-0.tar.bz2) = 3072df52b2bed2a1b52e969f140ae9a4373ec931029d3eaa032e7c609a91ef82
|
||||
SIZE (v1-9-0.tar.bz2) = 128098305
|
30
graphics/ogre3d19/files/patch-CMakeLists.txt
Normal file
30
graphics/ogre3d19/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,30 @@
|
||||
--- CMakeLists.txt.orig 2013-12-01 18:28:12.000000000 +0100
|
||||
+++ CMakeLists.txt 2014-03-11 21:56:26.000000000 +0100
|
||||
@@ -102,9 +102,9 @@
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse")
|
||||
endif ()
|
||||
# This is a set of sensible warnings that provide meaningful output
|
||||
- set(OGRE_WARNING_FLAGS "-Wall -Winit-self -Wno-overloaded-virtual -Wcast-qual -Wwrite-strings -Wextra -Wno-unused-parameter -Wshadow -Wno-missing-field-initializers -Wno-long-long")
|
||||
+ set(OGRE_WARNING_FLAGS "-Wall -Winit-self -Wno-overloaded-virtual -Wcast-qual -Wwrite-strings -Wno-unused-parameter -Wshadow -Wno-missing-field-initializers -Wno-long-long")
|
||||
if (NOT APPLE)
|
||||
- set(OGRE_WARNING_FLAGS "${OGRE_WARNING_FLAGS} -Wno-unused-but-set-parameter")
|
||||
+ set(OGRE_WARNING_FLAGS "${OGRE_WARNING_FLAGS}")
|
||||
endif ()
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OGRE_WARNING_FLAGS}")
|
||||
endif ()
|
||||
@@ -435,6 +435,7 @@
|
||||
option(OGRE_PROFILING "Enable internal profiling support." FALSE)
|
||||
cmake_dependent_option(OGRE_CONFIG_STATIC_LINK_CRT "Statically link the MS CRT dlls (msvcrt)" FALSE "MSVC" FALSE)
|
||||
set(OGRE_LIB_DIRECTORY "lib${LIB_SUFFIX}" CACHE STRING "Install path for libraries, e.g. 'lib64' on some 64-bit Linux distros.")
|
||||
+set(OGRE_LIBDATA_DIRECTORY "libdata" CACHE STRING "Install path for data files.")
|
||||
if (WIN32)
|
||||
option(OGRE_INSTALL_VSPROPS "Install Visual Studio Property Page." FALSE)
|
||||
if (OGRE_INSTALL_VSPROPS)
|
||||
@@ -477,6 +478,7 @@
|
||||
OGRE_PROFILING
|
||||
OGRE_CONFIG_STATIC_LINK_CRT
|
||||
OGRE_LIB_DIRECTORY
|
||||
+ OGRE_LIBDATA_DIRECTORY
|
||||
)
|
||||
|
||||
###################################################################
|
57
graphics/ogre3d19/files/patch-CMake_ConfigureBuild.cmake
Normal file
57
graphics/ogre3d19/files/patch-CMake_ConfigureBuild.cmake
Normal file
@ -0,0 +1,57 @@
|
||||
--- CMake/ConfigureBuild.cmake.orig 2013-04-16 03:54:30.000000000 +0200
|
||||
+++ CMake/ConfigureBuild.cmake 2013-08-12 14:32:35.000000000 +0200
|
||||
@@ -211,18 +211,18 @@
|
||||
else ()
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE.pc @ONLY)
|
||||
endif ()
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
|
||||
# configure additional packages
|
||||
|
||||
if (OGRE_BUILD_PLUGIN_PCZ)
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-PCZ.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-PCZ.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-PCZ.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-PCZ.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (OGRE_BUILD_COMPONENT_PAGING)
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-Paging.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Paging.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Paging.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Paging.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (OGRE_BUILD_COMPONENT_TERRAIN)
|
||||
@@ -230,27 +230,27 @@
|
||||
set(OGRE_PAGING_ADDITIONAL_PACKAGES ", OGRE-Paging = ${OGRE_VERSION}")
|
||||
endif ()
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-Terrain.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Terrain.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Terrain.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Terrain.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (OGRE_BUILD_COMPONENT_RTSHADERSYSTEM)
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-RTShaderSystem.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-RTShaderSystem.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-RTShaderSystem.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-RTShaderSystem.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (OGRE_BUILD_COMPONENT_PROPERTY)
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-Property.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Property.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Property.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Property.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (OGRE_BUILD_COMPONENT_OVERLAY)
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-Overlay.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Overlay.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Overlay.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Overlay.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (OGRE_BUILD_COMPONENT_VOLUME)
|
||||
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-Volume.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Volume.pc @ONLY)
|
||||
- install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Volume.pc DESTINATION ${OGRE_LIB_DIRECTORY}/pkgconfig)
|
||||
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Volume.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
|
||||
endif ()
|
||||
|
||||
if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
|
@ -0,0 +1,11 @@
|
||||
--- OgreMain/include/OgrePlatformInformation.h.orig 2013-12-01 18:28:12.000000000 +0100
|
||||
+++ OgreMain/include/OgrePlatformInformation.h 2014-06-15 21:59:18.000000000 +0200
|
||||
@@ -94,6 +94,7 @@
|
||||
OGRE_PLATFORM != OGRE_PLATFORM_NACL
|
||||
# define __OGRE_HAVE_SSE 1
|
||||
#elif OGRE_DOUBLE_PRECISION == 0 && OGRE_CPU == OGRE_CPU_X86 && (OGRE_COMPILER == OGRE_COMPILER_GNUC || OGRE_COMPILER == OGRE_COMPILER_CLANG) && \
|
||||
+ defined(__SSE__) && \
|
||||
OGRE_PLATFORM != OGRE_PLATFORM_APPLE_IOS && OGRE_PLATFORM != OGRE_PLATFORM_NACL
|
||||
# define __OGRE_HAVE_SSE 1
|
||||
#endif
|
||||
|
@ -0,0 +1,10 @@
|
||||
--- Tools/XMLConverter/CMakeLists.txt.orig 2013-04-16 03:54:34.000000000 +0200
|
||||
+++ Tools/XMLConverter/CMakeLists.txt 2013-08-12 14:34:48.000000000 +0200
|
||||
@@ -37,6 +37,7 @@
|
||||
set(TINYXML_LIBRARIES "")
|
||||
endif(NOT TINYXML_FOUND)
|
||||
|
||||
+set (CMAKE_INCLUDE_DIRECTORIES_BEFORE ON)
|
||||
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include ${TINYXML_INCLUDE_DIR})
|
||||
add_definitions(-DTIXML_USE_STL)
|
||||
ogre_add_executable(OgreXMLConverter ${HEADER_FILES} ${SOURCE_FILES})
|
8
graphics/ogre3d19/pkg-descr
Normal file
8
graphics/ogre3d19/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible
|
||||
3D engine written in C++ designed to make it easier and more intuitive for
|
||||
developers to produce games and demos utilising 3D hardware. The class library
|
||||
abstracts all the details of using the underlying system libraries like
|
||||
Direct3D and OpenGL and provides an interface based on world objects and other
|
||||
intuitive classes.
|
||||
|
||||
WWW: http://www.ogre3d.org/
|
1571
graphics/ogre3d19/pkg-plist
Normal file
1571
graphics/ogre3d19/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
@ -4,6 +4,7 @@
|
||||
PORTNAME= rigsofrods-caelum
|
||||
PORTVERSION= 0.6.3
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= monwarez@mailoo.org
|
||||
@ -12,7 +13,7 @@ COMMENT= OGRE plugin for atmospheric effects
|
||||
LICENSE= LGPL3+
|
||||
LICENSE_FILE= ${WRKSRC}/lgpl.txt
|
||||
|
||||
LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
|
||||
LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= RigsOfRods
|
||||
|
@ -4,6 +4,7 @@
|
||||
PORTNAME= rigsofrods-pagedgeometry
|
||||
PORTVERSION= 1.2.0
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= monwarez@mailoo.org
|
||||
@ -12,7 +13,7 @@ COMMENT= OGRE plugin for real-time dense forests
|
||||
LICENSE= ZLIB
|
||||
LICENSE_FILE= ${WRKSRC}/zlib.txt
|
||||
|
||||
LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
|
||||
LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= RigsOfRods
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= visp
|
||||
DISTVERSION= 3.2.0
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://gforge.inria.fr/frs/download.php/latestfile/475/
|
||||
|
||||
@ -37,6 +37,6 @@ OPTIONS_DEFINE= OGRE
|
||||
OGRE_DESC= Include Ogre support
|
||||
OGRE_CMAKE_BOOL= USE_OGRE
|
||||
OGRE_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
|
||||
libOgreMain.so:graphics/ogre3d
|
||||
libOgreMain.so:graphics/ogre3d19
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,14 +1,14 @@
|
||||
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
PKGNAMESUFFIX= -ogre
|
||||
|
||||
COMMENT= Ogre3d renderer for MyGUI
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../mygui
|
||||
|
||||
LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
|
||||
LIB_DEPENDS= libOgreMain.so:graphics/ogre3d19
|
||||
|
||||
MYGUI_RENDERSYSTEM= 3
|
||||
MYGUI_SUBDIR= Platforms/Ogre/OgrePlatform
|
||||
|
Loading…
Reference in New Issue
Block a user