- Repocopy and move graphics/gphoto to graphics/gphoto2

- Update graphics/gphoto2 to 2.0

PR:		35495
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
Repocopied by:	joe
Approved by:	portmgr
This commit is contained in:
Patrick Li 2002-03-08 00:37:10 +00:00
parent e4d8125f80
commit f683de923b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55699
31 changed files with 156 additions and 565 deletions

View File

@ -93,7 +93,7 @@
SUBDIR += gnomeiconedit
SUBDIR += gozer
SUBDIR += gpaint
SUBDIR += gphoto
SUBDIR += gphoto2
SUBDIR += gplot
SUBDIR += gqview
SUBDIR += gracula

View File

@ -1,33 +0,0 @@
# New ports collection makefile for: gphoto
# Date created: 26 May 1999
# Whom: Anders Nordby <anders@fix.no>
#
# $FreeBSD$
#
PORTNAME= gphoto
PORTVERSION= 0.4.3
CATEGORIES= graphics
MASTER_SITES= http://www.gphoto.net/dist/
MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_IMLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
MAN1= gphoto.1
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/gphoto
.for file in ChangeLog FAQ NEWS PROGRAMMERS README THANKS THEMES TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gphoto
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (gphoto-0.4.3.tar.gz) = 8b4e70df78870479d2d9a45c8f4db5f4

View File

@ -1,13 +0,0 @@
--- src/callbacks.c.orig Tue Mar 7 06:23:06 2000
+++ src/callbacks.c Thu Apr 20 03:00:00 2000
@@ -529,7 +529,9 @@
#ifdef linux
sprintf(serial_port_prefix, "/dev/ttyS");
-#elif defined(BSD)
+#elif defined(__FreeBSD__)
+ sprintf(serial_port_prefix, "/dev/cuaa");
+#elif defined(__NetBSD__)
sprintf(serial_port_prefix, "/dev/tty0");
#else
sprintf(serial_port_prefix, "/dev/tty0");

View File

@ -1,33 +0,0 @@
--- Makefile.in.orig Tue Mar 7 07:06:33 2000
+++ Makefile.in Thu Apr 20 03:00:00 2000
@@ -85,12 +85,12 @@
driversdir = @driversdir@
gallerydir = @gallerydir@
-CFLAGS = -O2 -Wall
+CFLAGS = @CFLAGS@
SUBDIRS = canon casio directory fuji gallery kodak kodak_generic konica konica_qmxxx man minolta mustek nikon philips photopc ricoh samsung sony src
-gphotodocdir = $(datadir)/gphoto/doc
+gphotodocdir = $(datadir)/gphoto
gphotodoc_DATA = AUTHORS MANUAL
@@ -365,13 +365,13 @@
install-exec-am:
install-exec: install-exec-recursive
-install-data-am: install-gphotodocDATA install-sysDATA
+install-data-am: install-gphotodocDATA
install-data: install-data-recursive
install-am: all-am
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
install: install-recursive
-uninstall-am: uninstall-gphotodocDATA uninstall-sysDATA
+uninstall-am: uninstall-gphotodocDATA
uninstall: uninstall-recursive
all-am: Makefile $(DATA) config.h
all-redirect: all-recursive-am

View File

@ -1,12 +0,0 @@
--- kodak/dc21x/lowlevel.c.orig Fri Jan 21 06:42:18 2000
+++ kodak/dc21x/lowlevel.c Thu Apr 20 03:00:00 2000
@@ -2,7 +2,9 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
+#ifndef __FreeBSD__
#include <sys/select.h>
+#endif
#include <sys/time.h>
#include <time.h>
#include "dc21x.h"

View File

@ -1,12 +0,0 @@
--- kodak/dc21x/main.c.orig Fri Jan 21 06:42:18 2000
+++ kodak/dc21x/main.c Thu Apr 20 03:00:00 2000
@@ -2,7 +2,9 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
+#ifndef __FreeBSD__
#include <sys/select.h>
+#endif
#include <sys/time.h>
#include <time.h>
#include "dc21x.h"

View File

@ -1,11 +0,0 @@
--- kodak/dc21x/Makefile.in.orig Tue Mar 7 07:06:48 2000
+++ kodak/dc21x/Makefile.in Thu Apr 20 03:00:00 2000
@@ -87,7 +87,7 @@
LIBDIR =
LIBS =
-CFLAGS = -O2 -Wall
+CFLAGS = @CFLAGS@
bin_PROGRAMS = dc21x_cam
dc21x_cam_SOURCES = dc21x.h main.c lowlevel.c

View File

@ -1,11 +0,0 @@
--- mustek/device.c.orig Mon Dec 6 03:48:54 1999
+++ mustek/device.c Thu Apr 20 03:00:00 2000
@@ -59,7 +59,7 @@
newtio.c_cflag = (newtio.c_cflag & ~CSIZE) | CS8;
// Set into raw, no echo mode
- #if defined(__NetBSD__)
+ #if defined(__NetBSD__) || defined(__FreeBSD__)
newtio.c_iflag &= ~(IGNBRK | IGNCR | INLCR | ICRNL |
IXANY | IXON | IXOFF | INPCK | ISTRIP);
#else

View File

@ -1,10 +0,0 @@
--- philips/philips_io.c.orig Sun Nov 21 01:28:41 1999
+++ philips/philips_io.c Thu Apr 20 03:00:00 2000
@@ -55,7 +55,6 @@
#include <errno.h>
#include <signal.h>
#include <time.h>
-#include <malloc.h>
#include <unistd.h>
#include <string.h>
#include <sys/time.h>

View File

@ -1,10 +0,0 @@
--- src/main.c.orig Tue Mar 7 06:23:06 2000
+++ src/main.c Thu Apr 20 03:00:00 2000
@@ -134,6 +134,7 @@
"Usage: gphoto [-h] [-c] [-n] [-s # filename] [-t # filename]\n");
fprintf(stdout, " [-d #] [-p filename] [-l filename]\n");
+ gtk_set_locale();
gtk_init(&argc, &argv);
#if 1 /* by fujisawa */
gdk_imlib_init();

View File

@ -1,22 +0,0 @@
--- src/util.c.orig Tue Mar 7 06:23:06 2000
+++ src/util.c Thu Apr 20 03:00:00 2000
@@ -1,3 +1,4 @@
+#include "config.h"
#include "gphoto.h"
#include "util.h"
#include <stdio.h>
@@ -9,10 +10,12 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
-#include <sys/dir.h>
+#ifdef HAVE_DIRENT_H
#include <dirent.h>
-#ifdef __FreeBSD__
#else
+#include <sys/dir.h>
+#endif
+#ifndef __FreeBSD__
#include <sys/resource.h>
#endif
#ifdef linux

View File

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Tue Mar 7 07:07:09 2000
+++ src/Makefile.in Thu Apr 20 03:00:00 2000
@@ -89,7 +89,7 @@
bin_PROGRAMS = gphoto
-CFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ -O2 -Wall -I$(srcdir)/icons
+CFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ @CFLAGS@ -I$(srcdir)/icons
gphoto_LDADD = ../konica/libgphoto_konica_qm100.la ../konica_qmxxx/libgphoto_konica_qmxxx.la ../canon/libgphoto_canon.la ../casio/libgphoto_casio_qv.la ../nikon/libgphoto_coolpix600.la ../philips/libgphoto_philips.la ../fuji/libgphoto_fuji.la ../photopc/libgphoto_photopc.la ../kodak/libgphoto_kodak_dc2x.la ../kodak_generic/libgphoto_kodak_generic.la ../minolta/libgphoto_dimage_v.la ../mustek/libgphoto_mustek_mdc800.la ../ricoh/libgphoto_ricoh300z.la ../samsung/libgphoto_samsung.la ../sony/libgphoto_sony_dscf1.la ../sony/dscf55/libgphoto_sony_dscf55.la ../directory/libgphoto_dir.la @GTK_LIBS@ @GDK_IMLIB_LIBS@ -ljpeg

View File

@ -1 +0,0 @@
A universal digital camera picture control tool

View File

@ -1,16 +0,0 @@
gPhoto is an universal, free GTK+ application that will allow
downloading, saving, and manipulation of images from several
different digital camera models, or from the local harddrive.
gPhoto has a basic command line interface, which is handy,
if you want to set up a web camera, and use gphoto in a
script, e.g. with Perl/PHP.
gPhoto sports a new HTML engine, that let's you create your
gallery "themes" (HTML with special tags), and publish images
to the web. A directory browse mode has also been implemented.
gPhoto supports a wide array of digital camera models. Visit
http://www.gphoto.org/cameras-04.html for an updated list.
WWW: http://www.gphoto.org/

View File

@ -1,98 +0,0 @@
bin/dc21x_cam
bin/gphoto
bin/gphoto-exifdump
bin/qm100
bin/qmxxx
bin/rsony
lib/libgphoto_canon.a
lib/libgphoto_canon.so
lib/libgphoto_canon.so.0
lib/libgphoto_casio_qv.a
lib/libgphoto_casio_qv.so
lib/libgphoto_casio_qv.so.0
lib/libgphoto_coolpix600.so.0
lib/libgphoto_coolpix600.a
lib/libgphoto_coolpix600.so
lib/libgphoto_dimage_v.a
lib/libgphoto_dimage_v.so
lib/libgphoto_dimage_v.so.0
lib/libgphoto_dir.a
lib/libgphoto_dir.so
lib/libgphoto_dir.so.0
lib/libgphoto_fuji.a
lib/libgphoto_fuji.so
lib/libgphoto_fuji.so.0
lib/libgphoto_kodak_dc2x.a
lib/libgphoto_kodak_dc2x.so
lib/libgphoto_kodak_dc2x.so.0
lib/libgphoto_kodak_generic.a
lib/libgphoto_kodak_generic.so
lib/libgphoto_kodak_generic.so.0
lib/libgphoto_konica_qm100.a
lib/libgphoto_konica_qm100.so
lib/libgphoto_konica_qm100.so.0
lib/libgphoto_konica_qmxxx.a
lib/libgphoto_konica_qmxxx.so
lib/libgphoto_konica_qmxxx.so.0
lib/libgphoto_mustek_mdc800.a
lib/libgphoto_mustek_mdc800.so
lib/libgphoto_mustek_mdc800.so.1
lib/libgphoto_philips.a
lib/libgphoto_philips.so
lib/libgphoto_philips.so.0
lib/libgphoto_photopc.a
lib/libgphoto_photopc.so
lib/libgphoto_photopc.so.0
lib/libgphoto_ricoh300z.a
lib/libgphoto_ricoh300z.so
lib/libgphoto_ricoh300z.so.0
lib/libgphoto_samsung.a
lib/libgphoto_samsung.so
lib/libgphoto_samsung.so.0
lib/libgphoto_sony_dscf1.a
lib/libgphoto_sony_dscf1.so
lib/libgphoto_sony_dscf1.so.0
lib/libgphoto_sony_dscf55.a
lib/libgphoto_sony_dscf55.so
lib/libgphoto_sony_dscf55.so.0
%%PORTDOCS%%share/doc/gphoto/ChangeLog
%%PORTDOCS%%share/doc/gphoto/FAQ
%%PORTDOCS%%share/doc/gphoto/NEWS
%%PORTDOCS%%share/doc/gphoto/PROGRAMMERS
%%PORTDOCS%%share/doc/gphoto/README
%%PORTDOCS%%share/doc/gphoto/THANKS
%%PORTDOCS%%share/doc/gphoto/THEMES
%%PORTDOCS%%share/doc/gphoto/TODO
share/gphoto/AUTHORS
share/gphoto/MANUAL
share/gphoto/gallery/CSStheme/gphotobutton.png
share/gphoto/gallery/CSStheme/index_bottom.html
share/gphoto/gallery/CSStheme/index_top.html
share/gphoto/gallery/CSStheme/mwcos.png
share/gphoto/gallery/CSStheme/picture.html
share/gphoto/gallery/CSStheme/styles.css
share/gphoto/gallery/CSStheme/thumbnail.html
share/gphoto/gallery/CSStheme/vh40.png
share/gphoto/gallery/Default/banner.gif
share/gphoto/gallery/Default/index.gif
share/gphoto/gallery/Default/index_bottom.html
share/gphoto/gallery/Default/index_top.html
share/gphoto/gallery/Default/next.gif
share/gphoto/gallery/Default/picture.html
share/gphoto/gallery/Default/previous.gif
share/gphoto/gallery/Default/thumbnail.html
share/gphoto/gallery/RedNGray/backgrnd.gif
share/gphoto/gallery/RedNGray/banner.gif
share/gphoto/gallery/RedNGray/index.gif
share/gphoto/gallery/RedNGray/index_bottom.html
share/gphoto/gallery/RedNGray/index_top.html
share/gphoto/gallery/RedNGray/next.gif
share/gphoto/gallery/RedNGray/picture.html
share/gphoto/gallery/RedNGray/previous.gif
share/gphoto/gallery/RedNGray/thumbnail.html
@dirrm share/gphoto/gallery/RedNGray
@dirrm share/gphoto/gallery/Default
@dirrm share/gphoto/gallery/CSStheme
@dirrm share/gphoto/gallery
@dirrm share/gphoto
%%PORTDOCS%%@dirrm share/doc/gphoto

View File

@ -5,29 +5,41 @@
# $FreeBSD$
#
PORTNAME= gphoto
PORTVERSION= 0.4.3
PORTNAME= gphoto2
PORTVERSION= 2.0
CATEGORIES= graphics
MASTER_SITES= http://www.gphoto.net/dist/
MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv \
intl.1:${PORTSDIR}/devel/gettext \
usb-0.1.5:${PORTSDIR}/devel/libusb \
aa.1:${PORTSDIR}/graphics/aalib \
jpeg.9:${PORTSDIR}/graphics/jpeg
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_IMLIB= yes
USE_LIBTOOL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-cdk --without-exif --without-fig2dev \
--with-doc-dir=${DOCSDIR}
INSTALLS_SHLIB= yes
MAN1= gphoto.1
MAN1= gphoto2.1
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/gphoto
.for file in ChangeLog FAQ NEWS PROGRAMMERS README THANKS THEMES TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gphoto
INSTALL_CMD= /usr/bin/install -c -o ${BINOWN} -g ${BINGRP}
post-patch:
.for file in configure libgphoto2_port/configure
@${PERL} -pi -e 's|<iconv.h>|<giconv.h>|g ; \
s|-liconv|-lgiconv|g ; \
s|-g -Wall||g' ${WRKSRC}/${file}
.endfor
.endif
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\@INSTALL\@|${INSTALL_CMD}|g ; \
s|AUTHORS COPYING README|AUTHORS README|g'
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (gphoto-0.4.3.tar.gz) = 8b4e70df78870479d2d9a45c8f4db5f4
MD5 (gphoto2-2.0.tar.gz) = f958d3c4b7238a8d6f1827da0d708941

View File

@ -1,13 +0,0 @@
--- src/callbacks.c.orig Tue Mar 7 06:23:06 2000
+++ src/callbacks.c Thu Apr 20 03:00:00 2000
@@ -529,7 +529,9 @@
#ifdef linux
sprintf(serial_port_prefix, "/dev/ttyS");
-#elif defined(BSD)
+#elif defined(__FreeBSD__)
+ sprintf(serial_port_prefix, "/dev/cuaa");
+#elif defined(__NetBSD__)
sprintf(serial_port_prefix, "/dev/tty0");
#else
sprintf(serial_port_prefix, "/dev/tty0");

View File

@ -1,33 +0,0 @@
--- Makefile.in.orig Tue Mar 7 07:06:33 2000
+++ Makefile.in Thu Apr 20 03:00:00 2000
@@ -85,12 +85,12 @@
driversdir = @driversdir@
gallerydir = @gallerydir@
-CFLAGS = -O2 -Wall
+CFLAGS = @CFLAGS@
SUBDIRS = canon casio directory fuji gallery kodak kodak_generic konica konica_qmxxx man minolta mustek nikon philips photopc ricoh samsung sony src
-gphotodocdir = $(datadir)/gphoto/doc
+gphotodocdir = $(datadir)/gphoto
gphotodoc_DATA = AUTHORS MANUAL
@@ -365,13 +365,13 @@
install-exec-am:
install-exec: install-exec-recursive
-install-data-am: install-gphotodocDATA install-sysDATA
+install-data-am: install-gphotodocDATA
install-data: install-data-recursive
install-am: all-am
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
install: install-recursive
-uninstall-am: uninstall-gphotodocDATA uninstall-sysDATA
+uninstall-am: uninstall-gphotodocDATA
uninstall: uninstall-recursive
all-am: Makefile $(DATA) config.h
all-redirect: all-recursive-am

View File

@ -1,12 +0,0 @@
--- kodak/dc21x/lowlevel.c.orig Fri Jan 21 06:42:18 2000
+++ kodak/dc21x/lowlevel.c Thu Apr 20 03:00:00 2000
@@ -2,7 +2,9 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
+#ifndef __FreeBSD__
#include <sys/select.h>
+#endif
#include <sys/time.h>
#include <time.h>
#include "dc21x.h"

View File

@ -1,12 +0,0 @@
--- kodak/dc21x/main.c.orig Fri Jan 21 06:42:18 2000
+++ kodak/dc21x/main.c Thu Apr 20 03:00:00 2000
@@ -2,7 +2,9 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
+#ifndef __FreeBSD__
#include <sys/select.h>
+#endif
#include <sys/time.h>
#include <time.h>
#include "dc21x.h"

View File

@ -1,11 +0,0 @@
--- kodak/dc21x/Makefile.in.orig Tue Mar 7 07:06:48 2000
+++ kodak/dc21x/Makefile.in Thu Apr 20 03:00:00 2000
@@ -87,7 +87,7 @@
LIBDIR =
LIBS =
-CFLAGS = -O2 -Wall
+CFLAGS = @CFLAGS@
bin_PROGRAMS = dc21x_cam
dc21x_cam_SOURCES = dc21x.h main.c lowlevel.c

View File

@ -1,11 +0,0 @@
--- mustek/device.c.orig Mon Dec 6 03:48:54 1999
+++ mustek/device.c Thu Apr 20 03:00:00 2000
@@ -59,7 +59,7 @@
newtio.c_cflag = (newtio.c_cflag & ~CSIZE) | CS8;
// Set into raw, no echo mode
- #if defined(__NetBSD__)
+ #if defined(__NetBSD__) || defined(__FreeBSD__)
newtio.c_iflag &= ~(IGNBRK | IGNCR | INLCR | ICRNL |
IXANY | IXON | IXOFF | INPCK | ISTRIP);
#else

View File

@ -1,10 +0,0 @@
--- philips/philips_io.c.orig Sun Nov 21 01:28:41 1999
+++ philips/philips_io.c Thu Apr 20 03:00:00 2000
@@ -55,7 +55,6 @@
#include <errno.h>
#include <signal.h>
#include <time.h>
-#include <malloc.h>
#include <unistd.h>
#include <string.h>
#include <sys/time.h>

View File

@ -1,10 +0,0 @@
--- src/main.c.orig Tue Mar 7 06:23:06 2000
+++ src/main.c Thu Apr 20 03:00:00 2000
@@ -134,6 +134,7 @@
"Usage: gphoto [-h] [-c] [-n] [-s # filename] [-t # filename]\n");
fprintf(stdout, " [-d #] [-p filename] [-l filename]\n");
+ gtk_set_locale();
gtk_init(&argc, &argv);
#if 1 /* by fujisawa */
gdk_imlib_init();

View File

@ -1,22 +0,0 @@
--- src/util.c.orig Tue Mar 7 06:23:06 2000
+++ src/util.c Thu Apr 20 03:00:00 2000
@@ -1,3 +1,4 @@
+#include "config.h"
#include "gphoto.h"
#include "util.h"
#include <stdio.h>
@@ -9,10 +10,12 @@
#include <stdlib.h>
#include <string.h>
#include <errno.h>
-#include <sys/dir.h>
+#ifdef HAVE_DIRENT_H
#include <dirent.h>
-#ifdef __FreeBSD__
#else
+#include <sys/dir.h>
+#endif
+#ifndef __FreeBSD__
#include <sys/resource.h>
#endif
#ifdef linux

View File

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Tue Mar 7 07:07:09 2000
+++ src/Makefile.in Thu Apr 20 03:00:00 2000
@@ -89,7 +89,7 @@
bin_PROGRAMS = gphoto
-CFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ -O2 -Wall -I$(srcdir)/icons
+CFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ @CFLAGS@ -I$(srcdir)/icons
gphoto_LDADD = ../konica/libgphoto_konica_qm100.la ../konica_qmxxx/libgphoto_konica_qmxxx.la ../canon/libgphoto_canon.la ../casio/libgphoto_casio_qv.la ../nikon/libgphoto_coolpix600.la ../philips/libgphoto_philips.la ../fuji/libgphoto_fuji.la ../photopc/libgphoto_photopc.la ../kodak/libgphoto_kodak_dc2x.la ../kodak_generic/libgphoto_kodak_generic.la ../minolta/libgphoto_dimage_v.la ../mustek/libgphoto_mustek_mdc800.la ../ricoh/libgphoto_ricoh300z.la ../samsung/libgphoto_samsung.la ../sony/libgphoto_sony_dscf1.la ../sony/dscf55/libgphoto_sony_dscf55.la ../directory/libgphoto_dir.la @GTK_LIBS@ @GDK_IMLIB_LIBS@ -ljpeg

View File

@ -0,0 +1,23 @@
--- ltmain.sh.orig Sat Mar 2 08:58:32 2002
+++ ltmain.sh Sat Mar 2 08:59:07 2002
@@ -958,6 +958,7 @@
;;
-avoid-version)
+ build_old_libs=no
avoid_version=yes
continue
;;
@@ -4247,10 +4248,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,16 +1,7 @@
gPhoto is an universal, free GTK+ application that will allow
downloading, saving, and manipulation of images from several
different digital camera models, or from the local harddrive.
gphoto2 is a library that can be used by applications to access
various digital cameras.
gPhoto has a basic command line interface, which is handy,
if you want to set up a web camera, and use gphoto in a
script, e.g. with Perl/PHP.
gPhoto sports a new HTML engine, that let's you create your
gallery "themes" (HTML with special tags), and publish images
to the web. A directory browse mode has also been implemented.
gPhoto supports a wide array of digital camera models. Visit
http://www.gphoto.org/cameras-04.html for an updated list.
Additionally, the command-line frontend, which is shipped with
the library, is called gphoto2, too.
WWW: http://www.gphoto.org/

View File

@ -1,98 +1,102 @@
bin/dc21x_cam
bin/gphoto
bin/gphoto-exifdump
bin/qm100
bin/qmxxx
bin/rsony
lib/libgphoto_canon.a
lib/libgphoto_canon.so
lib/libgphoto_canon.so.0
lib/libgphoto_casio_qv.a
lib/libgphoto_casio_qv.so
lib/libgphoto_casio_qv.so.0
lib/libgphoto_coolpix600.so.0
lib/libgphoto_coolpix600.a
lib/libgphoto_coolpix600.so
lib/libgphoto_dimage_v.a
lib/libgphoto_dimage_v.so
lib/libgphoto_dimage_v.so.0
lib/libgphoto_dir.a
lib/libgphoto_dir.so
lib/libgphoto_dir.so.0
lib/libgphoto_fuji.a
lib/libgphoto_fuji.so
lib/libgphoto_fuji.so.0
lib/libgphoto_kodak_dc2x.a
lib/libgphoto_kodak_dc2x.so
lib/libgphoto_kodak_dc2x.so.0
lib/libgphoto_kodak_generic.a
lib/libgphoto_kodak_generic.so
lib/libgphoto_kodak_generic.so.0
lib/libgphoto_konica_qm100.a
lib/libgphoto_konica_qm100.so
lib/libgphoto_konica_qm100.so.0
lib/libgphoto_konica_qmxxx.a
lib/libgphoto_konica_qmxxx.so
lib/libgphoto_konica_qmxxx.so.0
lib/libgphoto_mustek_mdc800.a
lib/libgphoto_mustek_mdc800.so
lib/libgphoto_mustek_mdc800.so.1
lib/libgphoto_philips.a
lib/libgphoto_philips.so
lib/libgphoto_philips.so.0
lib/libgphoto_photopc.a
lib/libgphoto_photopc.so
lib/libgphoto_photopc.so.0
lib/libgphoto_ricoh300z.a
lib/libgphoto_ricoh300z.so
lib/libgphoto_ricoh300z.so.0
lib/libgphoto_samsung.a
lib/libgphoto_samsung.so
lib/libgphoto_samsung.so.0
lib/libgphoto_sony_dscf1.a
lib/libgphoto_sony_dscf1.so
lib/libgphoto_sony_dscf1.so.0
lib/libgphoto_sony_dscf55.a
lib/libgphoto_sony_dscf55.so
lib/libgphoto_sony_dscf55.so.0
%%PORTDOCS%%share/doc/gphoto/ChangeLog
%%PORTDOCS%%share/doc/gphoto/FAQ
%%PORTDOCS%%share/doc/gphoto/NEWS
%%PORTDOCS%%share/doc/gphoto/PROGRAMMERS
%%PORTDOCS%%share/doc/gphoto/README
%%PORTDOCS%%share/doc/gphoto/THANKS
%%PORTDOCS%%share/doc/gphoto/THEMES
%%PORTDOCS%%share/doc/gphoto/TODO
share/gphoto/AUTHORS
share/gphoto/MANUAL
share/gphoto/gallery/CSStheme/gphotobutton.png
share/gphoto/gallery/CSStheme/index_bottom.html
share/gphoto/gallery/CSStheme/index_top.html
share/gphoto/gallery/CSStheme/mwcos.png
share/gphoto/gallery/CSStheme/picture.html
share/gphoto/gallery/CSStheme/styles.css
share/gphoto/gallery/CSStheme/thumbnail.html
share/gphoto/gallery/CSStheme/vh40.png
share/gphoto/gallery/Default/banner.gif
share/gphoto/gallery/Default/index.gif
share/gphoto/gallery/Default/index_bottom.html
share/gphoto/gallery/Default/index_top.html
share/gphoto/gallery/Default/next.gif
share/gphoto/gallery/Default/picture.html
share/gphoto/gallery/Default/previous.gif
share/gphoto/gallery/Default/thumbnail.html
share/gphoto/gallery/RedNGray/backgrnd.gif
share/gphoto/gallery/RedNGray/banner.gif
share/gphoto/gallery/RedNGray/index.gif
share/gphoto/gallery/RedNGray/index_bottom.html
share/gphoto/gallery/RedNGray/index_top.html
share/gphoto/gallery/RedNGray/next.gif
share/gphoto/gallery/RedNGray/picture.html
share/gphoto/gallery/RedNGray/previous.gif
share/gphoto/gallery/RedNGray/thumbnail.html
@dirrm share/gphoto/gallery/RedNGray
@dirrm share/gphoto/gallery/Default
@dirrm share/gphoto/gallery/CSStheme
@dirrm share/gphoto/gallery
@dirrm share/gphoto
%%PORTDOCS%%@dirrm share/doc/gphoto
bin/gphoto2
bin/gphoto2-config
bin/gphoto2-port-config
include/gphoto2/gphoto2-abilities-list.h
include/gphoto2/gphoto2-camera.h
include/gphoto2/gphoto2-context.h
include/gphoto2/gphoto2-file.h
include/gphoto2/gphoto2-filesys.h
include/gphoto2/gphoto2-library.h
include/gphoto2/gphoto2-list.h
include/gphoto2/gphoto2-port-info-list.h
include/gphoto2/gphoto2-port-log.h
include/gphoto2/gphoto2-port-portability.h
include/gphoto2/gphoto2-port-result.h
include/gphoto2/gphoto2-port.h
include/gphoto2/gphoto2-result.h
include/gphoto2/gphoto2-setting.h
include/gphoto2/gphoto2-widget.h
include/gphoto2/gphoto2.h
lib/gphoto2/2.0/libgphoto2_agfa.so
lib/gphoto2/2.0/libgphoto2_barbie.so
lib/gphoto2/2.0/libgphoto2_canon.so
lib/gphoto2/2.0/libgphoto2_casio_qv.so
lib/gphoto2/2.0/libgphoto2_digita.so
lib/gphoto2/2.0/libgphoto2_dimagev.so
lib/gphoto2/2.0/libgphoto2_dimera3500.so
lib/gphoto2/2.0/libgphoto2_directory.so
lib/gphoto2/2.0/libgphoto2_jamcam.so
lib/gphoto2/2.0/libgphoto2_jd11.so
lib/gphoto2/2.0/libgphoto2_kodak_dc120.so
lib/gphoto2/2.0/libgphoto2_kodak_dc240.so
lib/gphoto2/2.0/libgphoto2_kodak_dc3200.so
lib/gphoto2/2.0/libgphoto2_konica.so
lib/gphoto2/2.0/libgphoto2_panasonic_coolshot.so
lib/gphoto2/2.0/libgphoto2_panasonic_dc1000.so
lib/gphoto2/2.0/libgphoto2_panasonic_dc1580.so
lib/gphoto2/2.0/libgphoto2_panasonic_l859.so
lib/gphoto2/2.0/libgphoto2_polaroid_pdc320.so
lib/gphoto2/2.0/libgphoto2_polaroid_pdc640.so
lib/gphoto2/2.0/libgphoto2_polaroid_pdc700.so
lib/gphoto2/2.0/libgphoto2_ptp.so
lib/gphoto2/2.0/libgphoto2_ricoh.so
lib/gphoto2/2.0/libgphoto2_samsung.so
lib/gphoto2/2.0/libgphoto2_sierra.so
lib/gphoto2/2.0/libgphoto2_sony_dscf1.so
lib/gphoto2/2.0/libgphoto2_sony_dscf55.so
lib/gphoto2/2.0/libgphoto2_stv0680.so
lib/gphoto2_port/0.0.4/libgphoto2_port_serial.so
lib/gphoto2_port/0.0.4/libgphoto2_port_usb.so
lib/libgphoto2.a
lib/libgphoto2.so
lib/libgphoto2.so.2
lib/libgphoto2_port.a
lib/libgphoto2_port.so
lib/libgphoto2_port.so.0
lib/pkgconfig/libgphoto2.pc
share/doc/gphoto2/AUTHORS
share/doc/gphoto2/FAQ
share/doc/gphoto2/NEWS
share/doc/gphoto2/README
share/doc/gphoto2/gphoto2-cli.txt
share/doc/gphoto2/gphoto2.txt
share/doc/gphoto2/linux-hotplug/usbcam.console
share/doc/gphoto2/linux-hotplug/usbcam.group
share/gphoto2/konica/english
share/gphoto2/konica/french
share/gphoto2/konica/german
share/gphoto2/konica/japanese
share/gphoto2/konica/korean
share/gphoto2/konica/spanish
share/locale/da/LC_MESSAGES/gphoto2.mo
share/locale/da/LC_MESSAGES/libgphoto2_port.mo
share/locale/de/LC_MESSAGES/gphoto2.mo
share/locale/de/LC_MESSAGES/libgphoto2_port.mo
share/locale/fr/LC_MESSAGES/gphoto2.mo
share/locale/fr/LC_MESSAGES/libgphoto2_port.mo
share/locale/it/LC_MESSAGES/gphoto2.mo
share/locale/it/LC_MESSAGES/libgphoto2_port.mo
share/locale/ja/LC_MESSAGES/gphoto2.mo
share/locale/ja/LC_MESSAGES/libgphoto2_port.mo
share/locale/no/LC_MESSAGES/gphoto2.mo
share/locale/no/LC_MESSAGES/libgphoto2_port.mo
share/locale/ru/LC_MESSAGES/gphoto2.mo
share/locale/ru/LC_MESSAGES/libgphoto2_port.mo
share/locale/sl/LC_MESSAGES/gphoto2.mo
share/locale/sl/LC_MESSAGES/libgphoto2_port.mo
share/locale/sv/LC_MESSAGES/gphoto2.mo
share/locale/sv/LC_MESSAGES/libgphoto2_port.mo
share/locale/uk/LC_MESSAGES/gphoto2.mo
share/locale/uk/LC_MESSAGES/libgphoto2_port.mo
share/locale/zh_CN/LC_MESSAGES/gphoto2.mo
share/locale/zh_CN/LC_MESSAGES/libgphoto2_port.mo
@dirrm share/gphoto2/konica
@dirrm share/gphoto2
@dirrm share/doc/gphoto2/linux-hotplug
@dirrm share/doc/gphoto2/html/figures
@dirrm share/doc/gphoto2/html
@dirrm share/doc/gphoto2
@dirrm lib/gphoto2_port/0.0.4
@dirrm lib/gphoto2_port
@dirrm lib/gphoto2/2.0
@dirrm lib/gphoto2