Remove libsocialweb, it archived upstream, last commit was 3 years ago.

This commit is contained in:
Koop Mast 2019-03-23 12:05:20 +00:00
parent 034c469609
commit f67f27f347
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=496642
7 changed files with 1 additions and 313 deletions

1
MOVED
View File

@ -11975,3 +11975,4 @@ security/yubikey-piv-manager||2019-03-16|Has expired: Qt4 has been EOL since dec
textproc/xxdiff-scripts||2019-03-16|Has expired: Qt4 has been EOL since december 2015
graphics/py-pivy||2019-03-16|Has expired: Qt4 has been EOL since december 2015
security/pinentry-qt4||2019-03-17|Has expired: Qt4 has been EOL since december 2015
www/libsocialweb||2019-03-23|Project was archived upstream

View File

@ -346,7 +346,6 @@
SUBDIR += libmicrohttpd
SUBDIR += libnghttp2
SUBDIR += libresonic-standalone
SUBDIR += libsocialweb
SUBDIR += libwww
SUBDIR += lightsquid
SUBDIR += lighttpd

View File

@ -1,35 +0,0 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
PORTNAME= libsocialweb
PORTVERSION= 0.25.21
PORTREVISION= 3
CATEGORIES= www gnome
MASTER_SITES= GNOME
MAINTAINER= kwm@FreeBSD.org
COMMENT= Personal social data server
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= vapigen:lang/vala
LIB_DEPENDS= librest-0.7.so:devel/librest \
libgnome-keyring.so:security/libgnome-keyring \
libsoup-gnome-2.4.so:devel/libsoup-gnome \
libjson-glib-1.0.so:devel/json-glib
USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_GNOME= gconf2 glib20 intlhack introspection:build \
libxslt:build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-vala-bindings
# review if we want all the services enabled, because of not completely
# safe public API security wise?
CONFIGURE_ARGS+=--enable-all-services
INSTALL_TARGET= install-strip
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (libsocialweb-0.25.21.tar.xz) = f676567640cede66b6ff62f440c968943c2f3a164dd5f26155b6154ab93bf687
SIZE (libsocialweb-0.25.21.tar.xz) = 472152

View File

@ -1,82 +0,0 @@
From c1791e96182815449781fcda6007b69cd88cf7bf Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Mon, 04 Jun 2012 17:54:12 +0000
Subject: client: Fix namespacing of introspection annotations
---
diff --git a/libsocialweb-client/sw-client-contact-view.c b/libsocialweb-client/sw-client-contact-view.c
index bb2679f..6eaee0e 100644
--- libsocialweb-client/sw-client-contact-view.c
+++ libsocialweb-client/sw-client-contact-view.c
@@ -384,7 +384,7 @@ sw_client_contact_view_class_init (SwClientContactViewClass *klass)
/**
* SwClientContactView::contacts-added:
* @self:
- * @contacts: (type GLib.List) (element-type Sw.Contact):
+ * @contacts: (type GLib.List) (element-type SocialWebClient.Contact):
*/
signals[CONTACTS_ADDED_SIGNAL] =
g_signal_new ("contacts-added",
@@ -401,7 +401,7 @@ sw_client_contact_view_class_init (SwClientContactViewClass *klass)
/**
* SwClientContactView::contacts-removed:
* @self:
- * @contacts: (type GLib.List) (element-type Sw.Contact):
+ * @contacts: (type GLib.List) (element-type SocialWebClient.Contact):
*/
signals[CONTACTS_REMOVED_SIGNAL] =
g_signal_new ("contacts-removed",
@@ -418,7 +418,7 @@ sw_client_contact_view_class_init (SwClientContactViewClass *klass)
/**
* SwClientContactView::contacts-changed:
* @self:
- * @contacts: (type GLib.List) (element-type Sw.Contact):
+ * @contacts: (type GLib.List) (element-type SocialWebClient.Contact):
*/
signals[CONTACTS_CHANGED_SIGNAL] =
g_signal_new ("contacts-changed",
diff --git a/libsocialweb-client/sw-client-item-view.c b/libsocialweb-client/sw-client-item-view.c
index 6bfdb76..ab98fdd 100644
--- libsocialweb-client/sw-client-item-view.c
+++ libsocialweb-client/sw-client-item-view.c
@@ -389,7 +389,7 @@ sw_client_item_view_class_init (SwClientItemViewClass *klass)
/**
* SwClientItemView::items-added:
* @self:
- * @items: (type GLib.List) (element-type Sw.Item):
+ * @items: (type GLib.List) (element-type SocialWebClient.Item):
*/
signals[ITEMS_ADDED_SIGNAL] =
g_signal_new ("items-added",
@@ -406,7 +406,7 @@ sw_client_item_view_class_init (SwClientItemViewClass *klass)
/**
* SwClientItemView::items-removed:
* @self:
- * @items: (type GLib.List) (element-type Sw.Item):
+ * @items: (type GLib.List) (element-type SocialWebClient.Item):
*/
signals[ITEMS_REMOVED_SIGNAL] =
g_signal_new ("items-removed",
@@ -423,7 +423,7 @@ sw_client_item_view_class_init (SwClientItemViewClass *klass)
/**
* SwClientItemView::items-changed:
* @self:
- * @items: (type GLib.List) (element-type Sw.Item):
+ * @items: (type GLib.List) (element-type SocialWebClient.Item):
*/
signals[ITEMS_CHANGED_SIGNAL] =
g_signal_new ("items-changed",
diff --git a/libsocialweb-client/sw-contact.c b/libsocialweb-client/sw-contact.c
index efefb37..b56ab39 100644
--- libsocialweb-client/sw-contact.c
+++ libsocialweb-client/sw-contact.c
@@ -104,7 +104,6 @@ sw_contact_get_value (SwContact *contact,
/**
* sw_contact_get_value_all:
- *
* @contact: :
* @key: :
*
--
cgit v0.9.0.2

View File

@ -1 +0,0 @@
A personal social data server.

View File

@ -1,192 +0,0 @@
include/libsocialweb/interfaces/sw-avatar-ginterface.h
include/libsocialweb/interfaces/sw-banishable-ginterface.h
include/libsocialweb/interfaces/sw-collections-ginterface.h
include/libsocialweb/interfaces/sw-contacts-query-ginterface.h
include/libsocialweb/interfaces/sw-photo-upload-ginterface.h
include/libsocialweb/interfaces/sw-query-ginterface.h
include/libsocialweb/interfaces/sw-status-update-ginterface.h
include/libsocialweb/interfaces/sw-video-upload-ginterface.h
include/libsocialweb/libsocialweb-client/libsocialweb-client-hack-for-vala.h
include/libsocialweb/libsocialweb-client/sw-client-contact-view.h
include/libsocialweb/libsocialweb-client/sw-client-item-view.h
include/libsocialweb/libsocialweb-client/sw-client-lastfm.h
include/libsocialweb/libsocialweb-client/sw-client-service.h
include/libsocialweb/libsocialweb-client/sw-client.h
include/libsocialweb/libsocialweb-client/sw-contact.h
include/libsocialweb/libsocialweb-client/sw-item.h
include/libsocialweb/libsocialweb-keyfob/sw-keyfob.h
include/libsocialweb/libsocialweb-keystore/sw-keystore.h
include/libsocialweb/libsocialweb/sw-cache.h
include/libsocialweb/libsocialweb/sw-cacheable.h
include/libsocialweb/libsocialweb/sw-client-monitor.h
include/libsocialweb/libsocialweb/sw-contact-view.h
include/libsocialweb/libsocialweb/sw-contact.h
include/libsocialweb/libsocialweb/sw-core.h
include/libsocialweb/libsocialweb/sw-debug.h
include/libsocialweb/libsocialweb/sw-enum-types.h
include/libsocialweb/libsocialweb/sw-item-stream.h
include/libsocialweb/libsocialweb/sw-item-view.h
include/libsocialweb/libsocialweb/sw-item.h
include/libsocialweb/libsocialweb/sw-module.h
include/libsocialweb/libsocialweb/sw-online.h
include/libsocialweb/libsocialweb/sw-service.h
include/libsocialweb/libsocialweb/sw-set.h
include/libsocialweb/libsocialweb/sw-types.h
include/libsocialweb/libsocialweb/sw-utils.h
include/libsocialweb/libsocialweb/sw-web.h
lib/libsocialweb/services/libfacebook.so
lib/libsocialweb/services/libflickr.so
lib/libsocialweb/services/liblastfm.so
lib/libsocialweb/services/libmyspace.so
lib/libsocialweb/services/libphotobucket.so
lib/libsocialweb/services/libplurk.so
lib/libsocialweb/services/libsina.so
lib/libsocialweb/services/libsmugmug.so
lib/libsocialweb/services/libtwitter.so
lib/libsocialweb/services/libvimeo.so
lib/libsocialweb/services/libyoutube.so
lib/girepository-1.0/SocialWebClient-0.25.typelib
lib/libsocialweb-client.so
lib/libsocialweb-client.so.2
lib/libsocialweb-client.so.2.0.0
lib/libsocialweb-keyfob.so
lib/libsocialweb-keyfob.so.0
lib/libsocialweb-keyfob.so.0.0.0
lib/libsocialweb-keystore.so
lib/libsocialweb-keystore.so.0
lib/libsocialweb-keystore.so.0.0.0
lib/libsocialweb.so
lib/libsocialweb.so.0
lib/libsocialweb.so.0.0.0
libdata/pkgconfig/libsocialweb-client.pc
libdata/pkgconfig/libsocialweb-keyfob.pc
libdata/pkgconfig/libsocialweb-keystore.pc
libdata/pkgconfig/libsocialweb-module.pc
libexec/libsocialweb-core
share/dbus-1/services/libsocialweb.service
share/gir-1.0/SocialWebClient-0.25.gir
share/gtk-doc/html/libsocialweb-client/SwClient.html
share/gtk-doc/html/libsocialweb-client/SwClientItemView.html
share/gtk-doc/html/libsocialweb-client/SwClientLastfm.html
share/gtk-doc/html/libsocialweb-client/SwClientService.html
share/gtk-doc/html/libsocialweb-client/api-index-full.html
share/gtk-doc/html/libsocialweb-client/ch01.html
share/gtk-doc/html/libsocialweb-client/home.png
share/gtk-doc/html/libsocialweb-client/index.html
share/gtk-doc/html/libsocialweb-client/index.sgml
share/gtk-doc/html/libsocialweb-client/left.png
share/gtk-doc/html/libsocialweb-client/libsocialweb-client-sw-item.html
share/gtk-doc/html/libsocialweb-client/libsocialweb-client.devhelp2
share/gtk-doc/html/libsocialweb-client/object-tree.html
share/gtk-doc/html/libsocialweb-client/right.png
share/gtk-doc/html/libsocialweb-client/style.css
share/gtk-doc/html/libsocialweb-client/up.png
share/gtk-doc/html/libsocialweb-dbus/Avatar.html
share/gtk-doc/html/libsocialweb-dbus/Banishable.html
share/gtk-doc/html/libsocialweb-dbus/Collections.html
share/gtk-doc/html/libsocialweb-dbus/ItemView.html
share/gtk-doc/html/libsocialweb-dbus/Lastfm.html
share/gtk-doc/html/libsocialweb-dbus/PhotoUpload.html
share/gtk-doc/html/libsocialweb-dbus/Query.html
share/gtk-doc/html/libsocialweb-dbus/Service.html
share/gtk-doc/html/libsocialweb-dbus/StatusUpdate.html
share/gtk-doc/html/libsocialweb-dbus/VideoUpload.html
share/gtk-doc/html/libsocialweb-dbus/ch01.html
share/gtk-doc/html/libsocialweb-dbus/ch01s02.html
share/gtk-doc/html/libsocialweb-dbus/ch01s03.html
share/gtk-doc/html/libsocialweb-dbus/home.png
share/gtk-doc/html/libsocialweb-dbus/index.html
share/gtk-doc/html/libsocialweb-dbus/index.sgml
share/gtk-doc/html/libsocialweb-dbus/left.png
share/gtk-doc/html/libsocialweb-dbus/libsocialweb-dbus.devhelp2
share/gtk-doc/html/libsocialweb-dbus/libsocialweb.html
share/gtk-doc/html/libsocialweb-dbus/right.png
share/gtk-doc/html/libsocialweb-dbus/style.css
share/gtk-doc/html/libsocialweb-dbus/up.png
share/gtk-doc/html/libsocialweb/SwCore.html
share/gtk-doc/html/libsocialweb/SwItem.html
share/gtk-doc/html/libsocialweb/SwItemStream.html
share/gtk-doc/html/libsocialweb/SwItemView.html
share/gtk-doc/html/libsocialweb/SwService.html
share/gtk-doc/html/libsocialweb/SwSet.html
share/gtk-doc/html/libsocialweb/api-index-full.html
share/gtk-doc/html/libsocialweb/ch01.html
share/gtk-doc/html/libsocialweb/ch02.html
share/gtk-doc/html/libsocialweb/ch03.html
share/gtk-doc/html/libsocialweb/home.png
share/gtk-doc/html/libsocialweb/index.html
share/gtk-doc/html/libsocialweb/index.sgml
share/gtk-doc/html/libsocialweb/left.png
share/gtk-doc/html/libsocialweb/libsocialweb-SwCallList.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-banned.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-cache.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-client-monitor.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-debug.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-enum-types.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-keyfob.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-keystore.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-module.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-online.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-utils.html
share/gtk-doc/html/libsocialweb/libsocialweb-sw-web.html
share/gtk-doc/html/libsocialweb/libsocialweb.devhelp2
share/gtk-doc/html/libsocialweb/object-tree.html
share/gtk-doc/html/libsocialweb/right.png
share/gtk-doc/html/libsocialweb/style.css
share/gtk-doc/html/libsocialweb/up.png
share/libsocialweb/services/facebook.keys
share/libsocialweb/services/flickr.keys
share/libsocialweb/services/lastfm.keys
share/libsocialweb/services/lastfm.png
share/libsocialweb/services/myspace.keys
share/libsocialweb/services/myspace.png
share/libsocialweb/services/photobucket.keys
share/libsocialweb/services/plurk.keys
share/libsocialweb/services/plurk.png
share/libsocialweb/services/sina.keys
share/libsocialweb/services/sina.png
share/libsocialweb/services/smugmug.keys
share/libsocialweb/services/twitter.keys
share/libsocialweb/services/twitter.png
share/libsocialweb/services/vimeo.keys
share/libsocialweb/services/vimeo.png
share/libsocialweb/services/youtube.keys
share/libsocialweb/services/youtube.png
share/locale/ar/LC_MESSAGES/libsocialweb.mo
share/locale/ast/LC_MESSAGES/libsocialweb.mo
share/locale/bn_IN/LC_MESSAGES/libsocialweb.mo
share/locale/ca/LC_MESSAGES/libsocialweb.mo
share/locale/ca@valencia/LC_MESSAGES/libsocialweb.mo
share/locale/cs/LC_MESSAGES/libsocialweb.mo
share/locale/da/LC_MESSAGES/libsocialweb.mo
share/locale/de/LC_MESSAGES/libsocialweb.mo
share/locale/en_GB/LC_MESSAGES/libsocialweb.mo
share/locale/es/LC_MESSAGES/libsocialweb.mo
share/locale/eu/LC_MESSAGES/libsocialweb.mo
share/locale/fa/LC_MESSAGES/libsocialweb.mo
share/locale/fi/LC_MESSAGES/libsocialweb.mo
share/locale/fr/LC_MESSAGES/libsocialweb.mo
share/locale/gl/LC_MESSAGES/libsocialweb.mo
share/locale/hu/LC_MESSAGES/libsocialweb.mo
share/locale/id/LC_MESSAGES/libsocialweb.mo
share/locale/it/LC_MESSAGES/libsocialweb.mo
share/locale/ja/LC_MESSAGES/libsocialweb.mo
share/locale/ko/LC_MESSAGES/libsocialweb.mo
share/locale/lv/LC_MESSAGES/libsocialweb.mo
share/locale/nl/LC_MESSAGES/libsocialweb.mo
share/locale/pa/LC_MESSAGES/libsocialweb.mo
share/locale/pl/LC_MESSAGES/libsocialweb.mo
share/locale/pt_BR/LC_MESSAGES/libsocialweb.mo
share/locale/ro/LC_MESSAGES/libsocialweb.mo
share/locale/ru/LC_MESSAGES/libsocialweb.mo
share/locale/sk/LC_MESSAGES/libsocialweb.mo
share/locale/sl/LC_MESSAGES/libsocialweb.mo
share/locale/sv/LC_MESSAGES/libsocialweb.mo
share/locale/th/LC_MESSAGES/libsocialweb.mo
share/locale/tr/LC_MESSAGES/libsocialweb.mo
share/locale/uk/LC_MESSAGES/libsocialweb.mo
share/locale/wa/LC_MESSAGES/libsocialweb.mo
share/locale/zh_CN/LC_MESSAGES/libsocialweb.mo
share/locale/zh_TW/LC_MESSAGES/libsocialweb.mo
share/vala/vapi/libsocialweb-client.deps
share/vala/vapi/libsocialweb-client.vapi