add cppadvio

Advanced i/o, networking, and arithmetic compression C++ classlib

PR:		23053
Submitted by:	Oleg <oleg@pobox.com>
This commit is contained in:
Ying-Chieh Liao 2001-05-19 11:05:42 +00:00
parent 71fb67d740
commit f67a73af56
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42727
8 changed files with 178 additions and 0 deletions

View File

@ -69,6 +69,7 @@
SUBDIR += cons-test
SUBDIR += cook
SUBDIR += cpp2html
SUBDIR += cppadvio
SUBDIR += cproto
SUBDIR += crossgo32
SUBDIR += crossgo32-djgpp2

45
devel/cppadvio/Makefile Normal file
View File

@ -0,0 +1,45 @@
# New ports collection makefile for: cppadvio
# Date created: November 23, 2000
# Whom: Oleg Kiselyov <oleg@pobox.com>
#
# $FreeBSD$
#
PORTNAME= cppadvio
PORTVERSION= 2.6
CATEGORIES= devel net
MASTER_SITES= http://www.lh.com/~oleg/ftp/packages/ \
${MASTER_SITE_LOCAL}
MAINTAINER= oleg@pobox.com
WRKSRC= ${WRKDIR}/cppadvio
ALL_TARGET= lib
USE_GMAKE= yes
USE_NEWGCC= yes
post-patch:
@( cd ${WRKSRC}; ${MV} c++ c++.orig; \
${SED} -e 's/^ *gcc/${CXX} ${CXXFLAGS}/' c++.orig > c++; ${CHMOD} +x c++ )
do-install:
$(INSTALL_DATA) ${WRKSRC}/libcppadvio.a ${PREFIX}/lib
${MKDIR} ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/Logger.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/TCPstream.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/arithm.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/arithm_modadapt.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/arithm_modadh.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/builtin.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/endian_io.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/histogram.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/minmax.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/myenv.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/std.h ${PREFIX}/include/cppadvio
$(INSTALL_DATA) ${WRKSRC}/voc.h ${PREFIX}/include/cppadvio
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cppadvio
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cppadvio
.endif
.include <bsd.port.mk>

1
devel/cppadvio/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (cppadvio-2.6.tar.gz) = cca888d30ddfcf4957fa501b6ee0569b

View File

@ -0,0 +1,84 @@
--- Makefile Sun Nov 19 14:57:06 2000
+++ Makefile Thu Nov 23 14:12:35 2000
@@ -62,8 +62,8 @@
#
# $Id: Makefile,v 4.2 2000/11/19 22:57:06 oleg Exp oleg $
-CC=./c++
-CCL=g++ -pipe
+CCXC=./c++
+CCL=$(CXX)
.SUFFIXES: .cc
MODULES=myenv.cc endian_io.cc \
arithm_coding.cc arithm_model.cc arithm_modadapt.cc \
@@ -83,10 +83,10 @@
# Rules, new style
%.o : %.cc
- $(CC) $*.cc
+ $(CCXC) $*.cc
$(LIBRARY)(%.o) : %.cc
- $(CC) $*.cc
+ $(CCXC) $*.cc
ar rcv $(LIBRARY) $*.o
rm -f $*.o
@@ -95,7 +95,7 @@
./$@
% :: %.cc
- $(CC) $*.cc
+ $(CCXC) $*.cc
$(CCL) $*.o $(CLDEF) $(LIBRARY) $(LIBS) -o $@
./$@
@@ -104,11 +104,11 @@
# $(CCL) $*.o $(CLDEF) $(LIBRARY) $(LIBS) -o $*
# ./$*
#.cc: $*.cc $(LIBRARY)
-# $(CC) $*.cc
+# $(CCXC) $*.cc
# $(CCL) $*.o $(CLDEF) $(LIBRARY) $(LIBS) -o $*
# ./$*
#.cc.o:
-# $(CC) $*.cc
+# $(CCXC) $*.cc
#
# Primary goal
@@ -126,7 +126,7 @@
#$(LIBRARY):: $(MODULES)
# Compile the source files that have been changed
-# $(CC) $?
+# $(CCXC) $?
# listobj=`echo $? | sed s/.cc/.o/g` ; \
# ar rv $(LIBRARY) $$listobj && \
# rm $$listobj
@@ -151,14 +151,14 @@
# Optimization causes internal compiler error...
#vmyenv.o: vmyenv.cc
-# $(CC) -O0 vmyenv.cc
+# $(CCXC) -O0 vmyenv.cc
vTCPstream: vTCPstream.o $(LIBRARY)
$(CCL) $^ -o $@ $(NETLIBS) -lm
ECHO_HOST=$(ECHO_HOST) ./$@
vTCPstream_server.o: vTCPstream_server.cc
- $(CC) -DDO_FORK vTCPstream_server.cc
+ $(CCXC) -DDO_FORK vTCPstream_server.cc
vTCPstream_server: vTCPstream_server.o $(LIBRARY)
$(CCL) $^ -o $@ $(NETLIBS) -lm
@@ -177,7 +177,7 @@
vendian_io_ext: sys_open_glue.o open_ext.o
- $(CC) -DEXT_OPEN=1 -DEXT_NETIO=$(ECHO_HOST) vendian_io.cc
+ $(CCXC) -DEXT_OPEN=1 -DEXT_NETIO=$(ECHO_HOST) vendian_io.cc
$(CCL) vendian_io.o $^ $(LIBRARY) $(NETLIBS) -o $@ -lm
./$@

View File

@ -0,0 +1 @@
Advanced i/o, networking, and arithmetic compression C++ classlib

20
devel/cppadvio/pkg-descr Normal file
View File

@ -0,0 +1,20 @@
cppadvio: Advanced i/o, Networking, and Arithmetic Compression
classlib, extended file names, and portable handling and compression
of binary data
A collection of classes and C++ streams that perform:
- a variable-bit coding of sequences of integers (including
Arithmetic compression),
- a trick of sharing a stream buffer (a "file") among several streams,
- handling of extended file names, with uni- and bi-directional 'pipes'
and a 'tcp://' prefix
- explicit endian specification in dealing with integer streams
- TCP streams
- a Vocabulary package, (poly/homo)morphic dictionaries with a
dynamic "inheritance" path, an embedded OO system
Current Version: 2.6, November 19, 2000.
WWW: http://pobox.com/~oleg/ftp/packages.html
Oleg Kiselyov
mailto:oleg@pobox.com, mailto:oleg@acm.org, mailto:oleg@computer.org

View File

@ -0,0 +1,10 @@
Don't forget to compile and run verification/validation code: gmake check-all
or specifically, sub-targets
vmyenv vendian_io vendian_io_ext vhistogram varithm
vTCPstream vTCPstream_server vvoc
See comments in the work/cppadvio/Makefile for details, as well as
c++serv.dr. The verification code checks to see that all the
functions in this package have compiled and run well. The validation
code can also serve as an illustration of how package's classes and
functions may be employed.

16
devel/cppadvio/pkg-plist Normal file
View File

@ -0,0 +1,16 @@
lib/libcppadvio.a
%%PORTDOCS%%share/doc/cppadvio/README
%%PORTDOCS%%@dirrm share/doc/cppadvio
include/cppadvio/Logger.h
include/cppadvio/TCPstream.h
include/cppadvio/arithm.h
include/cppadvio/arithm_modadapt.h
include/cppadvio/arithm_modadh.h
include/cppadvio/builtin.h
include/cppadvio/endian_io.h
include/cppadvio/histogram.h
include/cppadvio/minmax.h
include/cppadvio/myenv.h
include/cppadvio/std.h
include/cppadvio/voc.h
@dirrm include/cppadvio