- Update xmame/xmess to 0.67.1
- Mark xpinmame as broken. Approved by: MAINTAINER
This commit is contained in:
parent
6b0492ae8e
commit
f66dda511f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=78694
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME?= xmame
|
||||
PORTVERSION?= 0.65.1
|
||||
PORTVERSION?= 0.67.1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://x.mame.net/download/:xmame \
|
||||
http://www.sys2064.com/files/util/:history \
|
||||
@ -22,6 +22,7 @@ COMMENT?= UNIX/X11 port of the Multi Arcade Machine Emulator (MAME)
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GNOMENG= yes
|
||||
|
||||
MAN6= x${MAMEMESS}.6
|
||||
@ -257,7 +258,7 @@ pre-everything::
|
||||
# XXX: The -Imess part was added because of a conflict with cdparanoia-3.9.8_3
|
||||
# which (imho bogusly) installs an 'utils.h' header in $LOCALBASE/include
|
||||
do-configure:
|
||||
${SED} -e "s@= gcc@?= ${CC}@g" \
|
||||
${REINPLACE_CMD} -e "s@= gcc@?= ${CC}@g" \
|
||||
-e "s@^TARGET.*@TARGET = ${MAMEMESS}@g" \
|
||||
-e "s@# MAME_NET@${NETWORK}MAME_NET@g" \
|
||||
-e "s@# X86_ASM_68000@${ASM_COMMENT}X86_ASM_68000@g" \
|
||||
@ -277,7 +278,7 @@ do-configure:
|
||||
-e "s@/usr/X11R6@${X11BASE}@g" \
|
||||
-e "s@^SDL_CONFIG.*@SDL_CONFIG = ${SDL_CONFIG}@g" \
|
||||
-e "s@^GLLIBS=.*@GLLIBS= ${PTHREAD_LIBS}@g" \
|
||||
${WRKSRC}/makefile.unix > ${WRKSRC}/Makefile
|
||||
${WRKSRC}/makefile.unix
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
|
||||
|
@ -1,6 +1,4 @@
|
||||
MD5 (xmame/xmame-0.65.1.tar.bz2) = 7bf1f83c22d3093944c322bb5315d317
|
||||
MD5 (xmame/xmame-0.59.2.tar.bz2) = f35a5f9a79da963c157867015c284562
|
||||
MD5 (xmame/xmame-0.67.1.tar.bz2) = 6ae6a6cec51c275b2bc349a13f3cd8a5
|
||||
MD5 (xmame/cheat.zip) = b745ea4df1a3a517c00fedae1ee49a14
|
||||
MD5 (xmame/history.dat.zip) = 8c758537d5f5bc90fc3224b19421ae12
|
||||
MD5 (xmame/uhsdat795.zip) = c30956e15cd8218f558f41013a47f22e
|
||||
MD5 (xmame/xmame-0.59.2-pinmame-1.20.b.patch.gz) = aeefd4f6593d389cddbb7081cfc4eb42
|
||||
|
@ -1,58 +0,0 @@
|
||||
--- src/unix/joystick-drivers/joy_usb.c.orig Mon Mar 17 22:36:59 2003
|
||||
+++ src/unix/joystick-drivers/joy_usb.c Tue Apr 8 22:54:47 2003
|
||||
@@ -20,19 +20,27 @@
|
||||
"Patches to support other archs are welcome ;)"
|
||||
#endif
|
||||
|
||||
-#if defined(__ARCH_netbsd)
|
||||
-#ifdef HAVE_USBHID_H
|
||||
-#include <usbhid.h>
|
||||
+#if defined(HAVE_USBHID_H) || defined(HAVE_LIBUSBHID_H)
|
||||
+# ifdef HAVE_USBHID_H
|
||||
+# include <usbhid.h>
|
||||
+# endif
|
||||
+# ifdef HAVE_LIBUSBHID_H
|
||||
+# include <libusbhid.h>
|
||||
+# endif
|
||||
#else
|
||||
-#include <usb.h>
|
||||
-#endif
|
||||
-#elif defined(__ARCH_freebsd)
|
||||
-#ifdef HAVE_USBHID_H
|
||||
-#include <libusbhid.h>
|
||||
-#else
|
||||
-#include <libusb.h>
|
||||
+# ifdef __ARCH_netbsd
|
||||
+# include <usb.h>
|
||||
+# endif
|
||||
+# ifdef __ARCH_freebsd
|
||||
+# include <libusb.h>
|
||||
+# endif
|
||||
#endif
|
||||
+
|
||||
+#ifdef __ARCH_freebsd
|
||||
+#include <osreldate.h>
|
||||
+#include <sys/ioctl.h>
|
||||
#endif
|
||||
+
|
||||
#include <dev/usb/usb.h>
|
||||
#include <dev/usb/usbhid.h>
|
||||
|
||||
@@ -90,7 +98,7 @@
|
||||
|
||||
priv_joy_data[i].hids = NULL;
|
||||
|
||||
-#ifdef HAVE_USBHID_H
|
||||
+#if defined(HAVE_USBHID_H) || defined(HAVE_LIBUSBHID_H)
|
||||
#if defined(__ARCH_netbsd) || (defined(__ARCH_freebsd) && __FreeBSD_version > 500000)
|
||||
if (ioctl(joy_data[i].fd, USB_GET_REPORT_ID, &report_id) < 0)
|
||||
{
|
||||
@@ -114,7 +122,7 @@
|
||||
priv_joy_data[i].dlen = size;
|
||||
|
||||
is_joystick = 0;
|
||||
-#if defined(__ARCH_netbsd) && defined(HAVE_USBHID_H)
|
||||
+#if defined(HAVE_USBHID_H)
|
||||
for (d = hid_start_parse(rd, 1 << hid_input, report_id);
|
||||
hid_get_item(d, &h); )
|
||||
#else
|
@ -1,54 +0,0 @@
|
||||
--- src/unix/unix.mak.orig Wed Feb 12 05:13:26 2003
|
||||
+++ src/unix/unix.mak Wed Feb 12 10:04:04 2003
|
||||
@@ -31,7 +31,7 @@
|
||||
LIBS.macosx = -framework CoreAudio
|
||||
#LIBS.openbsd = -lossaudio
|
||||
LIBS.nto = -lsocket -lasound
|
||||
-LIBS.beos = `sdl-config --libs`
|
||||
+LIBS.beos = `$(SDL_CONFIG) --libs`
|
||||
|
||||
##############################################################################
|
||||
# **** Display dependent settings.
|
||||
@@ -219,8 +219,8 @@
|
||||
endif
|
||||
|
||||
ifdef SOUND_SDL
|
||||
-CONFIG += -DSYSDEP_DSP_SDL `sdl-config --cflags`
|
||||
-MY_LIBS += `sdl-config --libs`
|
||||
+CONFIG += -DSYSDEP_DSP_SDL `$(SDL_CONFIG) --cflags`
|
||||
+MY_LIBS += `$(SDL_CONFIG) --libs`
|
||||
endif
|
||||
|
||||
ifdef SOUND_WAVEOUT
|
||||
@@ -248,27 +248,20 @@
|
||||
ifdef JOY_PS2
|
||||
CONFIG += -DPS2_JOYSTICK
|
||||
endif
|
||||
+
|
||||
ifdef JOY_USB
|
||||
CONFIG += -DUSB_JOYSTICK
|
||||
-ifeq ($(ARCH), netbsd)
|
||||
ifeq ($(shell test -f /usr/include/usbhid.h && echo have_usbhid), have_usbhid)
|
||||
CONFIG += -DHAVE_USBHID_H
|
||||
MY_LIBS += -lusbhid
|
||||
else
|
||||
-MY_LIBS += -lusb
|
||||
-endif
|
||||
-else
|
||||
-ifeq ($(ARCH), freebsd)
|
||||
-ifeq ($(shell test -f /usr/include/libusbhid.h && echo have_usbhid), have_usbhid)
|
||||
-CONFIG += -DHAVE_USBHID_H
|
||||
+ifeq ($(shell test -f /usr/include/libusbhid.h && echo have_libusbhid), have_libusbhid)
|
||||
+CONFIG += -DHAVE_LIBUSBHID_H
|
||||
MY_LIBS += -lusbhid
|
||||
-else
|
||||
-MY_LIBS += -lusb
|
||||
+endif
|
||||
endif
|
||||
else
|
||||
MY_LIBS += -lusb
|
||||
-endif
|
||||
-endif
|
||||
endif
|
||||
|
||||
ifdef EFENCE
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= xmess
|
||||
PORTVERSION= 0.65.1
|
||||
PORTVERSION= 0.67.1
|
||||
|
||||
MAINTAINER= stijn@win.tue.nl
|
||||
COMMENT= X11 emulator for game consoles
|
||||
|
@ -13,6 +13,7 @@ PATCHFILES+= ${DISTNAME}-pinmame-${PINMAMEVERSION}.patch.gz
|
||||
|
||||
MAINTAINER= stijn@win.tue.nl
|
||||
COMMENT= X11 emulator for pinball ROMs
|
||||
BROKEN= "Patch file out of date."
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../xmame
|
||||
DESCR= ${.CURDIR}/pkg-descr
|
||||
|
Loading…
Reference in New Issue
Block a user