- Fix build with gcc 4.2

PR:		118029
Submitted by:	Pietro Cerutti <gahr@gahr.ch>
Approved by:	portmgr (erwin)
This commit is contained in:
Martin Wilke 2007-11-22 08:35:23 +00:00
parent e202be6a26
commit f63311415c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202790
3 changed files with 29 additions and 4 deletions

View File

@ -80,10 +80,6 @@ INFO= qdoc
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
.if ${ARCH} == "amd64"
BROKEN= Does not build on amd64 (shared libraries must be compiled with -fPIC)
.endif

View File

@ -0,0 +1,19 @@
--- modules/octave/octave.c.orig 2007-11-14 03:04:18.000000000 +0100
+++ modules/octave/octave.c 2007-11-14 03:06:27.000000000 +0100
@@ -126,6 +126,8 @@
static const char *octaverc = ".octaverc";
static const char *octaverc_bak = ".octaverc.$$$";
+static int send_octave(char *);
+
/* handle SIGINT and SIGTERM */
#if RETSIGTYPE == void
@@ -272,7 +274,6 @@
FILE *fp, *fp2;
char buf[bufsz];
int bak = 0;
- static int send_octave(char *cmd);
static int init = 0;
if (!octp) {
/* get the command from the OCTAVE variable if defined */

View File

@ -0,0 +1,10 @@
--- src/qmparse.y.orig 2007-11-14 03:07:31.000000000 +0100
+++ src/qmparse.y 2007-11-14 03:09:06.000000000 +0100
@@ -239,7 +239,6 @@
| _PROMPT_ arg_list
{
- static savepos();
char **argv = $2.v;
int argc = $2.c, i;
if (argc == 0) {