Update to 0.3.0.

PR:		ports/53078
Submitted by:	Thierry Thomas <thierry@pompo.net> (maintainer)
This commit is contained in:
Adam Weinberger 2003-06-14 04:08:18 +00:00
parent 3eb9ccd2ab
commit f616e0cc43
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82970
9 changed files with 243 additions and 83 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= pinball
PORTVERSION= 0.1.2
PORTVERSION= 0.3.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= thierry@pompo.net
COMMENT= Emilia Pinball is a free pinball game
PATCH_DEPENDS= ${DOS2UNIX}:${PORTSDIR}/converters/unix2dos
.if !defined(WITH_ALLEGRO)
BUILD_DEPENDS= ${SDL_CONFIG}:${PORTSDIR}/devel/sdl12
LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
@ -24,34 +25,44 @@ LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
.endif
USE_X_PREFIX= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_MESA= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX}
.if defined(WITH_ALLEGRO)
CONFIGURE_ARGS+= --with-allegro
EXTRA_LIBS= -lGL -lGLU
.endif
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib" \
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include -DRZR_LIBSTATIC" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${EXTRA_LIBS}" \
SDL_CONFIG="${SDL_CONFIG}"
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
DOS2UNIX= ${LOCALBASE}/bin/dos2unix
DOCS= README
DOS2TR= base/Private.h
post-patch:
.for FILE in ${DOS2TR}
@${DOS2UNIX} ${WRKSRC}/${FILE}
.endfor
post-install:
@${MV} ${PREFIX}/bin/${MACHINE_ARCH}-unknown-freebsd${OSREL}-pinball \
${PREFIX}/bin/pinball
@${MV} ${PREFIX}/bin/${MACHINE_ARCH}-unknown-freebsd${OSREL}-pinball-config \
${PREFIX}/bin/pinball-config
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"
@${ECHO_MSG}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (pinball-0.1.2.tar.gz) = 8c40d8b8be8352c1c476d6d86438336d
MD5 (pinball-0.3.0.tar.gz) = b81a062874e541914e258ddb9c1cc941

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Thu May 29 06:47:43 2003
+++ Makefile.in Thu Jun 5 22:12:54 2003
@@ -107,7 +107,7 @@
install_sh = @install_sh@
AUTOMAKE_OPTIONS = gnu
-SUBDIRS = libltdl addon base data src test
+SUBDIRS = addon base data src test
EXTRA_DIST = bootstrap pinball.spec clean

View File

@ -0,0 +1,19 @@
--- base/TextureUtil.cpp.orig Wed May 14 14:42:22 2003
+++ base/TextureUtil.cpp Sun Jun 8 22:02:21 2003
@@ -58,6 +58,7 @@
#if EM_USE_ALLEGRO
#include <allegro.h>
+#include <GL/gl.h>
BITMAP * backbuffer = NULL;
ZBUFFER * zbuffer = NULL;
#endif // EM_USE_ALLEGRO
@@ -92,7 +93,7 @@
for ( i = m_hImageName.begin();
i != m_hImageName.end();
i++) {
- glDeleteTextures (1, (*i).first ); //is that correct ?
+ glDeleteTextures (1, (GLuint *) (*i).first ); //is that correct ?
delete (*i).first ; // (*i).first = 0;
}
m_hImageName.erase ( m_hImageName.begin() , m_hImageName.end() );

View File

@ -1,11 +0,0 @@
--- ./base/TextureUtil.cpp.orig Fri Nov 1 14:49:57 2002
+++ ./base/TextureUtil.cpp Mon Nov 11 01:27:54 2002
@@ -18,7 +18,7 @@
#if EM_DEBUG
#include <GL/glu.h>
#endif
-#include <SDL/SDL.h>
+#include <SDL.h>
#include <SDL_image.h>
extern "C" {

View File

@ -1,6 +1,15 @@
--- configure.orig Wed Nov 6 12:03:53 2002
+++ configure Mon Nov 11 00:39:54 2002
@@ -713,8 +713,8 @@
--- configure.orig Thu May 29 06:47:26 2003
+++ configure Thu Jun 5 22:11:02 2003
@@ -419,7 +419,7 @@
PACKAGE_STRING='pinball 0.3.0'
PACKAGE_BUGREPORT='henqvist@users.sourceforge.net'
-ac_subdirs_all="$ac_subdirs_all libltdl"
+ac_subdirs_all="$ac_subdirs_all"
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
@@ -1879,12 +1879,12 @@
@ -9,40 +18,83 @@
+#CFLAGS="-g -W -Wall -O2"
+#CXXFLAGS="-g -W -Wall -O2"
SDL_VERSION=1.2.0
ALLEGRO_VERSION=4.0.0
@@ -5599,7 +5599,7 @@
fi
-subdirs="$subdirs libltdl"
+subdirs="$subdirs"
ac_ext=c
@@ -3258,16 +3258,6 @@
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
- case $enable_ltdl_convenience in
- no) { { echo "$as_me:$LINENO: error: this package needs a convenience libltdl" >&5
-echo "$as_me: error: this package needs a convenience libltdl" >&2;}
- { (exit 1); exit 1; }; } ;;
- "") enable_ltdl_convenience=yes
- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
- esac
- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
- INCLTDL='-I${top_srcdir}/''libltdl'
-
# Check whether --enable-shared or --disable-shared was given.
if test "${enable_shared+set}" = set; then
enableval="$enable_shared"
@@ -7866,7 +7856,8 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+LIBTOOL_DEPS="--disable-ltlibs $ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -7963,7 +7954,7 @@
use_allegro="no"
fi;
-if test x"$use_allegro" == "xno"; then
+if test x"$use_allegro" = xno; then
+if test x"$use_allegro" = "xno"; then
cat >> confdefs.h <<\EOF
#define EM_USE_SDL 1
@@ -6997,7 +6997,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include "allegro.h"
+#include <allegro.h>
char*
my_strdup (char *str)
@@ -7092,7 +7092,7 @@
#include "confdefs.h"
cat >>confdefs.h <<\_ACEOF
@@ -9996,7 +9987,7 @@
use_unittest="no"
fi;
#include <stdio.h>
-#include "ALLEGRO.h"
+#include <allegro.h>
-if test x"$use_unittest" == "xyes"; then
+if test x"$use_unittest" = "xyes"; then
int main(int argc, char *argv[])
{ return 0; }
@@ -7225,6 +7225,7 @@
int main () { int i; for (i = 0; i < 256; i++)
if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) exit(2);
exit (0); }
+END_OF_MAIN();
EOF
if { (eval echo configure:7231: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
@@ -10517,14 +10508,14 @@
# Check whether --with-debug or --without-debug was given.
-if test "${with_debug+set}" = set; then
+if test "set${with_debug}" = "set"; then
withval="$with_debug"
use_debug="yes"
else
use_debug="no"
fi;
-if test x"$use_debug" == "xyes"; then
+if test x"$use_debug" = "xyes"; then
cat >>confdefs.h <<\_ACEOF
#define EM_DEBUG 1
@@ -11187,8 +11178,8 @@
s,@ac_ct_RANLIB@,$ac_ct_RANLIB,;t t
s,@CPP@,$CPP,;t t
s,@LIBTOOL@,$LIBTOOL,;t t
-s,@INCLTDL@,$INCLTDL,;t t
-s,@LIBLTDL@,$LIBLTDL,;t t
+s,@INCLTDL@,,;t t
+s,@LIBLTDL@,,;t t
s,@EM_DATADIR@,$EM_DATADIR,;t t
s,@EM_LIBDIR@,$EM_LIBDIR,;t t
s,@EM_BUILD_ROOT@,$EM_BUILD_ROOT,;t t

View File

@ -0,0 +1,18 @@
--- ./src/EyeBehavior.cpp.orig Mon May 26 08:38:02 2003
+++ ./src/EyeBehavior.cpp Sun Jun 8 22:14:17 2003
@@ -55,6 +55,7 @@
EmAssert(table->getBall(2) != NULL, "Ball3 group NULL");
EmAssert(this->getParent() != NULL, "Parent group NULL");
+#if EM_USE_SDL
// short cuts for changing view F1, F2, F2, F4
if (Keyboard::isKeyDown(SDLK_F1)) {
Config::getInstance()->setView(0);
@@ -65,6 +66,7 @@
} else if (Keyboard::isKeyDown(SDLK_F4)) {
Config::getInstance()->setView(3);
}
+#endif
// the nudge code is here ----------------
if (m_iNudgeTick < 1) {

View File

@ -1,8 +0,0 @@
*****************************************************************************
pinball has been installed in %%PREFIX%%/bin.
Remark: if run under KDE/artsd, launch it as
`artsdsp pinball' (else you'll get /dev/dsp is busy!).
*****************************************************************************

View File

@ -1,38 +1,94 @@
bin/pinball
bin/pinball-config
include/pinball/BigSphere.h
include/pinball/ColorBehavior.h
include/pinball/Cone.h
include/pinball/Cube.h
include/pinball/Cylinder.h
include/pinball/Grid.h
include/pinball/KeyBehavior.h
include/pinball/KeyRotBehavior.h
include/pinball/Menu.h
include/pinball/Sphere.h
include/pinball/StdAnimation.h
include/pinball/TexAnimation.h
include/pinball/AlignVisitor.h
include/pinball/AllegroVisitor.h
include/pinball/AmbientLightVisitor.h
include/pinball/BaseTest.h
include/pinball/Behavior.h
include/pinball/BehaviorVisitor.h
include/pinball/BillBoard.h
include/pinball/Camera.h
include/pinball/CollisionBounds.h
include/pinball/Config.h
include/pinball/CollisionVisitor.h
include/pinball/EMath.h
include/pinball/EmFont.h
include/pinball/Engine.h
include/pinball/Group.h
include/pinball/Keyboard.h
include/pinball/Light.h
include/pinball/Node.h
include/pinball/OctTree.h
include/pinball/OpenGLVisitor.h
include/pinball/PointLightVisitor.h
include/pinball/Polygon.h
include/pinball/Private.h
include/pinball/Profiler.h
include/pinball/Shape3D.h
include/pinball/SignalSender.h
include/pinball/Sound.h
include/pinball/SoundUtil.h
include/pinball/SoundVisitor.h
include/pinball/StateMachine.h
include/pinball/TextureUtil.h
include/pinball/TransformVisitor.h
include/pinball/Visitor.h
include/pinball/ArmBehavior.h
include/pinball/BallGroup.h
include/pinball/BounceBehavior.h
include/pinball/BumperBehavior.h
include/pinball/EyeBehavior.h
include/pinball/FakeModuleBehavior.h
include/pinball/LoaderModule.h
include/pinball/Loader.h
include/pinball/Obj3dsUtil.h
include/pinball/Pinball.h
include/pinball/PlungerBehavior.h
include/pinball/Score.h
include/pinball/Script.h
include/pinball/SrcTest.h
include/pinball/StateBehavior.h
include/pinball/Table.h
include/pinball/pinconfig.h
lib/pinball/libemilia_addon.a
lib/pinball/libemilia_base.a
lib/pinball/libModuleTux.so.0
lib/pinball/libModuleTux.so
lib/pinball/libModuleTux.a
lib/pinball/libModuleProfessor.so.0
lib/pinball/libModuleProfessor.so
lib/pinball/libModuleProfessor.a
lib/pinball/libemilia_pin.a
lib/pinball/libModuleTest.so.0
lib/pinball/libModuleTest.so
lib/pinball/libModuleTest.a
%%PORTDOCS%%share/doc/pinball/README
share/pinball/font_34.png
share/pinball/font_35.pcx
share/pinball/libmodule_test.a
share/pinball/libmodule_test.la
share/pinball/libmodule_test.so
share/pinball/libmodule_test.so.0
share/pinball/pinball.xpm
share/pinball/professor/floor.png
share/pinball/professor/floor.png.pcx
share/pinball/professor/libmodule_professor.a
share/pinball/professor/libmodule_professor.la
share/pinball/professor/libmodule_professor.so
share/pinball/professor/libmodule_professor.so.0
share/pinball/professor/pinball.pbl
share/pinball/professor/professor.mid
share/pinball/tux/bump.wav
share/pinball/tux/bumphard.wav
share/pinball/tux/bumpsoft.wav
share/pinball/tux/bump.wav
share/pinball/tux/face.png
share/pinball/tux/face.png.pcx
share/pinball/tux/flip.wav
share/pinball/tux/floor.pbl
share/pinball/tux/floor2.png
share/pinball/tux/floor2.png.pcx
share/pinball/tux/game.mid
share/pinball/tux/gameover.wav
share/pinball/tux/intro.mid
share/pinball/tux/libmodule_tux.a
share/pinball/tux/libmodule_tux.la
share/pinball/tux/libmodule_tux.so
share/pinball/tux/libmodule_tux.so.0
share/pinball/tux/locklock.wav
share/pinball/tux/lock.wav
share/pinball/tux/loop.wav
share/pinball/tux/floor.pbl
share/pinball/tux/multiball.mid
share/pinball/tux/nudge.wav
share/pinball/tux/opentux.wav
@ -41,7 +97,19 @@ share/pinball/tux/shoot.wav
share/pinball/tux/tiles.png
share/pinball/tux/tiles.png.pcx
share/pinball/tux/up.wav
share/pinball/professor/floor.png
share/pinball/professor/floor.png.pcx
share/pinball/professor/pinball.pbl
share/pinball/professor/professor.mid
share/pinball/professor/professor.png
share/pinball/font_34.png
share/pinball/font_35.pcx
share/pinball/pinball.xpm
share/pinball/splash.png
share/pinball/splash.png.pcx
@dirrm include/pinball
@dirrm lib/pinball
%%PORTDOCS%%@dirrm share/doc/pinball
@dirrm share/pinball/professor
@dirrm share/pinball/tux
@dirrm share/pinball/professor
@dirrm share/pinball