Update to imap-2004.
Adds support for IPv6 amongst other things. PR: 66517 Submitted by: Christian Kratzer <ck@cksoft.de>
This commit is contained in:
parent
d60bc2b93b
commit
f6070309f2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110821
@ -6,9 +6,9 @@
|
||||
#
|
||||
|
||||
PORTNAME= cclient
|
||||
PORTVERSION= 2002d
|
||||
PORTVERSION= 2004
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= mail devel
|
||||
CATEGORIES= mail devel ipv6
|
||||
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
|
||||
http://atreides.freenix.no/~anders/%SUBDIR%/ \
|
||||
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/imap/%SUBDIR%/ \
|
||||
@ -56,11 +56,10 @@ post-patch:
|
||||
post-configure:
|
||||
@${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}"
|
||||
|
||||
HEADERS= c-client.h dummy.h env.h env_unix.h fdstring.h flocksim.h \
|
||||
flstring.h fs.h ftl.h imap4r1.h linkage.c linkage.h mail.h \
|
||||
mbox.h mbx.h mh.h misc.h mmdf.h mtx.h mx.h netmsg.h news.h \
|
||||
newsrc.h nl.h nntp.h osdep.h phile.h pop3.h pseudo.h rfc822.h \
|
||||
smtp.h sslio.h tcp.h tcp_unix.h tenex.h unix.h utf8.h
|
||||
HEADERS= c-client.h dummy.h env.h env_unix.h fdstring.h flstring.h \
|
||||
fs.h ftl.h imap4r1.h linkage.c linkage.h mail.h mbx.h mh.h \
|
||||
misc.h mx.h netmsg.h newsrc.h nl.h nntp.h osdep.h pseudo.h \
|
||||
rfc822.h smtp.h sslio.h tcp.h tcp_unix.h unix.h utf8.h
|
||||
PORTREV_H= ${WRKDIR}/portrevision.h
|
||||
|
||||
post-build:
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (imap-2002d.tar.Z) = 64e82a195d21481fc4c54c4ed9fe0527
|
||||
SIZE (imap-2002d.tar.Z) = 2155224
|
||||
MD5 (imap-2004.tar.Z) = ec3dafeeae320457a1d098157e9bf969
|
||||
SIZE (imap-2004.tar.Z) = 2220333
|
||||
|
@ -1,23 +1,26 @@
|
||||
--- src/osdep/unix/Makefile.orig Tue Oct 15 00:45:24 2002
|
||||
+++ src/osdep/unix/Makefile Sun Dec 1 15:40:42 2002
|
||||
@@ -22,18 +22,18 @@
|
||||
--- src/osdep/unix/Makefile.orig Fri Apr 30 02:08:48 2004
|
||||
+++ src/osdep/unix/Makefile Fri Jun 4 07:00:12 2004
|
||||
@@ -22,20 +22,20 @@
|
||||
|
||||
EXTRAAUTHENTICATORS=
|
||||
EXTRADRIVERS=mbox
|
||||
-PASSWDTYPE=std
|
||||
-SSLTYPE=nopwd
|
||||
-IP=4
|
||||
+PASSWDTYPE=pam
|
||||
+SSLTYPE=unix.nopwd
|
||||
+IP=6
|
||||
|
||||
|
||||
# Extended flags needed for SSL. You may need to modify.
|
||||
|
||||
-SSLDIR=/usr/local/ssl
|
||||
-SSLCERTS=$(SSLDIR)/certs
|
||||
-SSLINCLUDE=$(SSLDIR)/include
|
||||
-SSLLIB=$(SSLDIR)/lib
|
||||
+SSLDIR=$(OPENSSLBASE)
|
||||
+SSLCERTS=$(PREFIX)/certs
|
||||
SSLKEYS=$(SSLCERTS)
|
||||
-SSLINCLUDE=$(SSLDIR)/include
|
||||
-SSLLIB=$(SSLDIR)/lib
|
||||
+SSLINCLUDE=$(OPENSSLINC)
|
||||
+SSLLIB=$(OPENSSLLIB)
|
||||
|
||||
@ -26,7 +29,7 @@
|
||||
|
||||
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
|
||||
# to use this instead
|
||||
@@ -60,7 +60,7 @@
|
||||
@@ -62,7 +62,7 @@
|
||||
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
|
||||
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
|
||||
DCELDFLAGS= -ldce
|
||||
@ -35,7 +38,7 @@
|
||||
|
||||
|
||||
# Build parameters normally set by the individual port
|
||||
@@ -97,7 +97,7 @@
|
||||
@@ -99,7 +99,7 @@
|
||||
# Commands possibly overriden by the individual port
|
||||
|
||||
ARRC=ar rc
|
||||
@ -44,16 +47,16 @@
|
||||
LN=ln -s
|
||||
RANLIB=ranlib
|
||||
|
||||
@@ -115,7 +115,7 @@
|
||||
@@ -117,7 +117,7 @@
|
||||
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
|
||||
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
|
||||
unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
|
||||
unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
|
||||
-CFLAGS=-g
|
||||
+CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
|
||||
|
||||
CAT=cat
|
||||
MAKE=make
|
||||
@@ -132,6 +132,10 @@
|
||||
@@ -134,6 +134,10 @@
|
||||
PASSWDTYPE=$(PASSWDTYPE) SSLTYPE=$(SSLTYPE)
|
||||
|
||||
|
||||
@ -64,7 +67,7 @@
|
||||
# Here if no make argument established
|
||||
|
||||
missing: osdep.h
|
||||
@@ -212,13 +216,14 @@
|
||||
@@ -214,13 +218,14 @@
|
||||
BASECFLAGS="-g -Dconst="
|
||||
|
||||
bsf: # FreeBSD
|
||||
@ -82,7 +85,7 @@
|
||||
|
||||
bsi: # BSD/i386
|
||||
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
|
||||
@@ -762,23 +767,35 @@
|
||||
@@ -786,23 +791,35 @@
|
||||
|
||||
# Build it!
|
||||
|
||||
@ -121,16 +124,16 @@
|
||||
|
||||
|
||||
# Dependencies
|
||||
@@ -812,7 +829,7 @@
|
||||
@@ -835,7 +852,7 @@
|
||||
|
||||
# OS-dependent
|
||||
|
||||
-osdep.o:mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \
|
||||
+OSDEPS= mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \
|
||||
osdep.h env_unix.h tcp_unix.h \
|
||||
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c \
|
||||
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c ip_unix.c\
|
||||
auths.c crexcl.c flocksim.c nfstest.c flcksafe.c fsync.c gethstid.c \
|
||||
@@ -824,12 +841,19 @@
|
||||
@@ -848,12 +865,19 @@
|
||||
write.c sslstdio.c \
|
||||
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
|
||||
OSCFLAGS
|
||||
|
@ -3,7 +3,6 @@ include/c-client/dummy.h
|
||||
include/c-client/env.h
|
||||
include/c-client/env_unix.h
|
||||
include/c-client/fdstring.h
|
||||
include/c-client/flocksim.h
|
||||
include/c-client/flstring.h
|
||||
include/c-client/fs.h
|
||||
include/c-client/ftl.h
|
||||
@ -11,28 +10,21 @@ include/c-client/imap4r1.h
|
||||
include/c-client/linkage.c
|
||||
include/c-client/linkage.h
|
||||
include/c-client/mail.h
|
||||
include/c-client/mbox.h
|
||||
include/c-client/mbx.h
|
||||
include/c-client/mh.h
|
||||
include/c-client/misc.h
|
||||
include/c-client/mmdf.h
|
||||
include/c-client/mtx.h
|
||||
include/c-client/mx.h
|
||||
include/c-client/netmsg.h
|
||||
include/c-client/news.h
|
||||
include/c-client/newsrc.h
|
||||
include/c-client/nl.h
|
||||
include/c-client/nntp.h
|
||||
include/c-client/osdep.h
|
||||
include/c-client/phile.h
|
||||
include/c-client/pop3.h
|
||||
include/c-client/pseudo.h
|
||||
include/c-client/rfc822.h
|
||||
include/c-client/smtp.h
|
||||
include/c-client/sslio.h
|
||||
include/c-client/tcp.h
|
||||
include/c-client/tcp_unix.h
|
||||
include/c-client/tenex.h
|
||||
include/c-client/unix.h
|
||||
include/c-client/utf8.h
|
||||
include/c-client/portrevision.h
|
||||
|
Loading…
Reference in New Issue
Block a user