- Update to 1.003009

PR:		144684
Submitted by:	Ashish SHUKLA <wahjava@gmail.com> (maintainer)
This commit is contained in:
Martin Wilke 2010-03-17 07:42:08 +00:00
parent 10dc0b9df2
commit f5ce3818dd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=251170
4 changed files with 11 additions and 30 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= Devel-REPL
PORTVERSION= 1.003007
PORTREVISION= 1
PORTVERSION= 1.003009
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@ -24,16 +23,19 @@ BUILD_DEPENDS= p5-Moose>=0.74:${PORTSDIR}/devel/p5-Moose \
p5-Task-Weaken>0:${PORTSDIR}/devel/p5-Task-Weaken \
p5-PPI>0:${PORTSDIR}/textproc/p5-PPI \
p5-Data-Dump-Streamer>0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
p5-Data-Dumper-Concise>0:${PORTSDIR}/devel/p5-Data-Dumper-Concise \
p5-File-Next>0:${PORTSDIR}/sysutils/p5-File-Next \
p5-B-Keywords>0:${PORTSDIR}/devel/p5-B-Keywords \
p5-Lexical-Persistence>0:${PORTSDIR}/devel/p5-Lexical-Persistence \
p5-App-Nopaste>0:${PORTSDIR}/www/p5-App-Nopaste \
p5-Module-Refresh>0:${PORTSDIR}/devel/p5-Module-Refresh
p5-Module-Refresh>0:${PORTSDIR}/devel/p5-Module-Refresh \
p5-Sys-SigAction>0:${PORTSDIR}/devel/p5-Sys-SigAction
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= 5.8.1+
MAN3= Devel::REPL.3 \
Devel::REPL::Overview.3 \
Devel::REPL::Plugin::B::Concise.3 \
Devel::REPL::Plugin::Colors.3 \
Devel::REPL::Plugin::Commands.3 \
@ -44,6 +46,7 @@ MAN3= Devel::REPL.3 \
Devel::REPL::Plugin::CompletionDriver::LexEnv.3 \
Devel::REPL::Plugin::CompletionDriver::Methods.3 \
Devel::REPL::Plugin::CompletionDriver::Turtles.3 \
Devel::REPL::Plugin::DDC.3 \
Devel::REPL::Plugin::DDS.3 \
Devel::REPL::Plugin::DumpHistory.3 \
Devel::REPL::Plugin::FancyPrompt.3 \
@ -65,7 +68,4 @@ MAN3= Devel::REPL.3 \
Devel::REPL::Plugin::Turtles.3 \
Devel::REPL::Profile.3
post-patch:
@${RM} ${WRKSRC}/lib/Devel/REPL/Meta/Plugin.pm.orig
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (Devel-REPL-1.003007.tar.gz) = 2feec7e574161c6551532295585857ab
SHA256 (Devel-REPL-1.003007.tar.gz) = 56960821b0342233253d15648a9420c29b01e97b127a76190d2ec05ee020e1b4
SIZE (Devel-REPL-1.003007.tar.gz) = 44082
MD5 (Devel-REPL-1.003009.tar.gz) = 6d74d8a1f32ace0f11a536cf4b237a18
SHA256 (Devel-REPL-1.003009.tar.gz) = 2303b64667c0066b81eca47a175937440a6d6903ef38025966fb8087eebca48e
SIZE (Devel-REPL-1.003009.tar.gz) = 49226

View File

@ -1,21 +0,0 @@
$FreeBSD$
--- lib/Devel/REPL/Meta/Plugin.pm.orig
+++ lib/Devel/REPL/Meta/Plugin.pm
@@ -6,6 +6,7 @@
before 'apply' => sub {
my ($self, $other) = @_;
+ return unless $other->isa('Devel::REPL');
if (my $pre = $self->get_method('BEFORE_PLUGIN')) {
$pre->body->($other, $self);
}
@@ -13,6 +14,7 @@
after 'apply' => sub {
my ($self, $other) = @_;
+ return unless $other->isa('Devel::REPL');
if (my $pre = $self->get_method('AFTER_PLUGIN')) {
$pre->body->($other, $self);
}

View File

@ -2,6 +2,7 @@ bin/re.pl
%%SITE_PERL%%/Devel/REPL.pm
%%SITE_PERL%%/Devel/REPL/Error.pm
%%SITE_PERL%%/Devel/REPL/Meta/Plugin.pm
%%SITE_PERL%%/Devel/REPL/Overview.pod
%%SITE_PERL%%/Devel/REPL/Plugin.pm
%%SITE_PERL%%/Devel/REPL/Plugin/B/Concise.pm
%%SITE_PERL%%/Devel/REPL/Plugin/Colors.pm
@ -13,6 +14,7 @@ bin/re.pl
%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/LexEnv.pm
%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/Methods.pm
%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/Turtles.pm
%%SITE_PERL%%/Devel/REPL/Plugin/DDC.pm
%%SITE_PERL%%/Devel/REPL/Plugin/DDS.pm
%%SITE_PERL%%/Devel/REPL/Plugin/DumpHistory.pm
%%SITE_PERL%%/Devel/REPL/Plugin/FancyPrompt.pm