- Improve handling of configuration file

PR:		ports/76419
Submitted by:	Florent Thoumie <flz@xbsd.org>
Approved by:	David Yeske <dyeske@yahoo.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-01-27 21:12:36 +00:00
parent 9ac8630fb4
commit f57b769c71
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127495
3 changed files with 20 additions and 1 deletions

View File

@ -6,7 +6,7 @@
PORTNAME= netboot
PORTVERSION= 0.9.8
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -20,4 +20,9 @@ GNU_CONFIGURE= yes
MAN5= netboot.5 netboot.config.5 netboot.drivers.5 netboot.db.5
MAN8= mknbi-mgl.8 makerom.8 mknbi-dos.8 mknbi-linux.8
post-install:
@if [ ! -f ${PREFIX}/etc/netboot.config ]; then \
${CP} ${PREFIX}/etc/netboot.config-dist ${PREFIX}/etc/netboot.config; \
fi
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- misc/Makefile.orig Wed Jan 19 15:24:01 2005
+++ misc/Makefile Wed Jan 19 15:24:27 2005
@@ -77,7 +77,7 @@
$(INSTALL) -d $(sysconfdir)
$(INSTALL) -d $(nblibdir)
$(INSTALL) -d $(mandir)/man$(MANEXT)
- $(INSTALL) -m 644 -o bin -g bin $(nbconfig) $(sysconfdir)/$(nbconfig)
+ $(INSTALL) -m 644 -o bin -g bin $(nbconfig) $(sysconfdir)/$(nbconfig)-dist
$(INSTALL) -m 644 -o bin -g bin $(drivers) $(nblibdir)/$(drivers)
$(INSTALL) -m 644 -o bin -g bin netboot.man $(mandir)/man$(MANEXT)/netboot.$(MANEXT)
$(INSTALL) -m 644 -o bin -g bin $(nbconfig).man $(mandir)/man$(MANEXT)/$(nbconfig).$(MANEXT)

View File

@ -2,6 +2,9 @@ bin/makerom
bin/mknbi-dos
bin/mknbi-linux
bin/mknbi-mgl
@unexec if cmp -s %D/etc/netboot.config %D/etc/netboot.config-dist; then rm -f %D/etc/netboot.config; fi
etc/netboot.config-dist
@exec [ -f %B/netboot.config ] || cp %B/%f %B/netboot.config
lib/netboot/netboot.drivers
lib/netboot/binaries/floppy.bin
lib/netboot/binaries/floppy86.bin