Upgrade to version 1.3.3 - 2012.02.22

* Change build system to CMake.
 * Add support ConsoleKit.
 * Fix some bugs....

For the port:

 * The Berlios mirrors don't have the new version, so update the
   MASTER_SITES per the instructions on the web page.
 * Add the ability to verify the PGP signature on the distfile
 * Add consolekit support, and switch build to CMake
 * Remove no-longer relevant patches
 * Add patches necessary to work with the new build system
 * Add a patch for a nicer default theme
 * Fix the console command in the slim.conf patch
 * Use @dirrmtry in the plist in case the user has installed themes
 * Remove uneeded blank lines around (and in) pkg-message
 * Add REQUIRE: dbus to the rc.d script to accomodate consolekit

The PR mentioned the new version, but did not supply a patch

PR:		ports/166964
Submitted by:	Dave <davemorgan353@btinternet.com>
Approved by:	maintainer timeout
This commit is contained in:
Doug Barton 2012-06-03 06:55:46 +00:00
parent a50c1cb647
commit f53379b163
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298051
10 changed files with 67 additions and 92 deletions

View File

@ -3,55 +3,52 @@
# Whom: Tobias Roth <ports@fsck.ch>
#
# $FreeBSD$
#
PORTNAME= slim
PORTVERSION= 1.3.2
PORTREVISION= 3
PORTVERSION= 1.3.3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://depot.fsck.ch/mirror/distfiles/
MASTER_SITE_SUBDIR=slim
MASTER_SITES= http://slim.berlios.de/releases/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.release.asc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= Graphical login manager for X11, derived from Login.app
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
ck-connector.0:${PORTSDIR}/sysutils/consolekit \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig
LICENSE= GPLv2
USE_CMAKE= yes
USE_XORG= x11 xft xmu xorg-server xrender
USE_RC_SUBR= slim.sh
SUB_FILES= pkg-message
MAN1= slim.1
CMAKE_ARGS= -DUSE_CONSOLEKIT=yes
MAKEFILE= Makefile.freebsd
MAN1= slim.1
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/${PORTNAME}.conf
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.release.asc
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
@${MKDIR} ${DATADIR}/themes/default
@${INSTALL_DATA} ${WRKSRC}/themes/default/${PORTNAME}.theme ${DATADIR}/themes/default
@${INSTALL_DATA} ${WRKSRC}/themes/default/panel.png ${DATADIR}/themes/default
@${INSTALL_DATA} ${WRKSRC}/themes/default/background.jpg ${DATADIR}/themes/default
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/${PORTNAME}.conf
@${REINPLACE_CMD} -e 's|"/etc"|"${PREFIX}/etc"|' \
-e 's|slim.conf|slim.conf.sample|' \
${WRKSRC}/CMakeLists.txt
@${MV} ${WRKSRC}/slim.conf ${WRKSRC}/slim.conf.sample
@${REINPLACE_CMD} -e 's|std::snprintf|snprintf|' ${WRKSRC}/Ck.cpp
post-install:
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
@if [ ! -f ${PREFIX}/etc/slim.conf ]; then \
${INSTALL_DATA} -p ${WRKSRC}/slim.conf ${PREFIX}/etc/slim.conf ; \
${CP} ${PREFIX}/etc/slim.conf.sample ${PREFIX}/etc/slim.conf ; \
fi
@${ECHO_MSG} ""
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
.include <bsd.port.post.mk>

View File

@ -1,2 +1,4 @@
SHA256 (slim-1.3.2.tar.gz) = f1560125005f253b9b88220598fed7a9575ef405716862c6ca3fcc72dbd482b8
SIZE (slim-1.3.2.tar.gz) = 220592
SHA256 (slim-1.3.3.tar.gz) = c15248d99c36cb45c66298b0797246d43cd851765536746a431a1533e48dbbb9
SIZE (slim-1.3.3.tar.gz) = 226797
SHA256 (slim-1.3.3.tar.gz.release.asc) = 14d2d9c1048ca624c8521bb815eb9bbd2802d03eea72069a5afd861ac970d430
SIZE (slim-1.3.3.tar.gz.release.asc) = 1145

View File

@ -1,41 +0,0 @@
--- Makefile.freebsd.orig 2009-05-20 18:53:00.000000000 +0400
+++ Makefile.freebsd 2009-05-20 18:53:39.000000000 +0400
@@ -3,18 +3,14 @@
# Edit the following section to adjust the options
# to fit into your operating system / distribution
#######################################################
-CXX=/usr/bin/g++
-CC=/usr/bin/gcc
-CFLAGS=-I. -I/usr/local/include/freetype2 -I/usr/local/include/freetype2/config -I/usr/local/include/libpng -I/usr/local/include -I/usr/include
-LDFLAGS= -L/usr/local/lib -lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng -lz -lm -lcrypt -lXmu -lpng -ljpeg
-CUSTOM=-DNEEDS_BASENAME
-.ifdef(USE_PAM)
- LDFLAGS+= -lpam
- CUSTOM+= -DUSE_PAM
-.endif
-PREFIX=/usr
-CFGDIR=/etc
-MANDIR=/usr/share/man
+CXX?=/usr/bin/g++
+CC?=/usr/bin/gcc
+CFLAGS+=-I${LOCALBASE}/include `freetype-config --cflags` `libpng-config --cflags`
+LDFLAGS=-L${LOCALBASE}/lib `freetype-config --libs` `libpng-config --libs` -lXft -lX11 -lXrender -lfontconfig -lz -lm -lcrypt -lXmu -ljpeg -lpam
+CUSTOM=-DNEEDS_BASENAME -DUSE_PAM
+PREFIX?=${LOCALBASE}
+CFGDIR=$(PREFIX)/etc
+MANDIR=$(MANPREFIX)/man
DESTDIR=
#######################################################
@@ -25,10 +21,7 @@
-DPKGDATADIR=\"$(PREFIX)/share/slim\" -DSYSCONFDIR=\"$(CFGDIR)\"
OBJECTS=jpeg.o png.o main.o image.o numlock.o cfg.o switchuser.o app.o \
- panel.o util.o
-.ifdef USE_PAM
- OBJECTS+=PAM.o
-.endif
+ panel.o util.o PAM.o
all: slim

View File

@ -1,10 +0,0 @@
--- panel.cpp.orig Thu May 19 22:46:22 2005
+++ panel.cpp Thu May 19 22:47:12 2005
@@ -10,6 +10,7 @@
*/
#include <sstream>
+#include <libgen.h>
#include "panel.h"
using namespace std;

View File

@ -1,11 +0,0 @@
--- png.c.orig 2010-07-08 07:04:10.000000000 +0200
+++ png.c 2012-05-06 10:02:42.000000000 +0200
@@ -57,7 +57,7 @@
return(0);
}
- if (setjmp(png_ptr->jmpbuf))
+ if (setjmp(png_jmpbuf(png_ptr)))
{
png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp) NULL);
fclose(infile);

View File

@ -18,7 +18,7 @@
reboot_cmd /sbin/shutdown -r now
-console_cmd /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
-#suspend_cmd /usr/sbin/suspend
+console_cmd /usr/X11R6/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
+console_cmd %%LOCALBASE%%/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/motd; exec /bin/login"
+suspend_cmd /usr/sbin/acpiconf -s 3
# Full path to the xauth binary

View File

@ -0,0 +1,38 @@
--- themes/default/slim.theme.orig 2012-02-21 15:59:52.000000000 -0800
+++ themes/default/slim.theme 2012-06-02 23:23:10.000000000 -0700
@@ -1,9 +1,10 @@
# text04 theme for SLiM
# by Johannes Winkelmann
+# ... with improvements by Doug Barton, dougb@FreeBSD.org
# Messages (ie: shutdown)
msg_color #FFFFFF
-msg_font Verdana:size=18:bold:dpi=75
+msg_font Verdana:size=20:bold:dpi=75
msg_x 50%
msg_y 40%
msg_shadow_color #702342
@@ -27,11 +28,21 @@
username_color #f9f9f9
username_x 280
username_y 183
-password_x 50%
+password_x 280
password_y 183
-username_shadow_color #702342
username_shadow_xoffset 1
username_shadow_yoffset 1
+username_shadow_color #702342
+
+# Welcome message
+welcome_font Verdana:size=12:dpi=75
+welcome_color #f9f9f9
+welcome_x 280
+welcome_y 210
+welcome_shadow_xoffset 1
+welcome_shadow_yoffset 1
+welcome_shadow_color #702342
username_msg Username:
password_msg Password:
+welcome_msg %host

View File

@ -4,4 +4,3 @@ Thanks to Nikos Ntarmos, it is now possible to start slim from /etc/ttys.
Please see %%PREFIX%%/etc/rc.d/slim for instructions on how to do that.
*************************************************************************

View File

@ -3,9 +3,9 @@
# $FreeBSD$
#
# PROVIDE: slim
# REQUIRE: LOGIN
# REQUIRE: LOGIN dbus
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable slim:
# slim_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable slim
@ -51,6 +51,7 @@ slim_rmfile ()
[ -e "$file" ] && unlink $file
done
# Needed if neither file exists
return 0
}

View File

@ -3,8 +3,8 @@ bin/slim
%%DATADIR%%/themes/default/panel.png
%%DATADIR%%/themes/default/slim.theme
@dirrm %%DATADIR%%/themes/default
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%
@dirrmtry %%DATADIR%%/themes
@dirrmtry %%DATADIR%%
@unexec if cmp -s %D/etc/slim.conf.sample %D/etc/slim.conf; then rm -f %D/etc/slim.conf; fi
etc/slim.conf.sample
@exec if [ ! -f %D/etc/slim.conf ] ; then cp -p %D/%F %B/slim.conf; fi