- Fix build on DragonFly

- Add LICENSE
This commit is contained in:
Dmitry Marakasov 2015-03-27 14:31:49 +00:00
parent cf044da9b2
commit f4d4e6343a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=382421
2 changed files with 17 additions and 8 deletions

View File

@ -11,6 +11,9 @@ MASTER_SITES= http://www.iua.upf.es/~mdeboer/resorama/jigzo/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OpenGL jigsaw puzzle game
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/GPL.txt
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg
@ -32,8 +35,6 @@ DESKTOP_ENTRIES="Jigzo" \
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e "s|int_p_NULL|NULL|g" \
${WRKSRC}/src/Loader.cxx

View File

@ -1,6 +1,14 @@
--- src/main.cxx.orig 2013-09-14 02:26:08.857226185 +0400
+++ src/main.cxx 2013-09-14 02:28:44.311226803 +0400
@@ -56,6 +56,7 @@
--- src/main.cxx.orig 2008-05-09 02:39:02.000000000 +0400
+++ src/main.cxx 2015-03-27 17:21:48.934373000 +0300
@@ -47,6 +47,7 @@
#include <fstream>
#include <string>
#include <sstream>
+#include <algorithm>
#ifdef WIN32
#include <io.h>
@@ -56,6 +57,7 @@
#include <sys/types.h>
#endif
#include <dirent.h>
@ -8,7 +16,7 @@
#include "Screen.hxx"
#include "Sprite.hxx"
@@ -1540,7 +1541,7 @@
@@ -1540,7 +1542,7 @@
int i;
Uint8 *keys = SDL_GetKeyState(&i);
SDL_Event event;
@ -17,7 +25,7 @@
//static Uint32 mark = 0;
SDL_Delay(10);
while (SDL_PollEvent(&event)) {
@@ -1579,7 +1580,7 @@
@@ -1579,7 +1581,7 @@
if (clickLeave)
{
if (mode == intro)
@ -26,7 +34,7 @@
else if (mode == browse) {
FadeOutTo(end_browse,start_intro);
} else {
@@ -1587,7 +1588,7 @@
@@ -1587,7 +1589,7 @@
}
}
if (event.type == SDL_QUIT) {