gecko: expose Wayland support
This commit is contained in:
parent
d6bdbcf80d
commit
f4b5e31301
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482626
@ -285,9 +285,11 @@ MOZ_EXPORT+= MOZ_GOOGLE_API_KEY=AIzaSyBsp9n41JLW8jCokwn7vhoaMejDFRd1mp8
|
||||
|
||||
.if ${PORT_OPTIONS:MGTK2}
|
||||
MOZ_TOOLKIT= cairo-gtk2
|
||||
.elif ${PORT_OPTIONS:MWAYLAND}
|
||||
MOZ_TOOLKIT= cairo-gtk3-wayland
|
||||
.endif
|
||||
|
||||
.if ${MOZ_TOOLKIT:Mcairo-gtk3}
|
||||
.if ${MOZ_TOOLKIT:Mcairo-gtk3*}
|
||||
BUILD_DEPENDS+= gtk3>=3.14.6:x11-toolkits/gtk30
|
||||
USE_GNOME+= gdkpixbuf2 gtk20 gtk30
|
||||
.else # gtk2, cairo-gtk2
|
||||
@ -574,6 +576,17 @@ gecko-moz-pis-patch:
|
||||
@${MOZCONFIG_SED} < ${FILESDIR}/${moz} > ${WRKDIR}/${moz}
|
||||
.endfor
|
||||
|
||||
pre-configure: gecko-pre-configure
|
||||
|
||||
gecko-pre-configure:
|
||||
.if ${PORT_OPTIONS:MWAYLAND}
|
||||
# .if !exists() evaluates too early before gtk3 has a chance to be installed
|
||||
@if ! pkg-config --exists gtk+-wayland-3.0; then \
|
||||
${ECHO_MSG} "${PKGNAME}: Needs gtk3 with WAYLAND support enabled."; \
|
||||
${FALSE}; \
|
||||
fi
|
||||
.endif
|
||||
|
||||
pre-install: gecko-moz-pis-pre-install
|
||||
post-install-script: gecko-create-plist
|
||||
|
||||
|
28
mail/thunderbird/files/patch-bug1474265
Normal file
28
mail/thunderbird/files/patch-bug1474265
Normal file
@ -0,0 +1,28 @@
|
||||
commit 1e7aec82f43d
|
||||
Author: Martin Stransky <stransky@redhat.com>
|
||||
Date: Mon Jul 9 13:18:59 2018 +0200
|
||||
|
||||
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp. r=jhorak, a=jcristau
|
||||
|
||||
MozReview-Commit-ID: HIz4gZOzfOE
|
||||
|
||||
--HG--
|
||||
extra : source : f1f6e434d3a86d729a39aabf00e8c057c794bed5
|
||||
extra : intermediate-source : f27de60fff477d7b61b5509fc2c9c9c098f5b953
|
||||
---
|
||||
widget/xremoteclient/DBusRemoteClient.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git widget/xremoteclient/DBusRemoteClient.cpp widget/xremoteclient/DBusRemoteClient.cpp
|
||||
index 1919ad027a14..6b242f075913 100644
|
||||
--- widget/xremoteclient/DBusRemoteClient.cpp
|
||||
+++ widget/xremoteclient/DBusRemoteClient.cpp
|
||||
@@ -142,7 +142,7 @@ DBusRemoteClient::GetRemoteDestinationName(const char *aProgram,
|
||||
(bool (*)(const char *, DBusError *))
|
||||
dlsym(RTLD_DEFAULT, "dbus_validate_bus_name");
|
||||
if (!sDBusValidateBusName) {
|
||||
- return false
|
||||
+ return false;
|
||||
}
|
||||
|
||||
if (!sDBusValidateBusName(aDestinationName.get(), nullptr)) {
|
12
mail/thunderbird/files/patch-bug1500484
Normal file
12
mail/thunderbird/files/patch-bug1500484
Normal file
@ -0,0 +1,12 @@
|
||||
Drop unused header breaking build on non-Linux
|
||||
|
||||
--- widget/gtk/nsClipboardWayland.cpp
|
||||
+++ widget/gtk/nsClipboardWayland.cpp
|
||||
@@ -29,7 +29,6 @@
|
||||
|
||||
#include <gtk/gtk.h>
|
||||
#include <poll.h>
|
||||
-#include <sys/epoll.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
28
www/firefox-esr/files/patch-bug1474265
Normal file
28
www/firefox-esr/files/patch-bug1474265
Normal file
@ -0,0 +1,28 @@
|
||||
commit 1e7aec82f43d
|
||||
Author: Martin Stransky <stransky@redhat.com>
|
||||
Date: Mon Jul 9 13:18:59 2018 +0200
|
||||
|
||||
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp. r=jhorak, a=jcristau
|
||||
|
||||
MozReview-Commit-ID: HIz4gZOzfOE
|
||||
|
||||
--HG--
|
||||
extra : source : f1f6e434d3a86d729a39aabf00e8c057c794bed5
|
||||
extra : intermediate-source : f27de60fff477d7b61b5509fc2c9c9c098f5b953
|
||||
---
|
||||
widget/xremoteclient/DBusRemoteClient.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git widget/xremoteclient/DBusRemoteClient.cpp widget/xremoteclient/DBusRemoteClient.cpp
|
||||
index 1919ad027a14..6b242f075913 100644
|
||||
--- widget/xremoteclient/DBusRemoteClient.cpp
|
||||
+++ widget/xremoteclient/DBusRemoteClient.cpp
|
||||
@@ -142,7 +142,7 @@ DBusRemoteClient::GetRemoteDestinationName(const char *aProgram,
|
||||
(bool (*)(const char *, DBusError *))
|
||||
dlsym(RTLD_DEFAULT, "dbus_validate_bus_name");
|
||||
if (!sDBusValidateBusName) {
|
||||
- return false
|
||||
+ return false;
|
||||
}
|
||||
|
||||
if (!sDBusValidateBusName(aDestinationName.get(), nullptr)) {
|
12
www/firefox-esr/files/patch-bug1500484
Normal file
12
www/firefox-esr/files/patch-bug1500484
Normal file
@ -0,0 +1,12 @@
|
||||
Drop unused header breaking build on non-Linux
|
||||
|
||||
--- widget/gtk/nsClipboardWayland.cpp
|
||||
+++ widget/gtk/nsClipboardWayland.cpp
|
||||
@@ -29,7 +29,6 @@
|
||||
|
||||
#include <gtk/gtk.h>
|
||||
#include <poll.h>
|
||||
-#include <sys/epoll.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
@ -2,7 +2,7 @@
|
||||
|
||||
OPTIONS_DEFINE+= BUNDLED_CAIRO CANBERRA DBUS DEBUG DTRACE FFMPEG GCONF \
|
||||
INTEGER_SAMPLES LIBPROXY \
|
||||
OPTIMIZED_CFLAGS PROFILE TEST
|
||||
OPTIMIZED_CFLAGS PROFILE TEST WAYLAND
|
||||
|
||||
OPTIONS_DEFAULT+= DBUS FFMPEG GCONF OPTIMIZED_CFLAGS PROFILE \
|
||||
${OPTIONS_MULTI_AUDIO:NSNDIO} \
|
||||
|
12
www/firefox/files/patch-bug1500484
Normal file
12
www/firefox/files/patch-bug1500484
Normal file
@ -0,0 +1,12 @@
|
||||
Drop unused header breaking build on non-Linux
|
||||
|
||||
--- widget/gtk/nsClipboardWayland.cpp
|
||||
+++ widget/gtk/nsClipboardWayland.cpp
|
||||
@@ -29,7 +29,6 @@
|
||||
|
||||
#include <gtk/gtk.h>
|
||||
#include <poll.h>
|
||||
-#include <sys/epoll.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
@ -41,7 +41,7 @@ MOZ_OPTIONS= --enable-application=browser \
|
||||
--enable-jemalloc-lib
|
||||
|
||||
OPTIONS_DEFAULT= BUNDLED_CAIRO GTK2
|
||||
OPTIONS_EXCLUDE= DTRACE INTEGER_SAMPLES JACK TEST
|
||||
OPTIONS_EXCLUDE= DTRACE INTEGER_SAMPLES JACK TEST WAYLAND
|
||||
|
||||
.include "${.CURDIR}/../../www/firefox/Makefile.options"
|
||||
|
||||
|
@ -46,6 +46,7 @@ OPTIONS_DEFINE= LDAP LIGHTNING RUST
|
||||
OPTIONS_SINGLE= TOOLKIT
|
||||
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
|
||||
OPTIONS_DEFAULT=CANBERRA GTK3 LDAP LIGHTNING
|
||||
OPTIONS_EXCLUDE=WAYLAND
|
||||
|
||||
LDAP_DESC?= LDAP support for Mailnews
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user