games/devilutionX: Update to 0.5.0

This release builds fine with Clang now.

PR:		241336
Submitted by:	benny.goemans@gmail.com (maintainer)
This commit is contained in:
Tobias Kortkamp 2019-11-02 11:09:31 +00:00
parent f8ec4110ff
commit f48f3ed455
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=516296
5 changed files with 43 additions and 17 deletions

View File

@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= devilutionX
PORTVERSION= 0.4.0
PORTREVISION= 1
PORTVERSION= 0.5.0
PORTREVISION= 0
CATEGORIES= games
MAINTAINER= benny.goemans@gmail.com
@ -10,20 +10,15 @@ COMMENT= Open-source implementation of Diablo Game engine
LICENSE= UNLICENSE
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Uses inline x86 assembly
LIB_DEPENDS= libsodium.so:security/libsodium
USES= cmake dos2unix sdl
USE_GCC= yes
USE_SDL= mixer2 sdl2 ttf2
PLIST_FILES= bin/devilutionx
USE_GITHUB= yes
GH_ACCOUNT= diasurgical
GH_PROJECT= devilutionX
OPTIONS_DEFAULT= RELEASE

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1558349866
SHA256 (diasurgical-devilutionX-0.4.0_GH0.tar.gz) = 2a2ca9c375aaca6958a4bcca001acf7e714e86adca80b1c03684befa48ea576c
SIZE (diasurgical-devilutionX-0.4.0_GH0.tar.gz) = 1351201
TIMESTAMP = 1570734030
SHA256 (diasurgical-devilutionX-0.5.0_GH0.tar.gz) = 45f779084aa7459880e5eab1bf3d63dcd223d937485a840dc055e7d1e8eace5c
SIZE (diasurgical-devilutionX-0.5.0_GH0.tar.gz) = 1767600

View File

@ -0,0 +1,10 @@
--- 3rdParty/StormLib/src/StormPort.h.orig 2019-10-11 11:58:58 UTC
+++ 3rdParty/StormLib/src/StormPort.h
@@ -165,6 +165,7 @@
#include <ctype.h>
#include <assert.h>
#include <errno.h>
+ #include <strings.h>
#ifndef __BIG_ENDIAN__
#define PLATFORM_LITTLE_ENDIAN

View File

@ -1,8 +1,32 @@
--- CMakeLists.txt.orig 2019-05-13 15:14:29 UTC
--- CMakeLists.txt.orig 2019-10-11 23:27:07 UTC
+++ CMakeLists.txt
@@ -287,3 +287,5 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
# Silence appfat.cpp warnings
@@ -68,6 +68,9 @@ list(APPEND CMAKE_MODULE_PATH "${DevilutionX_SOURCE_DI
if(${CMAKE_SYSTEM_NAME} STREQUAL FreeBSD)
set(ASAN OFF)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DO_LARGEFILE=0 -Dstat64=stat -Dlstat64=lstat -Dlseek64=lseek -Doff64_t=off_t -Dfstat64=fstat -Dftruncate64=ftruncate")
+ add_definitions(-D__BSD_VISIBLE=1)
+ add_definitions(-D__POSIX_VISIBLE=200809L)
+ add_definitions(-D__XSI_VISIBLE=1)
endif()
if(WIN32)
@@ -337,8 +340,8 @@ endif()
if(NOT CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
# Change __FILE__ to only show the path relative to the project folder
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-builtin-macro-redefined -D'__FILE__=\"$(subst $(realpath ${CMAKE_SOURCE_DIR})/,,$(abspath $<))\"'")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-builtin-macro-redefined -D'__FILE__=\"$(subst $(realpath ${CMAKE_SOURCE_DIR})/,,$(abspath $<))\"'")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-builtin-macro-redefined")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-builtin-macro-redefined")
if(DEBUG)
# Note: For Valgrind suppor.
@@ -368,6 +371,8 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
# Silence appfat.cpp warnings
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-narrowing")
endif()
+
+install(TARGETS devilutionx DESTINATION ${BINDIR})
if(APPLE)
set_source_files_properties("./Packaging/macOS/AppIcon.icns" PROPERTIES MACOSX_PACKAGE_LOCATION Resources)

View File

@ -7,11 +7,8 @@ If you don't own it yet, you can buy it at https://www.gog.com/game/diablo
Copy DIABDAT.MPQ to ~/.local/share/diasurgical/devilution/diabdat.mpq
Pay attention to the case, the resulting file needs to be entirely lowercase!
If you have any issues with this game, file a bug report on the GitHub page:
If you have any issues with this game, please file a bug report on the GitHub page:
https://github.com/diasurgical/devilutionX/issues
Note that only 32-bit builds are currently supported, amd64 is experimental but
seems to be working fine as far as I've tested.
EOM
}
]