This is the first release of a shoot em up game written in SDL. The

objective is simple: you have 1 life and 1 hit will kill you. Try
and destroy as many enemies as possible before this happens.

The game features an online scoring system and the ability to replay
game sessions.

WWW: http://www.parallelrealities.co.uk/randomShooter.php

PR:		ports/121203
Submitted by:	Dmitry Marakasov <amdmi3 at amdmi3.ru>
This commit is contained in:
Martin Wilke 2008-03-14 20:36:50 +00:00
parent a5d574339a
commit f45a686f54
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=209070
7 changed files with 151 additions and 0 deletions

View File

@ -667,6 +667,7 @@
SUBDIR += qwdtools
SUBDIR += r1q2
SUBDIR += race
SUBDIR += randomshooter
SUBDIR += reminiscence
SUBDIR += rfksay
SUBDIR += ri-li

View File

@ -0,0 +1,40 @@
# New ports collection makefile for: randomshooter
# Date created: 27 Feb 2008
# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
#
# $FreeBSD$
#
PORTNAME= randomshooter
DISTVERSION= 0.1-1
CATEGORIES= games
# original url: http://parallelrealities.co.uk/download.php?proj=randomShooter&file=${DISTNAME}&type=zip
MASTER_SITES= http://www.amdmi3.ru/distfiles/
DISTNAME= RandomShooter-${DISTVERSION}
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A simple shoot'em up with online scoring and replays
USE_GMAKE= yes
USE_SDL= sdl mixer image ttf net
WRKSRC= ${WRKDIR}/RandomShooter
PORTDOCS= *
MAKEFILE= makefile
MAKE_ENV= CXX="${CXX}"
CXXFLAGS+= -DINSTALL_DIR=\\\"${DATADIR}/\\\"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.for dir in font gfx music
${MKDIR} ${DATADIR}/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/help/help.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (RandomShooter-0.1-1.tar.gz) = 710d334ebaaea7336bb08cfdf61f5839
SHA256 (RandomShooter-0.1-1.tar.gz) = 7dea906bf6573784953075a81f795451f9dcc158a834c555651698094103a759
SIZE (RandomShooter-0.1-1.tar.gz) = 362257

View File

@ -0,0 +1,33 @@
--- makefile.orig 2008-02-26 00:44:53.000000000 +0300
+++ makefile 2008-02-27 23:28:42.000000000 +0300
@@ -1,19 +1,19 @@
VERSION = 0.1
-CFLAGS = -Wall -pedantic -Werror -DUNIX -DVERSION=$(VERSION)
-LFLAGS = `sdl-config --libs` -lSDL -lSDL_mixer -lSDL_image -lSDL_ttf -lSDL_net
+CXXFLAGS += -Wall -DUNIX -DVERSION=$(VERSION) `${SDL_CONFIG} --cflags`
+LFLAGS = `${SDL_CONFIG} --libs` -lSDL_mixer -lSDL_image -lSDL_ttf -lSDL_net
OBJS = animation.o audio.o bullets.o collisions.o colors.o draw.o enemies.o entities.o font.o game.o highscores.o
OBJS += init.o input.o main.o menu.o movement.o particles.o player.o random.o replay.o score.o screenshot.o
OBJS += settings.o stars.o vector.o wave.o weapons.o
PROG = randomshooter
-CXX = gcc
+CXX ?= gcc
# top-level rule to create the program.
all: $(PROG)
# compiling other source files.
%.o: src/%.c src/%.h src/structs.h src/defs.h
- $(CXX) $(CFLAGS) -c -s $<
+ $(CXX) $(CXXFLAGS) -c -s $<
# linking the program.
$(PROG): $(OBJS)
@@ -24,4 +24,4 @@
rm $(PROG) *.o
install:
- echo "make install isn't supported yet..."
\ No newline at end of file
+ echo "make install isn't supported yet..."

View File

@ -0,0 +1,11 @@
--- src/input.c.orig 2008-02-23 12:14:38.000000000 +0300
+++ src/input.c 2008-02-27 23:53:35.000000000 +0300
@@ -170,7 +170,7 @@
{
char *name = (char *)malloc(25);
- strncpy(name, SDL_GetKeyName(inputValue), 24);
+ strncpy(name, SDL_GetKeyName((SDLKey)inputValue), 24);
if (strcmp(name, "unknown key") == 0)
{

View File

@ -0,0 +1,8 @@
This is the first release of a shoot em up game written in SDL. The
objective is simple: you have 1 life and 1 hit will kill you. Try
and destroy as many enemies as possible before this happens.
The game features an online scoring system and the ability to replay
game sessions.
WWW: http://www.parallelrealities.co.uk/randomShooter.php

View File

@ -0,0 +1,55 @@
bin/randomshooter
%%DATADIR%%/font/blackWolf.ttf
%%DATADIR%%/gfx/enemy_bullet0001.png
%%DATADIR%%/gfx/enemy_frame0001.png
%%DATADIR%%/gfx/enemy_frame0002.png
%%DATADIR%%/gfx/enemy_frame0003.png
%%DATADIR%%/gfx/enemy_frame0004.png
%%DATADIR%%/gfx/enemy_frame0005.png
%%DATADIR%%/gfx/enemy_frame0006.png
%%DATADIR%%/gfx/enemy_frame0007.png
%%DATADIR%%/gfx/enemy_frame0008.png
%%DATADIR%%/gfx/enemy_frame0009.png
%%DATADIR%%/gfx/enemy_frame0010.png
%%DATADIR%%/gfx/enemy_frame0011.png
%%DATADIR%%/gfx/enemy_frame0012.png
%%DATADIR%%/gfx/enemy_frame0013.png
%%DATADIR%%/gfx/enemy_frame0014.png
%%DATADIR%%/gfx/enemy_frame0015.png
%%DATADIR%%/gfx/menu_ball0001.png
%%DATADIR%%/gfx/menu_ball0002.png
%%DATADIR%%/gfx/menu_ball0003.png
%%DATADIR%%/gfx/menu_ball0004.png
%%DATADIR%%/gfx/menu_ball0005.png
%%DATADIR%%/gfx/menu_ball0006.png
%%DATADIR%%/gfx/menu_ball0007.png
%%DATADIR%%/gfx/menu_ball0008.png
%%DATADIR%%/gfx/menu_ball0009.png
%%DATADIR%%/gfx/menu_ball0010.png
%%DATADIR%%/gfx/menu_ball0011.png
%%DATADIR%%/gfx/menu_ball0012.png
%%DATADIR%%/gfx/menu_ball0013.png
%%DATADIR%%/gfx/menu_ball0014.png
%%DATADIR%%/gfx/menu_ball0015.png
%%DATADIR%%/gfx/player0001.png
%%DATADIR%%/gfx/player_bullet0001.png
%%DATADIR%%/gfx/points_frame0001.png
%%DATADIR%%/gfx/points_frame0002.png
%%DATADIR%%/gfx/points_frame0003.png
%%DATADIR%%/gfx/points_frame0004.png
%%DATADIR%%/gfx/points_frame0005.png
%%DATADIR%%/gfx/points_frame0006.png
%%DATADIR%%/gfx/points_frame0007.png
%%DATADIR%%/gfx/points_frame0008.png
%%DATADIR%%/gfx/points_frame0009.png
%%DATADIR%%/gfx/points_frame0010.png
%%DATADIR%%/gfx/points_frame0011.png
%%DATADIR%%/gfx/points_frame0012.png
%%DATADIR%%/gfx/points_frame0013.png
%%DATADIR%%/gfx/points_frame0014.png
%%DATADIR%%/gfx/points_frame0015.png
%%DATADIR%%/music/17.mod
@dirrm %%DATADIR%%/music
@dirrm %%DATADIR%%/gfx
@dirrm %%DATADIR%%/font
@dirrm %%DATADIR%%