Update to 0.20.0, switch to Qt4.

Pass maintainership to submitter.

PR:		based on ports/133788
Submitted by:	Jason Bacon <jwbacon at tds.net>
Approved by:	markus (previous maintainer)
This commit is contained in:
Max Brazhnikov 2009-04-28 19:17:53 +00:00
parent 93e15a2756
commit f4344fa32b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=232912
8 changed files with 83 additions and 101 deletions

View File

@ -5,28 +5,21 @@
# $FreeBSD$
PORTNAME= cutecom
PORTVERSION= 0.14.2
PORTVERSION= 0.20.0
CATEGORIES= comms
MASTER_SITES= http://cutecom.sourceforge.net/
MASTER_SITES= http://cutecom.sourceforge.net/ \
http://personalpages.tds.net/~jwbacon/Ports/distfiles/
MAINTAINER= markus@FreeBSD.org
MAINTAINER= jwbacon@tds.net
COMMENT= Graphical serial terminal
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
RUN_DEPENDS= lsz:${PORTSDIR}/comms/lrzsz
USE_QT_VER= 3
USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= qt3support qmake_build moc_build rcc_build uic_build
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
MAKE_ENV+= QTDIR="${QT_PREFIX}"
do-configure:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
-spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ cutecom.pro
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cutecom ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/applnk/Utilities
${INSTALL_DATA} ${WRKSRC}/cutecom.desktop ${PREFIX}/share/applnk/Utilities
MAN1= cutecom.1
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (cutecom-0.14.2.tar.gz) = d7a1028e0a0f5ce800c3519f7461c157
SHA256 (cutecom-0.14.2.tar.gz) = e8b9ed594b219bccaf3d79ded78f379edb377a5cd2a168032ea98a6f227ba138
SIZE (cutecom-0.14.2.tar.gz) = 22682
MD5 (cutecom-0.20.0.tar.gz) = a42394c3a29a2dc30edab721469f5eee
SHA256 (cutecom-0.20.0.tar.gz) = 44bf6c3a827b5d3b3a2b201010215faebde6af42dc16f5e0f877c858c6e19fe0
SIZE (cutecom-0.20.0.tar.gz) = 22217

View File

@ -0,0 +1,14 @@
--- ./CMakeLists.txt.orig 2008-03-13 00:09:49.000000000 +0300
+++ ./CMakeLists.txt 2009-04-25 21:48:15.000000000 +0400
@@ -19,10 +19,4 @@
install(FILES cutecom.1 DESTINATION man/man1 )
-find_program(KDECONFIG_EXECUTABLE NAMES kde-config )
-
-if (KDECONFIG_EXECUTABLE)
- # then ask kde-config for the kde data dirs
- exec_program(${KDECONFIG_EXECUTABLE} ARGS --install apps --expandvars OUTPUT_VARIABLE _apps_DIR )
- install(FILES cutecom.desktop DESTINATION ${_apps_DIR}/Utilities)
-endif (KDECONFIG_EXECUTABLE)
+install(FILES cutecom.desktop DESTINATION share/applications)

View File

@ -1,14 +1,14 @@
--- cutecommdlg.ui.orig Thu Jul 15 01:11:45 2004
+++ cutecommdlg.ui Thu Jul 15 01:12:07 2004
@@ -248,11 +248,6 @@
</item>
<item>
<property name="text">
- <string>576000</string>
- </property>
- </item>
- <item>
- <property name="text">
<string>921600</string>
</property>
</item>
--- cutecommdlg.ui.orig 2008-03-12 16:09:50.000000000 -0500
+++ cutecommdlg.ui 2009-03-28 12:46:04.000000000 -0500
@@ -220,11 +220,6 @@
</item>
<item>
<property name="text" >
- <string>576000</string>
- </property>
- </item>
- <item>
- <property name="text" >
<string>921600</string>
</property>
</item>

View File

@ -1,78 +1,29 @@
--- qcppdialogimpl.cpp.orig 2008-03-10 17:53:45.000000000 -0500
+++ qcppdialogimpl.cpp 2008-04-15 17:43:27.000000000 -0500
@@ -49,6 +49,7 @@
#include <sys/time.h>
#include <sys/types.h>
#include <sys/select.h>
+#include <sys/param.h>
#include <fcntl.h>
void millisleep(int ms)
@@ -234,11 +235,27 @@
--- qcppdialogimpl.cpp.orig 2009-03-28 12:42:56.000000000 -0500
+++ qcppdialogimpl.cpp 2009-03-28 12:44:32.000000000 -0500
@@ -243,11 +243,10 @@
bool entryFound=false;
QStringList devices=settings.readListEntry("/cutecom/AllDevices", &entryFound);
if (!entryFound)
+#ifdef __FreeBSD__
+#if __FreeBSD_version < 600000
+ devices<<"/dev/cuaa0"<<"/dev/cuaa1"<<"/dev/cuaa2"<<"/dev/cuaa3"<<"/dev/cuaU0"<<"/dev/cuaU1";
+#else
+ devices<<"/dev/cuad0"<<"/dev/cuad1"<<"/dev/cuad2"<<"/dev/cuad3"<<"/dev/cuaU0"<<"/dev/cuaU1";
+#endif
+#else
devices<<"/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
+#endif
- devices<<"/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
+ devices<<DEVLIST;
m_deviceCb->insertStringList(devices);
+#ifdef __FreeBSD__
+#if __FreeBSD_version < 600000
+ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/cuaa0"));
+#else
+ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/cuad0"));
+#endif
+#else
m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/ttyS0"));
+#endif
-
- m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/ttyS0"));
+ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", DEFAULT_DEV));
QStringList history=settings.readListEntry("/cutecom/History");
@@ -350,7 +367,7 @@
m_sz->addArgument("sh");
m_sz->addArgument("-c");
// QString tmp=QString("sx -vv \"")+filename+"\" < "+m_deviceCb->currentText()+" > "+m_deviceCb->currentText();
- QString tmp=QString("sz ");
+ QString tmp=QString("lsz ");
if (m_protoPb->currentText()=="XModem")
tmp+="--xmodem ";
else if (m_protoPb->currentText()=="YModem")
@@ -472,7 +489,7 @@
void QCPPDialogImpl::sendDone()
{
- cerr<<"sx exited"<<endl;
+ cerr<<"lsx exited"<<endl;
}
bool QCPPDialogImpl::eventFilter(QObject* watched, QEvent *e)
@@ -915,15 +932,21 @@
case 230400:
_baud=B230400;
break;
+#if !defined(__FreeBSD__) || (_FreeBSD_version > 500000)
@@ -932,9 +931,9 @@
case 460800:
_baud=B460800;
break;
+#endif
+#ifndef __FreeBSD__
case 576000:
_baud=B576000;
break;
+#endif
+#if !defined(__FreeBSD__) || (_FreeBSD_version >= 500000)
- case 576000:
- _baud=B576000;
- break;
+// case 576000:
+// _baud=B576000;
+// break;
case 921600:
_baud=B921600;
break;
+#endif
// case 128000:
// _baud=B128000;
// break;

View File

@ -0,0 +1,24 @@
--- qcppdialogimpl.h.orig 2008-03-12 16:09:50.000000000 -0500
+++ qcppdialogimpl.h 2009-03-28 09:05:42.000000000 -0500
@@ -103,4 +103,21 @@
};
+#if defined(__FreeBSD__)
+
+#define DEVLIST "/dev/cuaU0"<<"/dev/cuaU1"<<"/dev/cuad0"<<"/dev/cuad1";
+#define DEFAULT_DEV "/dev/cuaU0"
+
+#elif defined(__APPLE__)
+
+#define DEVLIST "/dev/cu.usbserial"<<"/dev/cu.KeySerial1";
+#define DEFAULT_DEV "/dev/cu.usbserial"
+
+#else // Default to Linux devices.
+
+#define DEVLIST "/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
+#define DEFAULT_DEV "/dev/ttyS0"
+
+#endif
+
#endif

View File

@ -1,3 +1,4 @@
CuteCom is a graphical serial terminal, like minicom.
CuteCom is a QT-based graphical serial terminal ideally suited to embedded
programming and robotics.
WWW: http://cutecom.sourceforge.net/

View File

@ -1,4 +1,3 @@
bin/cutecom
share/applnk/Utilities/cutecom.desktop
@dirrmtry share/applnk/Utilities
@dirrmtry share/applnk
share/applications/cutecom.desktop
@dirrmtry share/applications