Switch Charm Time Tracker to Qt5 and take maintainership.
Approved by: tcberner (mentor) Approved by: avg (maintainer) Differential Revision: https://reviews.freebsd.org/D12489
This commit is contained in:
parent
aca5ca871c
commit
f3f099d7f4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450759
@ -2,32 +2,32 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= charmtimetracker
|
||||
PORTVERSION= 1.11.4
|
||||
DISTVERSION= 1.11.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= deskutils
|
||||
|
||||
MAINTAINER= avg@icyb.net.ua
|
||||
MAINTAINER= adridg@FreeBSD.org
|
||||
COMMENT= Time tracker
|
||||
|
||||
# The top-level license file is GPLv2, but all the sources say
|
||||
# (at your option) GPLv2+ .
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++0x"
|
||||
USES= cmake:outsource compiler:c++11-lib
|
||||
# Use bundled keychain; the keychain is only used for KDAB-internal
|
||||
# features not available or configurable in the port.
|
||||
CMAKE_ARGS= -DCharm_VERSION:STRING=${PORTVERSION} \
|
||||
-DCMAKE_DISABLE_FIND_PACKAGE_Qt5Keychain=TRUE
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= KDAB
|
||||
GH_PROJECT= Charm
|
||||
|
||||
USES= cmake
|
||||
CMAKE_ARGS+= -DCharm_VERSION:STRING=${PORTVERSION} -DCHARM_FORCE_QT4=true
|
||||
USE_QT4= qmake_build moc_build rcc_build uic_build corelib dbus gui \
|
||||
network qtestlib script sql sql-sqlite3 xml
|
||||
USE_XORG= ice x11 xext xscrnsaver
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
PORTDOCS= ReadMe.txt
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-install:
|
||||
${RM} ${STAGEDIR}${DOCSDIR}/License.txt
|
||||
USE_QT5= core dbus gui \
|
||||
network printsupport script sql sql-sqlite3 \
|
||||
testlib widgets xml \
|
||||
buildtools_build qmake_build
|
||||
USE_XORG= ice x11 xcb xext xscrnsaver
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,6 +1,33 @@
|
||||
--- CMakeLists.txt.orig 2012-04-19 18:05:29.938959913 +0300
|
||||
+++ CMakeLists.txt 2012-04-19 18:05:39.398959691 +0300
|
||||
@@ -191,7 +191,7 @@
|
||||
- Shuffle a little to enforce C++11 in a normal way
|
||||
- Drop non-standard flags (unbreak PPC64)
|
||||
- Don't install license, since the ports LICENSE_FILE already does that
|
||||
|
||||
--- CMakeLists.txt.orig 2016-11-02 11:10:18 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -1,4 +1,8 @@
|
||||
-PROJECT( Charm )
|
||||
+CMAKE_MINIMUM_REQUIRED( VERSION 2.6.0 )
|
||||
+PROJECT( Charm CXX )
|
||||
+SET( CMAKE_CXX_STANDARD 11 )
|
||||
+SET( CMAKE_CXX_STANDARD_REQUIRED ON )
|
||||
+
|
||||
IF( NOT Charm_VERSION )
|
||||
FIND_PACKAGE( Git QUIET )
|
||||
IF( EXISTS ${GIT_EXECUTABLE} )
|
||||
@@ -34,12 +38,8 @@ ENDIF()
|
||||
|
||||
MESSAGE( STATUS "Building Charm ${Charm_VERSION} in ${CMAKE_BUILD_TYPE} mode" )
|
||||
|
||||
-CMAKE_MINIMUM_REQUIRED( VERSION 2.6.0 )
|
||||
SET( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/CMake" )
|
||||
|
||||
-IF(CMAKE_COMPILER_IS_GNUCXX OR ${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
|
||||
- SET(CMAKE_CXX_FLAGS "-std=c++0x ${CMAKE_CXX_FLAGS}")
|
||||
-ENDIF()
|
||||
IF(MSVC)
|
||||
SET(CMAKE_CXX_FLAGS "-D_USING_V110_SDK71_=1 ${CMAKE_CXX_FLAGS}")
|
||||
ENDIF()
|
||||
@@ -191,7 +185,7 @@ IF( APPLE AND "${QT_VERSION_MAJOR}.${QT_
|
||||
ENDIF()
|
||||
|
||||
IF( CMAKE_BUILD_TYPE MATCHES "^[Rr]elease$" )
|
||||
@ -9,3 +36,12 @@
|
||||
ENDIF()
|
||||
|
||||
# Always include the source and build directories in the include path
|
||||
@@ -264,7 +258,7 @@ CONFIGURE_FILE( CharmCMake.h.cmake ${CMA
|
||||
SET( LICENSE_FILE "License.txt" )
|
||||
SET( README_FILE "ReadMe.txt" )
|
||||
IF( NOT APPLE )
|
||||
- INSTALL( FILES "${LICENSE_FILE}" "${README_FILE}" DESTINATION ${DOC_INSTALL_DIR} )
|
||||
+ INSTALL( FILES "${README_FILE}" DESTINATION ${DOC_INSTALL_DIR} )
|
||||
ENDIF()
|
||||
|
||||
# Only support CPack packaging on newer versions of CMake.
|
||||
|
@ -1,3 +1,4 @@
|
||||
bin/charmtimetracker
|
||||
share/applications/charmtimetracker.desktop
|
||||
%%DOCSDIR%%/ReadMe.txt
|
||||
share/icons/hicolor/128x128/apps/Charm-128x128.png
|
||||
|
Loading…
Reference in New Issue
Block a user