New port: audio/nekobi-lv2: Simple single-oscillator synth based on the Roland TB-303
This commit is contained in:
parent
7ef95f7e6f
commit
f3c7600892
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=491992
@ -569,6 +569,7 @@
|
||||
SUBDIR += ncmpc
|
||||
SUBDIR += ncmpcpp
|
||||
SUBDIR += nekobee
|
||||
SUBDIR += nekobi-lv2
|
||||
SUBDIR += noise-repellent-lv2
|
||||
SUBDIR += normalize
|
||||
SUBDIR += nosefart
|
||||
|
36
audio/nekobi-lv2/Makefile
Normal file
36
audio/nekobi-lv2/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nekobi
|
||||
DISTVERSION= g20180825
|
||||
CATEGORIES= audio
|
||||
PKGNAMESUFFIX= -lv2
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Simple single-oscillator synth based on the Roland TB-303
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= lv2>0:audio/lv2 \
|
||||
bash:shells/bash
|
||||
LIB_DEPENDS= libjack.so:audio/jack
|
||||
|
||||
USES= gl gmake localbase pkgconfig shebangfix
|
||||
SHEBANG_FILES= dpf/utils/generate-ttl.sh
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= DISTRHO
|
||||
GH_PROJECT= Nekobi
|
||||
GH_TAGNAME= 840a692
|
||||
GH_TUPLE= DISTRHO:DPF:ea7545a:dpf/dpf
|
||||
USE_GL= gl
|
||||
USE_XORG= x11
|
||||
USE_GCC= any # clang prints errors: https://github.com/DISTRHO/Nekobi/issues/7
|
||||
|
||||
CFLAGS+= -I${FILESDIR}
|
||||
|
||||
do-install: # https://github.com/DISTRHO/Nekobi/issues/8
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/lv2
|
||||
cd ${WRKSRC}/bin && ${COPYTREE_SHARE} Nekobi.lv2 ${STAGEDIR}${PREFIX}/lib/lv2/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/Nekobi ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
5
audio/nekobi-lv2/distinfo
Normal file
5
audio/nekobi-lv2/distinfo
Normal file
@ -0,0 +1,5 @@
|
||||
TIMESTAMP = 1549141025
|
||||
SHA256 (DISTRHO-Nekobi-g20180825-840a692_GH0.tar.gz) = c9c9cdd95ca19f8ead5ff4c0ba8849747ee34b65e6beb185c45bd4c53adfdb7e
|
||||
SIZE (DISTRHO-Nekobi-g20180825-840a692_GH0.tar.gz) = 420235
|
||||
SHA256 (DISTRHO-DPF-ea7545a_GH0.tar.gz) = 3b5be02832277d7e65c058a31573d93e694b10503872a12393637da61d7b0721
|
||||
SIZE (DISTRHO-DPF-ea7545a_GH0.tar.gz) = 1621242
|
35
audio/nekobi-lv2/files/mntent.h
Normal file
35
audio/nekobi-lv2/files/mntent.h
Normal file
@ -0,0 +1,35 @@
|
||||
#ifdef HAVE_MNTENT_H
|
||||
#include <mntent.h>
|
||||
#else
|
||||
|
||||
#ifndef mntent_h_
|
||||
#define mntent_h_
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/param.h>
|
||||
#include <sys/ucred.h>
|
||||
#include <sys/mount.h>
|
||||
|
||||
#define MOUNTED "mounted"
|
||||
#define MNTTYPE_NFS "nfs"
|
||||
|
||||
//#define MOPTSLEN (256 - (MNAMELEN * 2 + MFSNAMELEN + 2 * sizeof(int)))
|
||||
|
||||
struct mntent {
|
||||
char *mnt_fsname; /* file system name */
|
||||
char *mnt_dir; /* file system path prefix */
|
||||
char *mnt_type; /* dbg, efs, nfs */
|
||||
char *mnt_opts; /* ro, hide, etc. */
|
||||
int mnt_freq; /* dump frequency, in days */
|
||||
int mnt_passno; /* pass number on parallel fsck */
|
||||
};
|
||||
|
||||
FILE * setmntent(char * filep, char * type);
|
||||
struct mntent *getmntent(FILE * filep);
|
||||
//char * hasmntopt(struct mntent * mnt, char * opt);
|
||||
int endmntent(FILE * filep);
|
||||
|
||||
#endif /* mntent_h_ */
|
||||
#endif /* not HAVE_MNTENT_H */
|
20
audio/nekobi-lv2/files/patch-dpf_dgl_src_Window.cpp
Normal file
20
audio/nekobi-lv2/files/patch-dpf_dgl_src_Window.cpp
Normal file
@ -0,0 +1,20 @@
|
||||
--- dpf/dgl/src/Window.cpp.orig 2018-09-25 22:56:57 UTC
|
||||
+++ dpf/dgl/src/Window.cpp
|
||||
@@ -18,6 +18,7 @@
|
||||
//#define PUGL_GRAB_FOCUS 1
|
||||
|
||||
#include "../Base.hpp"
|
||||
+#include <unistd.h>
|
||||
|
||||
#undef PUGL_HAVE_CAIRO
|
||||
#undef PUGL_HAVE_GL
|
||||
@@ -1164,7 +1165,8 @@ bool Window::openFileBrowser(const FileB
|
||||
|
||||
if (startDir.isEmpty())
|
||||
{
|
||||
- if (char* const dir_name = get_current_dir_name())
|
||||
+ char buf[MAXPATHLEN];
|
||||
+ if (char* const dir_name = getwd(buf))
|
||||
{
|
||||
startDir = dir_name;
|
||||
std::free(dir_name);
|
8
audio/nekobi-lv2/pkg-descr
Normal file
8
audio/nekobi-lv2/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
Simple single-oscillator synth based on the Roland TB-303.
|
||||
|
||||
This is a DPF'ied build of nekobee, allowing LV2 and VST builds of the plugin,
|
||||
plus a nicer UI with a simple cat animation.
|
||||
|
||||
Please see also the port audio/nekobee which is a corresponding DSSI plugin.
|
||||
|
||||
WWW: https://github.com/DISTRHO/Nekobi
|
6
audio/nekobi-lv2/pkg-plist
Normal file
6
audio/nekobi-lv2/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
bin/Nekobi
|
||||
lib/lv2/Nekobi.lv2/Nekobi_dsp.so
|
||||
lib/lv2/Nekobi.lv2/Nekobi_dsp.ttl
|
||||
lib/lv2/Nekobi.lv2/Nekobi_ui.so
|
||||
lib/lv2/Nekobi.lv2/Nekobi_ui.ttl
|
||||
lib/lv2/Nekobi.lv2/manifest.ttl
|
Loading…
Reference in New Issue
Block a user