Add bastet, an ncurses Tetris clone which is harder than every other Tetris.

Bastet stands for "bastard tetris" and uses a special algorithm designed to
choose the worst brick possible.
This commit is contained in:
Michael Nottebrock 2004-10-21 18:57:58 +00:00
parent d7e7582683
commit f3b0d98ca7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119915
7 changed files with 71 additions and 0 deletions

View File

@ -40,6 +40,7 @@
SUBDIR += baduki
SUBDIR += barrage
SUBDIR += bass
SUBDIR += bastet
SUBDIR += battalion
SUBDIR += battleball
SUBDIR += biorythm

20
games/bastet/Makefile Normal file
View File

@ -0,0 +1,20 @@
# New ports collection makefile for: bastet
# Date created: 21 Oct 2004
# Whom: Michael Nottebrock <lofi@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= bastet
PORTVERSION= 0.41
CATEGORIES= games
MASTER_SITES= http://fph.altervista.org/prog/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An ncurses Tetris clone which is harder than every other Tetris
USE_GMAKE= yes
MAKE_ENV= DATADIR=${DATADIR}
.include <bsd.port.mk>

2
games/bastet/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (bastet-0.41.tgz) = 48379dc98916ba083e9be5544f552a06
SIZE (bastet-0.41.tgz) = 24195

View File

@ -0,0 +1,21 @@
--- Makefile.orig Tue Oct 19 19:54:58 2004
+++ Makefile Thu Oct 21 20:43:02 2004
@@ -1,8 +1,8 @@
#makefile for bastet (c) 2004 Federico Poloni
#default paths
-BIN_PREFIX=/usr/bin/
-DATA_PREFIX=/var/games/
+BIN_PREFIX=$(PREFIX)/bin/
+DATA_PREFIX=$(PREFIX)/share/bastet/
HISCORE=bastet.scores
#in order to handle highscores properly, bastet must be setuid.
@@ -41,6 +41,7 @@
cp $(EXNAME) $(BIN_PREFIX)
chown $(GAME_USER) $(BIN_PREFIX)$(EXNAME)
chmod u+s $(BIN_PREFIX)$(EXNAME)
+ mkdir -p $(DATA_PREFIX)
touch $(DATA_PREFIX)$(HISCORE)
chown $(GAME_USER) $(DATA_PREFIX)$(HISCORE)
chmod 644 $(DATA_PREFIX)$(HISCORE)

View File

@ -0,0 +1,11 @@
--- bast.c.orig Thu Oct 21 20:32:29 2004
+++ bast.c Thu Oct 21 20:32:39 2004
@@ -1,7 +1,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <ncurses.h>
-#include <termio.h>
+#include <termios.h>
#include <assert.h>
#include <unistd.h>
#include <string.h>

13
games/bastet/pkg-descr Normal file
View File

@ -0,0 +1,13 @@
Have you ever thought Tetris(R) was evil because it wouldn't send
you that straight "I" brick you needed in order to clear four rows
at the same time?
Well Tetris(R) probably isn't evil, but Bastet
certainly is. Bastet stands for "bastard tetris", and is a
simple ncurses-based Tetris(R) clone for Linux. Unlike normal
Tetris(R), however, Bastet does not choose your next brick at random.
Instead, Bastet uses a special algorithm designed to choose the
worst brick possible.
As you can imagine, playing Bastet can be a
very frustrating experience!

3
games/bastet/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/bastet
%%DATADIR%%/bastet.scores
@dirrm %%DATADIR%%