devel/renpy: update to 7.0.0

Changes:	https://www.renpy.org/release/7.0 (see Announcment)
Changes:	https://www.renpy.org/doc/html/changelog.html#renpy-7-0
MFH:		2018Q2 (stabilization, no in-tree consumers)
This commit is contained in:
Jan Beich 2018-06-02 16:21:06 +00:00
parent c14378bc87
commit f3a024906a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=471376
6 changed files with 17 additions and 28 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= game_sdl2
PORTVERSION= 6.99.14.3
PORTVERSION= 7.0.0
CATEGORIES= devel python
MASTER_SITES= http://www.renpy.org/dl/${PORTVERSION}/ \
GENTOO

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1522810845
SHA256 (pygame_sdl2-2.1.0-for-renpy-6.99.14.3.tar.gz) = 21ac604287b8aa295c4811b229de5f063c712219258fdda6dac544e46ecfb94e
SIZE (pygame_sdl2-2.1.0-for-renpy-6.99.14.3.tar.gz) = 2573293
TIMESTAMP = 1527821357
SHA256 (pygame_sdl2-2.1.0-for-renpy-7.0.0.tar.gz) = 7eba0b990d613868daa077943bf89ce542e2945ed005e130cfa85f9819944437
SIZE (pygame_sdl2-2.1.0-for-renpy-7.0.0.tar.gz) = 2573001

View File

@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= renpy
PORTVERSION?= 6.99.14.3
PORTVERSION?= 7.0.0
DISTVERSIONSUFFIX=-sdk
PORTREVISION?= 2
PORTREVISION?= 0
CATEGORIES= devel games
MASTER_SITES= https://www.renpy.org/dl/${PORTVERSION}/
@ -40,10 +40,8 @@ BUILD_WRKSRC= ${WRKSRC}/module
INSTALL_WRKSRC= ${BUILD_WRKSRC}
MAKE_ENV+= RENPY_DEPS_INSTALL="${LOCALBASE}" \
RENPY_CYTHON=cython-${PYTHON_VER}
PORTDATA= launcher renpy renpy.py templates
.ifndef PKGNAMESUFFIX
PORTDATA+= gui
.endif
PORTDATA?= gui
PORTDATA+= launcher renpy renpy.py
PORTDOCS= *
PLIST_FILES= bin/${PORTNAME}
@ -96,7 +94,8 @@ add-empty-dirs:
! \( -name "saves" -or -name "pysdlsound" \) | \
${SED} 's,^${WRKSRC},@dir ${DATADIR},' >>${TMPPLIST}
post-install:
post-install: common-post-install
common-post-install:
${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} -name \*.so \
-exec ${STRIP_CMD} {} +
${LN} -fs ../${DATADIR_REL}/renpy.py \
@ -106,7 +105,6 @@ post-install:
"! -name *.orig ! -name *.bak \
! -name saves ! -name log.txt")
${CHMOD} +x ${STAGEDIR}${DATADIR}/renpy.py
${CHMOD} -R u+w ${STAGEDIR}${DATADIR}/templates
post-install-DOCS-on:
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1522810708
SHA256 (renpy-6.99.14.3-sdk.tar.bz2) = 5cbeea134a1907e8a14458248013e37f39f0c2d023c7b68f6ee2bee574f7a381
SIZE (renpy-6.99.14.3-sdk.tar.bz2) = 101048525
TIMESTAMP = 1527821217
SHA256 (renpy-7.0.0-sdk.tar.bz2) = 548561684b4e800c5aa349f9fae0371789c462dc3ede4ffd60ef45d3df1cc384
SIZE (renpy-7.0.0-sdk.tar.bz2) = 92106485

View File

@ -1,13 +0,0 @@
https://github.com/renpy/renpy/commit/ba832e5e3d52
--- renpy/display/render.pyx.orig 2018-01-26 22:32:59 UTC
+++ renpy/display/render.pyx
@@ -572,7 +572,7 @@ PIXELLATE = 3
cdef class Render:
- def __init__(Render self, float width, float height, draw_func=None, layer_name=None, bint opaque=None): #@DuplicatedSignature
+ def __init__(Render self, float width, float height, draw_func=None, layer_name=None, bint opaque=False): #@DuplicatedSignature
"""
Creates a new render corresponding to the given widget with
the specified width and height.

View File

@ -16,9 +16,13 @@ BUILD_DEPENDS= ${PYGAME}
RUN_DEPENDS= ${PYGAME}
USE_SDL= sdl
PORTDATA= templates
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
${WRKSRC}/launcher/game/project.rpy
post-install:
${CHMOD} -R u+w ${STAGEDIR}${DATADIR}/templates
.include "${MASTERDIR}/Makefile"