databases/clickhouse: Add forgotten patch.

Reported by:	maintainer

(cherry picked from commit 2519b10407)
This commit is contained in:
Kirill Ponomarev 2021-04-27 08:51:50 +02:00
parent a6d30d9777
commit f39d8e48af
2 changed files with 13 additions and 0 deletions

View File

@ -4,6 +4,7 @@ PORTNAME= clickhouse
PORTVERSION= 21.3.6.55
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -lts
PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= olevole@olevole.ru

View File

@ -0,0 +1,12 @@
--- contrib/cassandra/CMakeLists.txt.orig 2021-01-25 21:26:46 UTC
+++ contrib/cassandra/CMakeLists.txt
@@ -165,7 +165,8 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang" OR
"${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
# Enable C++11 support to use std::atomic
if(CASS_USE_STD_ATOMIC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17")
+ set(CMAKE_CXX_STANDARD "17")
endif()
# OpenSSL is deprecated on later versions of Mac OS X. The long-term solution