- Move highscores to /var/games where they belong
- Simplify Makefile - Modernize plist PR: 205631 Submitted by: amdmi3 Approved by: gmarco@gufi.org (maintainer)
This commit is contained in:
parent
d1a609d19d
commit
f399b102e9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=404818
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= xtet42
|
||||
PORTVERSION= 2.21
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://utenti.gufi.org/~gmarco/files/distfiles/
|
||||
|
||||
@ -11,25 +11,20 @@ MAINTAINER= gmarco@gufi.org
|
||||
COMMENT= One or two player T*tris game
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-setgid=games
|
||||
CONFIGURE_ARGS= --localstatedir=/var/games
|
||||
USE_XORG= x11
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
|
||||
post-extract:
|
||||
@${CHMOD} -R u+w ${WRKSRC}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,^hiscoredir.*,hiscoredir=${DATADIR},' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
@${CHMOD} 775 ${STAGEDIR}${DATADIR}
|
||||
@${STRIP_CMD} ${WRKSRC}/xtet42
|
||||
${INSTALL} -c -m 755 ${WRKSRC}/xtet42 ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL} -c -m 664 ${WRKSRC}/xtet42.hiscore ${STAGEDIR}${DATADIR}/.xtet42.hiscore
|
||||
${INSTALL} -c -m 664 ${WRKSRC}/xtet42.hiscore.single ${STAGEDIR}${DATADIR}/.xtet42.hiscore.single
|
||||
${INSTALL} -c -m 664 /dev/null ${STAGEDIR}${DATADIR}/.xtet42.unlock
|
||||
${INSTALL} -c -m 664 /dev/null ${STAGEDIR}${DATADIR}/.xtet42.log
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/xtet42 ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/xtet42.6 ${STAGEDIR}${MANPREFIX}/man/man6
|
||||
@${MKDIR} ${STAGEDIR}/var/games/xtet42
|
||||
${INSTALL_DATA} ${WRKSRC}/xtet42.hiscore ${STAGEDIR}/var/games/xtet42/.xtet42.hiscore.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/xtet42.hiscore.single ${STAGEDIR}/var/games/xtet42/.xtet42.hiscore.single.sample
|
||||
${INSTALL_DATA} /dev/null ${STAGEDIR}/var/games/xtet42/.xtet42.unlock.sample
|
||||
${INSTALL_DATA} /dev/null ${STAGEDIR}/var/games/xtet42/.xtet42.log.sample
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- Makefile.in.orig Mon Feb 15 00:36:53 1999
|
||||
+++ Makefile.in Mon Feb 15 00:41:28 1999
|
||||
@@ -24,7 +24,7 @@
|
||||
libdir = @libdir@
|
||||
localstatedir = @localstatedir@
|
||||
mandir = @mandir@
|
||||
-hiscoredir = $(localstatedir)/$(PACKAGE)
|
||||
+hiscoredir = $(PREFIX)/lib/X11/$(PACKAGE)
|
||||
|
||||
_Ver = $(VERSION)
|
||||
_Lock = $(hiscoredir)/.xtet42.lock
|
||||
@@ -37,6 +37,8 @@
|
||||
-D_Hiscore=\"$(_Hiscore)\" -D_Hione=\"$(_Hione)\" \
|
||||
-D_Log=\"$(_Log)\" -D_Ver=\"$(_Ver)\"
|
||||
|
||||
+
|
||||
+all: xtet42
|
||||
|
||||
xtet42: $(OBJS)
|
||||
$(CC) $(LDFLAGS) -o xtet42 $(OBJS)
|
@ -1,31 +0,0 @@
|
||||
--- xtet42.c.orig Mon Feb 15 00:37:09 1999
|
||||
+++ xtet42.c Mon Feb 15 00:39:51 1999
|
||||
@@ -67,23 +67,23 @@
|
||||
#endif
|
||||
|
||||
#ifndef _Lock
|
||||
-#define _Lock "/local/games/lib/xtet42/.xtet42.lock"
|
||||
+#define _Lock "/usr/X11R6/lib/X11/xtet42/.xtet42.lock"
|
||||
#endif
|
||||
|
||||
#ifndef _Unlock
|
||||
-#define _Unlock "/local/games/lib/xtet42/.xtet42.unlock"
|
||||
+#define _Unlock "/usr/X11R6/lib/X11/xtet42/.xtet42.unlock"
|
||||
#endif
|
||||
|
||||
#ifndef _Log
|
||||
-#define _Log "/local/games/lib/xtet42/.xtet42.log"
|
||||
+#define _Log "/usr/X11R6/lib/X11/xtet42/.xtet42.log"
|
||||
#endif
|
||||
|
||||
#ifndef _Hiscore
|
||||
-#define _Hiscore "/local/games/lib/xtet42/.xtet42.hiscore"
|
||||
+#define _Hiscore "/usr/X11R6/lib/X11/xtet42/.xtet42.hiscore"
|
||||
#endif
|
||||
|
||||
#ifndef _Hione
|
||||
-#define _Hione "/local/games/lib/xtet42/.xtet42.hiscore.single"
|
||||
+#define _Hione "/usr/X11R6/lib/X11/xtet42/.xtet42.hiscore.single"
|
||||
#endif
|
||||
|
||||
static int bricks[7][4][4][4]=
|
@ -1,12 +1,7 @@
|
||||
@(,games,2755) bin/xtet42
|
||||
man/man6/xtet42.6.gz
|
||||
@group games
|
||||
@mode 2755
|
||||
bin/xtet42
|
||||
@mode 664
|
||||
%%DATADIR%%/.xtet42.hiscore.single
|
||||
%%DATADIR%%/.xtet42.hiscore
|
||||
%%DATADIR%%/.xtet42.unlock
|
||||
%%DATADIR%%/.xtet42.log
|
||||
@mode 775
|
||||
@exec install -d -o root -g games -m 755 %D/%%DATADIR%%
|
||||
@dirrm %%DATADIR%%
|
||||
@sample(,games,664) /var/games/xtet42/.xtet42.hiscore.sample
|
||||
@sample(,games,664) /var/games/xtet42/.xtet42.hiscore.single.sample
|
||||
@sample(,games,664) /var/games/xtet42/.xtet42.log.sample
|
||||
@sample(,games,664) /var/games/xtet42/.xtet42.unlock.sample
|
||||
@dir(,games,775) /var/games/xtet42
|
||||
|
Loading…
Reference in New Issue
Block a user