- Update to 0.9.11

- Respect NO_INSTALL_MANPAGES

PR:		ports/153011
Submitted by:	Sofian Brabez <sbrabez AT gmail.com>
This commit is contained in:
Li-Wen Hsu 2010-12-11 18:51:52 +00:00
parent 08780470d8
commit f359757d48
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=266055
3 changed files with 14 additions and 12 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= googlecl
PORTVERSION= 0.9.10
PORTREVISION= 1
PORTVERSION= 0.9.11
CATEGORIES= net www python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@ -21,12 +20,16 @@ USE_PYDISTUTILS= yes
LICENSE= ASL
.if !defined(NO_INSTALL_MANPAGES)
MAN1= google.1
.endif
PORTDOCS= *
post-install:
.if !defined(NO_INSTALL_MANPAGES)
${INSTALL_MAN} ${WRKSRC}/man/google.1 ${MANPREFIX}/man/man1
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}

View File

@ -1,3 +1,2 @@
MD5 (googlecl-0.9.10.tar.gz) = 66872cdee0b527d23754e1df111f7836
SHA256 (googlecl-0.9.10.tar.gz) = 03b58b0dfc03c15eea131c1f5b34a0499f872b14ade48b9ef1d0fcd70a68853c
SIZE (googlecl-0.9.10.tar.gz) = 56564
SHA256 (googlecl-0.9.11.tar.gz) = d09d386c545abf458fdcc89a13d614017092c8b84db378f593e8223438f3e741
SIZE (googlecl-0.9.11.tar.gz) = 63638

View File

@ -1,14 +1,14 @@
--- setup.py.orig 2010-07-24 10:30:33.000000000 +0800
+++ setup.py 2010-08-24 21:11:15.000000000 +0800
@@ -12,10 +12,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
--- ./setup.py.orig 2010-12-11 00:04:45.000000000 +0100
+++ ./setup.py 2010-12-11 00:04:57.000000000 +0100
@@ -14,10 +14,7 @@
from __future__ import with_statement
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
+from distutils.core import setup
import os
import shutil
packages =['googlecl',
'googlecl.blogger',
'googlecl.calendar',