emulators/lisaem: Cleanup EXPIRED ports
Approved by: portmgr
This commit is contained in:
parent
3637dcfb11
commit
f32fd0820e
1
MOVED
1
MOVED
@ -17727,3 +17727,4 @@ security/fprintd||2022-12-31|Has expired: Very outdated, unsupported upstream wh
|
||||
cad/linux-eagle5||2022-12-31|Has expired: Deprecated upstream, superseded by Autodesk EAGLE 9
|
||||
net-p2p/amule-devel|net-p2p/amule|2022-12-31|Has expired: Superseded by non development port
|
||||
graphics/comical||2022-12-31|Has expired: Abandoned project and use deprecated wxgtk28
|
||||
emulators/lisaem||2022-12-31|Broken for more than a year and use deprecated wxgtk28
|
||||
|
@ -69,7 +69,6 @@
|
||||
SUBDIR += linux-power10-functional-sim
|
||||
SUBDIR += linux-power9-functional-sim
|
||||
SUBDIR += linux_base-c7
|
||||
SUBDIR += lisaem
|
||||
SUBDIR += magia
|
||||
SUBDIR += mame
|
||||
SUBDIR += mastergear
|
||||
|
@ -1,51 +0,0 @@
|
||||
PORTNAME= lisaem
|
||||
PORTVERSION= 1.2.6.2
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://lisaem.sunder.net/downloads/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Apple Lisa 2 Emulator
|
||||
WWW= https://lisaem.sunder.net/
|
||||
|
||||
DEPRECATED= Broken for more than a year and use deprecated wxgtk28
|
||||
EXPIRATION_DATE= 2022-12-31
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN_FreeBSD_13= ld: error: duplicate symbol: mem68k_fetch_byte
|
||||
BROKEN_FreeBSD_14= ld: error: duplicate symbol: mem68k_fetch_byte
|
||||
|
||||
BUILD_DEPENDS= pngtopnm:graphics/netpbm
|
||||
|
||||
USES= compiler:c++11-lang tar:bzip2
|
||||
USE_WX= 2.8
|
||||
|
||||
BINARY_ALIAS= wx-config=${WX_CONFIG}
|
||||
|
||||
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
|
||||
CXXFLAGS_clang= -Wno-c++11-narrowing
|
||||
|
||||
DESKTOP_ENTRIES="LisaEm" "" "lisaem" "lisaem" "" ""
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|^inline |static inline |' ${WRKSRC}/lisa/zilog8530.c
|
||||
|
||||
do-build:
|
||||
${FIND} ${WRKSRC} -type l -delete
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./build.sh build \
|
||||
--without-optimize
|
||||
${GREP} -v "^//" ${WRKSRC}/resources/lisa128x85.xpm | \
|
||||
${LOCALBASE}/bin/xpmtoppm | ${LOCALBASE}/bin/pnmtopng \
|
||||
> ${WRKDIR}/lisaem.png
|
||||
|
||||
do-install:
|
||||
(cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} * ${STAGEDIR}${PREFIX}/bin)
|
||||
(cd ${WRKDIR} && ${INSTALL_DATA} lisaem.png ${STAGEDIR}${PREFIX}/share/pixmaps)
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
(cd ${WRKSRC}/resources && ${INSTALL_DATA} * ${STAGEDIR}${DATADIR})
|
||||
${LN} -sf lisaem ${STAGEDIR}${PREFIX}/share/LisaEm
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (lisaem-1.2.6.2.tar.bz2) = e971b529da91a1cd0f61c957f4e66e87746ddb7e336907a004d1ca8d56c64c98
|
||||
SIZE (lisaem-1.2.6.2.tar.bz2) = 1916162
|
@ -1,134 +0,0 @@
|
||||
--- build.sh.orig 2015-09-03 19:56:33 UTC
|
||||
+++ build.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
|
||||
#### Edit these options for your system
|
||||
|
||||
@@ -46,7 +46,7 @@ done
|
||||
|
||||
if [ -z "$CYGWIN" ];
|
||||
then
|
||||
- [ "`uname`" == "CYGWIN_NT-5.0" ] && CYGWIN="`uname`"
|
||||
+ [ "`uname`" = "CYGWIN_NT-5.0" ] && CYGWIN="`uname`"
|
||||
fi
|
||||
|
||||
|
||||
@@ -121,9 +121,9 @@ WITHBLITS="-DUSE_RAW_BITMAP_ACCESS"
|
||||
export RCINCS="--include-dir=`cygpath -wp ${WXDEV}/include/common` "
|
||||
export DEFINES="-D__WXMSW__ -D__GNUWIN32__ -D__WIN95__ -D __WIN32__"
|
||||
export CXXINCS="-I. -I ..\include -I ..\cpu68k -I ..\\wxui -I `cygpath -wp ${MINGW}/include` -I `cygpath -wp ${MINGCPP}/backward` -I `cygpath -wp ${MINGCPP}/mingw32` -I `cygpath -wp ${MINGCPP}` -I `cygpath -wp ${WXDEV}/include` -I `cygpath -wp ${WXDEV}/` -I `cygpath -wp ${WXDEV}/include/common/wx/msw` -I `cygpath -wp ${WXDEV}/include/common/wx/generic` -I `cygpath -wp ${WXDEV}/include/common/wx/fl` -I `cygpath -wp ${WXDEV}/include/common/wx/gizmos` -I `cygpath -wp ${WXDEV}/include/common/wx/html` -I `cygpath -wp ${WXDEV}/include/common/wx/mmedia` -I `cygpath -wp ${WXDEV}/include/common/wx/net` -I `cygpath -wp ${WXDEV}/include/common/wx/ogl` -I `cygpath -wp ${WXDEV}/include/common/wx/plot` -I `cygpath -wp ${WXDEV}/include/common/wx/protocol` -I `cygpath -wp ${WXDEV}/include/common/wx/stc` -I `cygpath -wp ${WXDEV}/include/common/wx/svg` -I `cygpath -wp ${WXDEV}/include/common/wx/xml` -I `cygpath -wp ${WXDEV}/include/common/wx/xrc` -I `cygpath -wp ${WXDEV}/include/common/wx` -I `cygpath -wp ${WXDEV}/include/common`"
|
||||
- export CXXFLAGS="${CXXINCS} ${DEFINES}"
|
||||
+ export CXXFLAGS="${CXXFLAGS} ${CXXINCS} ${DEFINES}"
|
||||
export CXXFLAGS="-Wno-write-strings ${CXXINCS} ${DEFINES}" #2015.08.30 allow GCC 4.6.3 to ignore constant violation
|
||||
- export CFLAGS="${INCS} ${DEFINES} -fno-exceptions -fno-pcc-struct-return -fstrict-aliasing $WARNINGS -Wno-format -Wno-unused -D__WXMSW__ -D__GNUWIN32__ -D__WIN95__ -fexpensive-optimizations -O3"
|
||||
+ export CFLAGS="${CFLAGS} ${INCS} ${DEFINES} -fno-exceptions -fno-pcc-struct-return -fstrict-aliasing $WARNINGS -Wno-format -Wno-unused -D__WXMSW__ -D__GNUWIN32__ -D__WIN95__"
|
||||
export GPROF=gprof.exe
|
||||
export RM="rm -f"
|
||||
export LINK=g++.exe
|
||||
@@ -172,7 +172,7 @@ esac
|
||||
|
||||
fi
|
||||
#$CYGWIN is pre-set. Cache $DARWIN so we don't have to call uname over and over.
|
||||
-[ "`uname`" == "Darwin" ] && DARWIN="Darwin"
|
||||
+[ "`uname`" = "Darwin" ] && DARWIN="Darwin"
|
||||
|
||||
|
||||
# not needed on OS X
|
||||
@@ -234,11 +234,11 @@ fi
|
||||
# if the object is older than the source, it will return true.
|
||||
##############################################################################
|
||||
|
||||
-function NEEDED()
|
||||
+NEEDED()
|
||||
{
|
||||
if [ -f $2 ]
|
||||
then
|
||||
- [ "`ls -tr $2 $1 2>/dev/null| tail -1`" == "$1" ] && return 0
|
||||
+ [ "`ls -tr $2 $1 2>/dev/null| tail -1`" = "$1" ] && return 0
|
||||
return 1
|
||||
fi
|
||||
return 0
|
||||
@@ -399,7 +399,7 @@ exit 1
|
||||
fi
|
||||
|
||||
# create built by info and license
|
||||
-BUILTBY="\"Compiled on `date` by $LOGNAME@`uname -n` (`uname -v `)\n options:$WITHBLITS $WITHDEBUG $WITHTRACE $WITHUNICODE\""
|
||||
+BUILTBY="\"options:$WITHBLITS $WITHDEBUG $WITHTRACE $WITHUNICODE\""
|
||||
echo "#define BUILTBY $BUILTBY" >./include/built_by.h
|
||||
echo -n "#define LICENSE " >>./include/built_by.h
|
||||
cat LICENSE | sed 's/^/"/g' | sed 's/$/\\n" \\/g' >>./include/built_by.h
|
||||
@@ -475,9 +475,9 @@ then
|
||||
fi
|
||||
#2015.08.31
|
||||
#CFLAGS="-Wwrite-strings -I. -I../include -I../cpu68k -I../wxui $WXCONFIGFLAGS $WITHOPTIMIZE $WITHDEBUG"
|
||||
- CFLAGS="-Wno-write-strings -I. -I../include -I../cpu68k -I../wxui $WXCONFIGFLAGS $WITHOPTIMIZE $WITHDEBUG"
|
||||
- CXXFLAGS="-Wno-write-strings -I. -I../include -I../cpu68k -I../wxui $WXCONFIGFLAGS $WITHOPTIMIZE $WITHDEBUG"
|
||||
- LINKOPTS="`wx-config $STATIC $WITHUNICODE --libs --linkdeps --cppflags`"
|
||||
+ CFLAGS="$CFLAGS -Wno-write-strings -I. -I../include -I../cpu68k -I../wxui $WXCONFIGFLAGS $WITHOPTIMIZE $WITHDEBUG"
|
||||
+ CXXFLAGS="$CXXFLAGS -Wno-write-strings -I. -I../include -I../cpu68k -I../wxui $WXCONFIGFLAGS $WITHOPTIMIZE $WITHDEBUG"
|
||||
+ LINKOPTS="$LDFLAGS `wx-config $STATIC $WITHUNICODE --libs --linkdeps --cppflags`"
|
||||
if [ -z "$LINKOPTS" ]
|
||||
then
|
||||
echo wx-config has failed, or returned an error. Ensure that it exists in your path.
|
||||
@@ -493,7 +493,7 @@ fi
|
||||
###########################################################################
|
||||
|
||||
# Has the configuration changed since last time? if so we may need to do a clean build.
|
||||
-[ -f .last-opts ] && source .last-opts
|
||||
+[ -f .last-opts ] && . .last-opts
|
||||
|
||||
needclean=0
|
||||
#debug and tracelog changes affect the whole project, so need to clean it all
|
||||
@@ -663,7 +663,6 @@ then
|
||||
$CC $CFLAGS $LDFLAGS -o ../bin/lisadiskinfo lisadiskinfo.c libdc42.o || exit 1
|
||||
if [ -z "$WITHDEBUG" ]
|
||||
then
|
||||
- strip ../bin/lisadiskinfo${EXT}
|
||||
if [ -z "$WITHOUTUPX" ]; then
|
||||
if [ -x "`which upx 2>/dev/null`" ]; then upx --best ../bin/lisadiskinfo${EXT} ; fi
|
||||
fi
|
||||
@@ -682,7 +681,6 @@ then
|
||||
$CC $CFLAGS -o ../bin/lisafsh-tool lisafsh-tool.c libdc42.o || exit 1
|
||||
if [ -z "$WITHDEBUG" ]
|
||||
then
|
||||
- strip ../bin/lisafsh-tool${EXT}
|
||||
if [ -z "$WITHOUTUPX" ]; then
|
||||
if [ -x "`which upx 2>/dev/null`" ]; then upx --best ../bin/lisafsh-tool${EXT} ; fi
|
||||
fi
|
||||
@@ -737,7 +735,7 @@ if [ "$VSTATIC" -gt 0 ]; then DEPS=1; else DEPS=0; fi
|
||||
if [ "$DEPS" -gt 0 ]
|
||||
then
|
||||
echo " Compiling lisaem_static_resources.cpp..."
|
||||
- $CXX $CFLAGS -c lisaem_static_resources.cpp -o lisaem_static_resources.o || exit 1
|
||||
+ $CXX $CXXFLAGS -c lisaem_static_resources.cpp -o lisaem_static_resources.o || exit 1
|
||||
fi
|
||||
LIST="$LIST lisaem_static_resources.o"
|
||||
|
||||
@@ -803,7 +801,7 @@ do
|
||||
if NEEDED ${i}.cpp ${i}.o
|
||||
then
|
||||
echo " Compiling ${i}.cpp..."
|
||||
- $CXX -W $WARNINGS $WITHDEBUG $WITHTRACE $WITHBLITS $CFLAGS -c ${i}.cpp -o ${i}.o || exit 1
|
||||
+ $CXX -W $WARNINGS $WITHDEBUG $WITHTRACE $WITHBLITS $CXXFLAGS -c ${i}.cpp -o ${i}.o || exit 1
|
||||
fi
|
||||
done
|
||||
|
||||
@@ -908,7 +906,6 @@ then
|
||||
done
|
||||
cp $RESCPYLIST LisaEm.app/Contents/Resources/ || exit 1
|
||||
|
||||
- [ -z "$WITHDEBUG" ] && strip ./lisaem
|
||||
chmod 755 lisaem
|
||||
mv lisaem LisaEm
|
||||
mv LisaEm LisaEm.app/Contents/MacOS/
|
||||
@@ -989,8 +986,6 @@ if [ -z "$WITHDEBUG" ]
|
||||
then
|
||||
|
||||
echo "Freshly compiled `du -sh lisaem`"
|
||||
- strip lisaem${EXT}
|
||||
- echo "Stripped `du -sh lisaem`"
|
||||
|
||||
# compress it if upx exists.
|
||||
if [ -z "$WITHOUTUPX" ]; then
|
@ -1,161 +0,0 @@
|
||||
--- generator/cpu68k.c.orig 2007-12-04 16:57:08 UTC
|
||||
+++ generator/cpu68k.c
|
||||
@@ -259,7 +259,7 @@ int cpu68k_init(void)
|
||||
continue;
|
||||
}
|
||||
}
|
||||
- if (cpu68k_iibtable[bitmap] != NULL) {EXIT(283,0,"CPU definition #%d conflicts (0x%x)", i, bitmap);}
|
||||
+ if (cpu68k_iibtable[bitmap] != NULL) {EXITR(283,0,"CPU definition #%d conflicts (0x%x)", i, bitmap);}
|
||||
|
||||
cpu68k_iibtable[bitmap] = iib;
|
||||
/* set both flag and non-flag versions */
|
||||
@@ -285,7 +285,7 @@ int cpu68k_init(void)
|
||||
|
||||
if (j != cpu68k_totalinstr)
|
||||
{
|
||||
- EXIT(84,0,"Instruction count not verified (%d/%d)\n",
|
||||
+ EXITR(84,0,"Instruction count not verified (%d/%d)\n",
|
||||
cpu68k_totalinstr, i);
|
||||
}
|
||||
|
||||
@@ -904,19 +904,19 @@ t_ipc_table *get_ipct(void)
|
||||
else /*---- Nope! We're out of IPCt's, allocate some more. ----*/
|
||||
{
|
||||
|
||||
- if ( ipcts_free) { EXIT(3,0,"Bug! ipcts_free is %ld, but ipct_free_head is null",ipcts_free);}
|
||||
+ if ( ipcts_free) { EXITR(3,0,"Bug! ipcts_free is %ld, but ipct_free_head is null",ipcts_free);}
|
||||
|
||||
//check_iib();
|
||||
|
||||
/*--- Did we call Malloc too many times? ---*/
|
||||
- if ((iipct_mallocs++)>MAX_IPCT_MALLOCS) { EXIT(2,0,"Excessive mallocs of ipct's recompile with more!");}
|
||||
+ if ((iipct_mallocs++)>MAX_IPCT_MALLOCS) { EXITR(2,0,"Excessive mallocs of ipct's recompile with more!");}
|
||||
|
||||
size_to_get = (ipcts_allocated/IPCT_ALLOC_PERCENT)+1; // add a percentange of what we have, least 1
|
||||
if ( (ipct_mallocs[iipct_mallocs]=(t_ipc_table *)malloc(size_to_get * sizeof(t_ipc_table)+1) )==NULL)
|
||||
{
|
||||
DEBUG_LOG(0,"Out of memory getting more ipcs: %p was returned", ipct_mallocs[iipct_mallocs]);
|
||||
DEBUG_LOG(0,"%d ipcts allocated so far, %d are free, %d used, %d mallocs done", ipcts_allocated, ipcts_free, ipcts_used, iipct_mallocs);
|
||||
- EXIT(86,0,"Out of memory while allocating more ipct's");
|
||||
+ EXITR(86,0,"Out of memory while allocating more ipct's");
|
||||
}
|
||||
|
||||
// DEBUG_LOG(0,"zzzzzzz ipct land allocated:: %p -to- %p", ipct_mallocs[iipct_mallocs], (void *)(ipct_mallocs[iipct_mallocs]+size_to_get * sizeof(t_ipc_table)));
|
||||
@@ -1084,8 +1084,8 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
DEBUG_LOG(1000,"Nope - calling get_ipct()");
|
||||
mmu_trn->table=get_ipct(); // allocate an ipc table for this mmu_t
|
||||
table=mmu_trn->table;
|
||||
- if (!table) {EXIT(21,0,"Couldn't get IPC Table! Doh!");}
|
||||
- if (pc&1) {EXIT(14,0,"odd pc!");}
|
||||
+ if (!table) {EXITR(21,0,"Couldn't get IPC Table! Doh!");}
|
||||
+ if (pc&1) {EXITR(14,0,"odd pc!");}
|
||||
|
||||
//check_iib();
|
||||
|
||||
@@ -1094,11 +1094,11 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
// ipc points to the MMU translation table entry for this page.
|
||||
ipc = &(table->ipc[((pc>>1) & 0xff)]);
|
||||
DEBUG_LOG(200,"ipc is now %p at pc %06x max %06x",ipc,pc,xpc);
|
||||
- if (!ipc) {EXIT(501,0,"cpu68k_makeipclist: But! ipc is null!"); }
|
||||
- if (pc&1) {EXIT(501,0,"odd pc!");}
|
||||
+ if (!ipc) {EXITR(501,0,"cpu68k_makeipclist: But! ipc is null!"); }
|
||||
+ if (pc&1) {EXITR(501,0,"odd pc!");}
|
||||
}
|
||||
else
|
||||
- {EXIT(502,0,"Let the bodies hit the floor!\nLet the bodies hit the floor!\nLet the bodies hit the floor!\n\n Either mmu_trn or table is null!");}
|
||||
+ {EXITR(502,0,"Let the bodies hit the floor!\nLet the bodies hit the floor!\nLet the bodies hit the floor!\n\n Either mmu_trn or table is null!");}
|
||||
}
|
||||
|
||||
//check_iib();
|
||||
@@ -1106,7 +1106,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
|
||||
if ( !ipc)
|
||||
{
|
||||
- EXIT(17,0,"ipc=NULL\n1. Something's got to give 2. Something's got to give. 3. Something's got to give 4. Something's got to give.\nNOW!");
|
||||
+ EXITR(17,0,"ipc=NULL\n1. Something's got to give 2. Something's got to give. 3. Something's got to give 4. Something's got to give.\nNOW!");
|
||||
}
|
||||
|
||||
//check_iib();
|
||||
@@ -1126,7 +1126,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
|
||||
if ( !ipc)
|
||||
{
|
||||
- EXIT(20,0,"ipc=NULL\n1. Something's got to give 2. Something's got to give. 3. Something's got to give 4. Something's got to give.\nNOW!");
|
||||
+ EXITR(20,0,"ipc=NULL\n1. Something's got to give 2. Something's got to give. 3. Something's got to give 4. Something's got to give.\nNOW!");
|
||||
}
|
||||
|
||||
//check_iib();
|
||||
@@ -1236,8 +1236,8 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
// fflush(buglog);
|
||||
// #endif
|
||||
|
||||
- if (!iib) {EXIT(53,0,"There's no proper IIB for the possibly illegal instruction opcode %04x @ pc=%08x\n",opcode,pc);}
|
||||
- if ( !ipc) {EXIT(54,0,"Have a cow man! ipc=NULL\n"); }
|
||||
+ if (!iib) {EXITR(53,0,"There's no proper IIB for the possibly illegal instruction opcode %04x @ pc=%08x\n",opcode,pc);}
|
||||
+ if ( !ipc) {EXITR(54,0,"Have a cow man! ipc=NULL\n"); }
|
||||
|
||||
//DEBUG_LOG(200,"ipc is %s",(!ipc)?"null":"ok");
|
||||
|
||||
@@ -1283,7 +1283,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
// grow the list of ipcs if we need to.
|
||||
if (instrs>=ipcs_to_get)
|
||||
{
|
||||
- EXIT(24,0,"Welcome to the realms of chaos! I'm dealing with over %d instructions, %d ipcs! %d/%d/%d pc=%d/%08x",instrs,ipcs_to_get,segment1,segment2,start,context,pc);
|
||||
+ EXITR(24,0,"Welcome to the realms of chaos! I'm dealing with over %d instructions, %d ipcs! %d/%d/%d pc=%d/%08x",instrs,ipcs_to_get,segment1,segment2,start,context,pc);
|
||||
pc24=pc;
|
||||
}
|
||||
|
||||
@@ -1308,7 +1308,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
table=mmu_trn->table;
|
||||
|
||||
if (!table) {
|
||||
- EXIT(99,0,"Couldnt get IPC Table! Doh!\n");}
|
||||
+ EXITR(99,0,"Couldnt get IPC Table! Doh!\n");}
|
||||
|
||||
//if (pc&1) {DEBUG_LOG(200,"odd pc!"); EXIT(26);}
|
||||
}
|
||||
@@ -1333,7 +1333,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
|
||||
// check_iib();
|
||||
|
||||
- if (!table) {EXIT(27,0,"Couldnt get IPC Table! Doh!");}
|
||||
+ if (!table) {EXITR(27,0,"Couldnt get IPC Table! Doh!");}
|
||||
//ipc = &(mmu_trn->table->ipc[((pc>>1) & 0xff)]);
|
||||
//myiib=cpu68k_iibtable[opcode]; iib=myiib; // iib = myiib ? myiib : illegaliib;
|
||||
//////cpu68k_ipc(pc, iib, ipc);
|
||||
@@ -1370,7 +1370,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
if (instrs == 2)
|
||||
{
|
||||
|
||||
- if (pc&1) {EXIT(28,0,"odd pc!");}
|
||||
+ if (pc&1) {EXITR(28,0,"odd pc!");}
|
||||
DEBUG_LOG(200,"*~*~*~*~*~*~ in 2instrs ipc is now %p at pc %06x max %06x",ipc,pc,xpc);
|
||||
ipc=ipcs[instrs-1-1]; //ipc--
|
||||
DEBUG_LOG(200,"ipc is now %p at pc %06x max %06x",ipc,pc,xpc);
|
||||
@@ -1443,7 +1443,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
DEBUG_LOG(200,"ipc is now %p at pc %06x max %06x ix=%d",ipc,pc,xpc,ix);
|
||||
if ( !ipc)
|
||||
{
|
||||
- EXIT(29,0,"Null ipc, bye");
|
||||
+ EXITR(29,0,"Null ipc, bye");
|
||||
}
|
||||
|
||||
//check_iib();
|
||||
@@ -1460,7 +1460,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
|
||||
if (!ipc->function)
|
||||
{
|
||||
- EXIT(3,0,"Null IPC fn returned for opcode:%04x ix=%d of %d instrs",ipc->opcode,ix,instrs);
|
||||
+ EXITR(3,0,"Null IPC fn returned for opcode:%04x ix=%d of %d instrs",ipc->opcode,ix,instrs);
|
||||
// cpu68k_printipc(ipc);
|
||||
}
|
||||
|
||||
@@ -1479,7 +1479,7 @@ t_ipc_table *cpu68k_makeipclist(uint32 p
|
||||
{
|
||||
// check_iib();
|
||||
ipc=ipcs[ix];
|
||||
- EXIT(6,0,"FATAL ipc with null fnction at index %d-> used:%d, set:%d, opcode %04x, len %02x, src %08x, dst %08x\n",
|
||||
+ EXITR(6,0,"FATAL ipc with null fnction at index %d-> used:%d, set:%d, opcode %04x, len %02x, src %08x, dst %08x\n",
|
||||
ix, ipc->used, ipc->set, ipc->opcode, ipc->wordlen, ipc->src, ipc->dst);
|
||||
}
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- generator/reg68k.c.orig 2007-12-04 16:57:08 UTC
|
||||
+++ generator/reg68k.c
|
||||
@@ -1308,7 +1308,7 @@ else
|
||||
|
||||
///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
|
||||
- if (abort_opcode==1) {EXIT(476,0,"MMU/BUS/Address exception occured on opcode fetch!\n");}
|
||||
+ if (abort_opcode==1) {EXITR(476,0,"MMU/BUS/Address exception occured on opcode fetch!\n");}
|
||||
abort_opcode=0; // clear any addr/bus errors/traps/etc that may have occured.
|
||||
|
||||
InstructionRegister=ipc->opcode;
|
||||
@@ -1397,7 +1397,7 @@ else
|
||||
InstructionRegister=ipc->opcode;
|
||||
abort_opcode=0;
|
||||
if (ipc->function) ipc->function(ipc);
|
||||
- else { EXIT(277,0,"No ipc function at %d/%08x, even after attempting to get one!\n",context,pc24);}
|
||||
+ else { EXITR(277,0,"No ipc function at %d/%08x, even after attempting to get one!\n",context,pc24);}
|
||||
}
|
||||
} // if we have it, execute, else loop is done. :)
|
||||
|
@ -1,3 +0,0 @@
|
||||
The first fully functional Apple Lisa 2 emulator. This package emulates
|
||||
a Lisa 2 computer, as well as its profile hard drives, and ImageWriter
|
||||
or ADMP printers.
|
@ -1,32 +0,0 @@
|
||||
bin/lisadiskinfo
|
||||
bin/lisaem
|
||||
bin/lisafsh-tool
|
||||
%%DATADIR%%/Info.plist
|
||||
%%DATADIR%%/LisaEm.icns
|
||||
%%DATADIR%%/floppy0.png
|
||||
%%DATADIR%%/floppy1.png
|
||||
%%DATADIR%%/floppy2.png
|
||||
%%DATADIR%%/floppy3.png
|
||||
%%DATADIR%%/floppyN.png
|
||||
%%DATADIR%%/floppy_eject.wav
|
||||
%%DATADIR%%/floppy_insert_sound.wav
|
||||
%%DATADIR%%/floppy_motor1.wav
|
||||
%%DATADIR%%/floppy_motor2.wav
|
||||
%%DATADIR%%/lisa128x85.xpm
|
||||
%%DATADIR%%/lisa2icon.ico
|
||||
%%DATADIR%%/lisa2icon.ico.old
|
||||
%%DATADIR%%/lisa2icon.xpm
|
||||
%%DATADIR%%/lisa_power_switch01.wav
|
||||
%%DATADIR%%/lisa_power_switch02.wav
|
||||
%%DATADIR%%/lisaem.exe.Manifest
|
||||
%%DATADIR%%/lisaem.ico
|
||||
%%DATADIR%%/lisaem.ico.old
|
||||
%%DATADIR%%/lisaface0.png
|
||||
%%DATADIR%%/lisaface1.png
|
||||
%%DATADIR%%/lisaface2.png
|
||||
%%DATADIR%%/lisaface3.png
|
||||
%%DATADIR%%/power_off.png
|
||||
%%DATADIR%%/power_on.png
|
||||
%%DATADIR%%/poweroffclk.wav
|
||||
share/LisaEm
|
||||
share/pixmaps/lisaem.png
|
Loading…
Reference in New Issue
Block a user