PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.

This package provides the D-BUS module.

WWW: http://www.riverbankcomputing.co.uk/pyqt/

PR:		ports/109626
Submitted by:	Danny Pansters <danny at ricin.com>
This commit is contained in:
Martin Wilke 2007-03-27 09:58:49 +00:00
parent 9045d6e974
commit f304a19afd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188498
6 changed files with 234 additions and 0 deletions

View File

@ -1838,6 +1838,7 @@
SUBDIR += py-pydasm
SUBDIR += py-pytz
SUBDIR += py-qt4-core
SUBDIR += py-qt4-dbus
SUBDIR += py-rbtree
SUBDIR += py-repl
SUBDIR += py-resourcepackage

View File

@ -0,0 +1,47 @@
# New ports collection makefile for: py-qt4-dbus
# Date created: 2007-02-20
# Whom: Danny Pansters <danny@ricin.com>
#
# $FreeBSD$
PORTNAME= dbus
PORTVERSION= 20070318
CATEGORIES= devel python
MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt4/ \
http://freebsd.ricin.com/ports/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
DISTNAME= PyQt-x11-gpl-4-snapshot-${PORTVERSION}
MAINTAINER= danny@ricin.com
COMMENT= Python bindings for the Qt4 toolkit, D-BUS module
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtCore.so:${PORTSDIR}/devel/py-qt4-core \
${PYTHON_PKGNAMEPREFIX}dbus>=0.8:${PORTSDIR}/devel/py-dbus
RUN_DEPENDS= ${BUILD_DEPENDS}
HAS_CONFIGURE= yes
USE_PYTHON= 2.3+
USE_QT_VER= 4
QT_COMPONENTS= corelib qmake moc
OPTIONS= DEBUG "Enable debugging in generated code" off \
TRACING "Enable tracing in generated code" off
OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
ARGS= -b ${PREFIX}/bin -c -j 2 -d ${PYTHONPREFIX_SITELIBDIR}/PyQt4 \
-q ${QT_PREFIX}/bin/qmake-qt4 -s ${LOCALBASE}/include/dbus-1.0/dbus/
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
ARGS+= -u
.endif
.if defined(WITH_TRACING)
ARGS+= -r
.endif
do-configure:
( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${PYTHON_CMD} configure.py ${ARGS} )
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 538cd5167ccb14a6b6a3ee687432617a
SHA256 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = d98516e20b02194264c199deddda2562845efca64315608522cc05a36c9210c7
SIZE (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 1076275

View File

@ -0,0 +1,178 @@
--- configure.py.orig Mon Feb 19 04:39:13 2007
+++ configure.py Tue Feb 20 12:45:35 2007
@@ -133,18 +133,18 @@
}
def check_modules(self):
- pyqt_modules.append("QtCore")
+ #pyqt_modules.append("QtCore")
- check_module("QtGui", "qwidget.h", "new QWidget()")
- check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
- check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
- check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
- check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
- check_module("QtTest", "QtTest", "QTest::qSleep(0)")
- check_module("QtXml", "qdom.h", "new QDomDocument()")
- check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+ #check_module("QtGui", "qwidget.h", "new QWidget()")
+ #check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
+ #check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
+ #check_module("QtSql", "qsqldatabase.h", "new QSqlDatabase()")
+ #check_module("QtSvg", "qsvgwidget.h", "new QSvgWidget()")
+ #check_module("QtTest", "QtTest", "QTest::qSleep(0)")
+ #check_module("QtXml", "qdom.h", "new QDomDocument()")
+ #check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
+ #check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+ #check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
if os.path.isdir("dbus"):
check_dbus()
@@ -201,31 +201,31 @@
generate_code("QAxContainer", ["QAxContainer", "QtGui", "QtCore"])
# Generate the consolidated module.
- sipconfig.inform("Creating Qt consolidated module...")
- f = open("Qt.py", "w")
+ #sipconfig.inform("Creating Qt consolidated module...")
+ #f = open("Qt.py", "w")
- for m in pyqt_modules:
- f.write("from PyQt4.%s import *\n" % m)
+ #for m in pyqt_modules:
+ # f.write("from PyQt4.%s import *\n" % m)
- f.close()
+ #f.close()
# Generate the QScintilla API file.
- sipconfig.inform("Creating QScintilla API file...")
- f = open("PyQt4.api", "w")
+ #sipconfig.inform("Creating QScintilla API file...")
+ #f = open("PyQt4.api", "w")
- for m in pyqt_modules:
- api = open(m + ".api")
+ #for m in pyqt_modules:
+ # api = open(m + ".api")
- for l in api:
- f.write("PyQt4." + l)
+ # for l in api:
+ # f.write("PyQt4." + l)
- api.close()
- os.remove(m + ".api")
+ # api.close()
+ # os.remove(m + ".api")
- f.close()
+ #f.close()
def module_installs(self):
- return ["__init__.py", "Qt.py", "pyqtconfig.py"]
+ return []
def qpylibs(self):
# See which QPy libraries to build.
@@ -278,7 +278,7 @@
tool.append("dbus")
# Only include ElementTree for older versions of Python.
- if sipcfg.py_version < 0x020500:
+ """if sipcfg.py_version < 0x020500:
sipconfig.inform("Creating elementtree Makefile...")
makefile = sipconfig.PythonModuleMakefile(
@@ -309,7 +309,7 @@
)
makefile.generate()
- tool.append("pyuic")
+ tool.append("pyuic")"""
if "QtXml" in pyqt_modules:
sipconfig.inform("Creating pylupdate4 Makefile...")
@@ -344,7 +344,8 @@
makefile.generate()
tool.append("pyrcc")
else:
- sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
+ #sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
+ pass
if "QtDesigner" in pyqt_modules:
enabled = True
@@ -419,16 +420,16 @@
sipconfig.inform("The %s Qt library is in %s." % (qt_lib, qt_libdir))
sipconfig.inform("The Qt binaries are in %s." % qt_bindir)
sipconfig.inform("The Qt mkspecs directory is in %s." % qt_datadir)
- sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
+ #sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
- sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
+ #sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
if pydbusmoddir:
sipconfig.inform("The dbus support module will be installed in %s." % pydbusmoddir)
- sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
+ #sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
- sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
+ #sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
if opt_vendorcheck:
sipconfig.inform("PyQt will only be usable with signed interpreters.")
@@ -761,7 +762,8 @@
sipfiles = []
for s in glob.glob("sip/" + mname + "/*.sip"):
- sipfiles.append(os.path.join("..", "sip", mname, os.path.basename(s)))
+ if mname == "":
+ sipfiles.append(os.path.join("..", "sip", mname, os.path.basename(s)))
installs.append([sipfiles, os.path.join(opt_pyqtsipdir, mname)])
@@ -825,7 +827,7 @@
sipconfig.error("This version of PyQt and the %s edition of Qt have incompatible licenses." % qted)
# Confirm the license.
- print
+ """print
print "Type 'L' to view the license."
print "Type 'yes' to accept the terms of the license."
print "Type 'no' to decline the terms of the license."
@@ -847,7 +849,7 @@
if resp == "l":
os.system("more LICENSE")
-
+ """
# If there should be a license file then check it is where it should be.
if lfile:
if os.access(os.path.join("sip", lfile), os.F_OK):
@@ -1366,17 +1368,17 @@
scidir = os.path.join(qt_datadir, "qsci")
- if opt_api or os.path.isdir(scidir):
- installs.append(("PyQt4.api", os.path.join(scidir, "api", "python")))
+ #if opt_api or os.path.isdir(scidir):
+ # installs.append(("PyQt4.api", os.path.join(scidir, "api", "python")))
sipconfig.ParentMakefile(
configuration=sipcfg,
- subdirs=pyqt.qpylibs() + pyqt_modules + pyqt.tools(),
+ subdirs=pyqt.tools(),
installs=installs
).generate()
# Install the configuration module.
- create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
+ #create_config("pyqtconfig.py", "pyqtconfig.py.in", macros)
###############################################################################

View File

@ -0,0 +1,4 @@
PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.
This package provides the D-BUS module.
WWW: http://www.riverbankcomputing.co.uk/pyqt/

View File

@ -0,0 +1 @@
%%PYTHON_SITELIBDIR%%/dbus/mainloop/qt.so