MFH: r391771
www/chromium: update to 43.0.2357.132 Modify the UI code for button labels to be more consistent with the UI found in Linux versions of Chromium. Modify the process code to use kqueue to wait on non-child processes, as is done on OSX, rather than doing the default which is nothing. Submitted by: LeFroid Obtained from: https://github.com/gliaskos/freebsd-chromium/pull/22 Changelog: https://chromium.googlesource.com/chromium/src/+log/43.0.2357.130..43.0.2357.132 Approved by: ports-secteam (feld)
This commit is contained in:
parent
83efed7221
commit
f2e4da22cc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2015Q3/; revision=391827
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= chromium
|
||||
PORTVERSION= 43.0.2357.130
|
||||
PORTVERSION= 43.0.2357.132
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
|
||||
|
@ -1,4 +1,4 @@
|
||||
SHA256 (chromium-43.0.2357.130.tar.xz) = 62fb55439396a5d49ba53d4377e8d2554c14c2e8a6255f07909ccee8f248002e
|
||||
SIZE (chromium-43.0.2357.130.tar.xz) = 304344816
|
||||
SHA256 (chromium-43.0.2357.130-testdata.tar.xz) = 9c51df4007e9f025256bc75e76414835dae730f850ef281f9ae9c1ff31e01302
|
||||
SIZE (chromium-43.0.2357.130-testdata.tar.xz) = 114568060
|
||||
SHA256 (chromium-43.0.2357.132.tar.xz) = 405f52c6649f1d2937952fbcfcd238ba058db7d13edf4705f7027805f3ce1809
|
||||
SIZE (chromium-43.0.2357.132.tar.xz) = 290954464
|
||||
SHA256 (chromium-43.0.2357.132-testdata.tar.xz) = 9433cb06677281af688bfc5692625d610499ea803514f751bda59164fb683905
|
||||
SIZE (chromium-43.0.2357.132-testdata.tar.xz) = 127574536
|
||||
|
@ -1,13 +1,34 @@
|
||||
--- base/process/process_posix.cc.orig 2015-05-20 21:26:57.068650000 -0400
|
||||
+++ base/process/process_posix.cc 2015-05-20 21:25:28.077153000 -0400
|
||||
@@ -17,6 +17,10 @@
|
||||
@@ -17,6 +17,13 @@
|
||||
#include <sys/event.h>
|
||||
#endif
|
||||
|
||||
+#if defined(OS_BSD)
|
||||
+#include <signal.h>
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/event.h>
|
||||
+#include <sys/time.h>
|
||||
+#endif
|
||||
+
|
||||
namespace {
|
||||
|
||||
#if !defined(OS_NACL_NONSFI)
|
||||
@@ -83,7 +90,7 @@
|
||||
return ret_pid > 0;
|
||||
}
|
||||
|
||||
-#if defined(OS_MACOSX)
|
||||
+#if defined(OS_MACOSX) || defined(OS_BSD)
|
||||
// Using kqueue on Mac so that we can wait on non-child processes.
|
||||
// We can't use kqueues on child processes because we need to reap
|
||||
// our own children using wait.
|
||||
@@ -180,7 +187,7 @@
|
||||
base::ProcessHandle parent_pid = base::GetParentProcessId(handle);
|
||||
base::ProcessHandle our_pid = base::GetCurrentProcessHandle();
|
||||
if (parent_pid != our_pid) {
|
||||
-#if defined(OS_MACOSX)
|
||||
+#if defined(OS_MACOSX) || defined(OS_BSD)
|
||||
// On Mac we can wait on non child processes.
|
||||
return WaitForSingleNonChildProcess(handle, timeout);
|
||||
#else
|
||||
|
@ -0,0 +1,38 @@
|
||||
--- ui/views/controls/button/label_button.cc.orig Thu May 14 00:23:12 2015
|
||||
+++ ui/views/controls/button/label_button.cc Wed May 20 08:34:57 2015
|
||||
@@ -17,7 +17,7 @@
|
||||
#include "ui/views/painter.h"
|
||||
#include "ui/views/window/dialog_delegate.h"
|
||||
|
||||
-#if defined(OS_LINUX) && !defined(OS_CHROMEOS)
|
||||
+#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS)
|
||||
#include "ui/views/linux_ui/linux_ui.h"
|
||||
#endif
|
||||
|
||||
@@ -26,7 +26,7 @@
|
||||
// The default spacing between the icon and text.
|
||||
const int kSpacing = 5;
|
||||
|
||||
-#if !(defined(OS_LINUX) && !defined(OS_CHROMEOS))
|
||||
+#if !((defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS))
|
||||
// Default text and shadow colors for STYLE_BUTTON.
|
||||
const SkColor kStyleButtonTextColor = SK_ColorBLACK;
|
||||
const SkColor kStyleButtonShadowColor = SK_ColorWHITE;
|
||||
@@ -406,7 +406,7 @@
|
||||
// confusion. These details should either be pushed into ui::NativeThemeWin
|
||||
// or should be obsoleted by rendering buttons with paint calls instead of
|
||||
// with static assets. http://crbug.com/350498
|
||||
-#if !(defined(OS_LINUX) && !defined(OS_CHROMEOS))
|
||||
+#if !((defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS))
|
||||
constant_text_color = true;
|
||||
colors[STATE_NORMAL] = kStyleButtonTextColor;
|
||||
label_->SetBackgroundColor(theme->GetSystemColor(
|
||||
@@ -443,7 +443,7 @@
|
||||
|
||||
scoped_ptr<LabelButtonBorder> label_button_border = CreateDefaultBorder();
|
||||
|
||||
-#if defined(OS_LINUX) && !defined(OS_CHROMEOS)
|
||||
+#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS)
|
||||
views::LinuxUI* linux_ui = views::LinuxUI::instance();
|
||||
if (linux_ui) {
|
||||
SetBorder(linux_ui->CreateNativeBorder(
|
Loading…
Reference in New Issue
Block a user