- Fix build with new gcc version (patch-tvchannels.c)

- Remove s/gawk/awk/ patches and introduce build time dependecy to gawk
  because one of the scripts uses `strftime' which is not available in
  our base systems awk.

Approved by:	portmgr (clement)
This commit is contained in:
Simon Barner 2005-08-16 20:49:59 +00:00
parent 668ac75430
commit f2db0bcd95
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140896
8 changed files with 14 additions and 128 deletions

View File

@ -14,7 +14,9 @@ MASTER_SITES= http://elektra.e-technik.uni-ulm.de/~mbuck/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= X11/Xview TV Videotext/Teletext page viewer (.vtx files)
BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT} \
gawk:${PORTSDIR}/lang/gawk
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
xview.3:${PORTSDIR}/x11-toolkits/xview
@ -25,10 +27,4 @@ MAN1= tunerctl.1 videotext.1 vtxget.1
FONTSDIR= lib/X11/fonts/local
PLIST_SUB= FONTSDIR=${FONTSDIR}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502102
BROKEN= "Does not build"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,19 +0,0 @@
*** scripts/check-help.orig Tue Jun 8 16:10:07 1999
--- scripts/check-help Tue Jun 8 16:10:07 1999
*************** INFOFILE="$1"
*** 24,30 ****
shift
egrep -h 'XV_HELP_DATA.*"videotext:[a-zA-Z0-9_]+"' "$@" |
! gawk '
BEGIN {
RS = "[ \t,]"
}
--- 24,30 ----
shift
egrep -h 'XV_HELP_DATA.*"videotext:[a-zA-Z0-9_]+"' "$@" |
! awk '
BEGIN {
RS = "[ \t,]"
}

View File

@ -1,19 +0,0 @@
*** scripts/install-magic.orig Tue Jun 8 16:10:07 1999
--- scripts/install-magic Tue Jun 8 16:10:07 1999
*************** fi
*** 21,27 ****
trap 'rm -f "$1.vtxnew"' 0
cp -p "$1" "$1.vtxnew"
! gawk '
/^#.*Id: Localstuff/ {
localfound++
}
--- 21,27 ----
trap 'rm -f "$1.vtxnew"' 0
cp -p "$1" "$1.vtxnew"
! awk '
/^#.*Id: Localstuff/ {
localfound++
}

View File

@ -1,25 +0,0 @@
*** scripts/mkpsprolog.orig Tue Jun 8 16:10:07 1999
--- scripts/mkpsprolog Tue Jun 8 16:10:07 1999
***************
*** 8,17 ****
# Read COPYING for more information
# Maybe sed would be more suitable for such a simple task, but you already
! # need gawk for mktitlepage & mkvtxfont, so why not use it here...
! exec gawk '
BEGIN {
print "/* This file was created automatically by mkpsprolog. DO NOT EDIT */"
print ""
--- 8,17 ----
# Read COPYING for more information
# Maybe sed would be more suitable for such a simple task, but you already
! # need awk for mktitlepage & mkvtxfont, so why not use it here...
! exec awk '
BEGIN {
print "/* This file was created automatically by mkpsprolog. DO NOT EDIT */"
print ""

View File

@ -1,19 +0,0 @@
*** scripts/mktitlepage.orig Tue Jun 8 16:10:07 1999
--- scripts/mktitlepage Tue Jun 8 16:10:07 1999
***************
*** 14,20 ****
# by 2 hex-digits, so currently we can only set the lower 16 bits of the attributes.
! exec gawk '
BEGIN {
print "/* This file was created automatically by mktitlepage. DO NOT EDIT */"
}
--- 14,20 ----
# by 2 hex-digits, so currently we can only set the lower 16 bits of the attributes.
! exec awk '
BEGIN {
print "/* This file was created automatically by mktitlepage. DO NOT EDIT */"
}

View File

@ -1,19 +0,0 @@
*** scripts/mkvtxfont.orig Tue Jun 8 16:10:07 1999
--- scripts/mkvtxfont Tue Jun 8 16:10:07 1999
*************** if [ $# -ne 4 ]; then
*** 18,24 ****
exit 1
fi
! exec gawk -v "nfile=$2" -v "dfile=$3" -v "vfile=$4" -f - << "THIS_IS_THE_END" "$1"
function print_header(xsize, ysize, ptsize, width, file) { # Print BDF-File header
print "STARTFONT 2.1" > file
--- 18,24 ----
exit 1
fi
! exec awk -v "nfile=$2" -v "dfile=$3" -v "vfile=$4" -f - << "THIS_IS_THE_END" "$1"
function print_header(xsize, ysize, ptsize, width, file) { # Print BDF-File header
print "STARTFONT 2.1" > file

View File

@ -1,19 +0,0 @@
*** scripts/uninstall-magic.orig Tue Jun 8 16:10:07 1999
--- scripts/uninstall-magic Tue Jun 8 16:10:07 1999
*************** fi
*** 21,27 ****
trap 'rm -f "$1.vtxnew"' 0
cp -p "$1" "$1.vtxnew"
! gawk '
/^#.*VideoteXt/ {
skip = 1
next
--- 21,27 ----
trap 'rm -f "$1.vtxnew"' 0
cp -p "$1" "$1.vtxnew"
! awk '
/^#.*VideoteXt/ {
skip = 1
next

View File

@ -0,0 +1,10 @@
--- tvchannels.c.orig Tue Aug 16 20:12:35 2005
+++ tvchannels.c Tue Aug 16 20:17:07 2005
@@ -106,6 +106,7 @@
(*chan)->freq = freq;
(*chan)->next = NULL;
chan_done:
+ ;
} else {
fprintf(stderr, "%s:%d: Warning: Frequency out of range, line ignored:\n%s\n",
FNAME, lcount, line);