- Unbreak on FreeBSD 5.X: variable p shouldn't be used for two completely

different things (a MessagePriority and QPixmap) in the same sentence.

PR:		ports/81081
Submitted by:	Johan van Selst <johans@stack.nl>
This commit is contained in:
Pav Lucistnik 2005-05-17 08:58:03 +00:00
parent b2ed5e24d7
commit f2ab274fe3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135450
2 changed files with 22 additions and 7 deletions

View File

@ -41,10 +41,4 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/kiltdown/kiltdown ${PREFIX}/bin/
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502122
BROKEN= gcc34: no match for operator==
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,21 @@
--- kiltdown/mailviewer.cc.orig Sun May 15 22:29:50 2005
+++ kiltdown/mailviewer.cc Sun May 15 22:28:00 2005
@@ -950,13 +950,13 @@ void MailViewer::layoutComponents()
? ID_LOW_PRIORITY_TEXT
: ID_HIGH_PRIORITY_TEXT);
if (pstr) {
- QPixmap p(p == LowPriority ? lowpriIcon : priorityhdrIcon);
- priorityPixLabel->setPixmap(p);
- priorityPixLabel->setGeometry(4, top, p.width() + 1, ctlHeight);
+ QPixmap qp(p == LowPriority ? lowpriIcon : priorityhdrIcon);
+ priorityPixLabel->setPixmap(qp);
+ priorityPixLabel->setGeometry(4, top, qp.width() + 1, ctlHeight);
priorityLabel->setText(pstr);
localFree(pstr);
- priorityLabel->setGeometry(p.width() + 5, top,
- this->width() - p.width() - 13,
+ priorityLabel->setGeometry(qp.width() + 5, top,
+ this->width() - qp.width() - 13,
ctlHeight);
top += ctlHeight + 5;
priorityPixLabel->show();