- Update to 0.06

- Use USE_DOS2UNIX to remove trailing ^M

Changes:	http://search.cpan.org/dist/HTTP-Recorder/CHANGES
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2012-04-24 19:17:53 +00:00
parent 46ce3512d4
commit f2a5392b23
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295425
4 changed files with 23 additions and 23 deletions

View File

@ -6,26 +6,28 @@
#
PORTNAME= HTTP-Recorder
PORTVERSION= 0.05
PORTREVISION= 1
PORTVERSION= 0.06
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:LEIRA
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Record interaction with websites
BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/HTTP/Request/Params.pm:${PORTSDIR}/www/p5-HTTP-Request-Params
BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-HTTP-Proxy>=0:${PORTSDIR}/www/p5-HTTP-Proxy \
p5-HTTP-Request-Params>=0:${PORTSDIR}/www/p5-HTTP-Request-Params \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
USE_DOS2UNIX= yes
MAN1= httprecorder.1
MAN3= HTTP::Recorder.3
post-patch:
${RM} -f ${WRKSRC}/lib/HTTP/Recorder.pm.orig
@${RM} -f ${WRKSRC}/lib/HTTP/Recorder.pm.orig
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (HTTP-Recorder-0.05.tar.gz) = a6ee3139b63fb35308ef4f7192490d53085c66c77f9bae672ffe521b633aa689
SIZE (HTTP-Recorder-0.05.tar.gz) = 9604
SHA256 (HTTP-Recorder-0.06.tar.gz) = c5fe788d7a9d1e24398e89d7f5cbcd9c467ad7a34b33dd585a48ea2ab79c623b
SIZE (HTTP-Recorder-0.06.tar.gz) = 10872

View File

@ -1,25 +1,22 @@
$FreeBSD$
--- lib/HTTP/Recorder.pm.orig
+++ lib/HTTP/Recorder.pm
@@ -344,12 +344,13 @@
# get rid of the arguments we added
my $prefix = $self->{prefix};
--- lib/HTTP/Recorder.pm.orig 2012-04-23 22:20:16.000000000 +0800
+++ lib/HTTP/Recorder.pm 2012-04-25 01:11:56.207852080 +0800
@@ -352,11 +352,12 @@
return $content;
}
- for my $key ($content->query_param) {
- if ($key =~ /^$prefix-/) {
- $content->query_param_delete($key);
- }
- }
- return $content;
+ $content =~ s/$prefix-(.*?)\?(.*?)&//g;
+ $content =~ s/$prefix-(.*?)&//g;
+ $content =~ s/$prefix-(.*?)$//g;
+ $content =~ s/&$//g;
+ $content =~ s/\?$//g;
+ $content =~ s/$prefix-(.*?)\?(.*?)&//g;
+ $content =~ s/$prefix-(.*?)&//g;
+ $content =~ s/$prefix-(.*?)$//g;
+ $content =~ s/&$//g;
+ $content =~ s/\?$//g;
+
+ return $content;
return $content;
}
sub extract_values {

View File

@ -1,3 +1,4 @@
bin/httprecorder
%%SITE_PERL%%/HTTP/Recorder.pm
%%SITE_PERL%%/HTTP/Recorder/Logger.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Recorder/.packlist