o Update to version 3.2beta

o Correction of MASTER_SITES
 o Includes patch for sendfax option handling modification,
   which prevents sending out a fax via tkhylafax
This commit is contained in:
Lars Koeller 2003-01-16 20:34:51 +00:00
parent acc1f3fc4b
commit f2344e5553
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73282
5 changed files with 147 additions and 100 deletions

View File

@ -6,9 +6,10 @@
#
PORTNAME= tkhylafax
PORTVERSION= 3.0b2
PORTVERSION= 3.2b
CATEGORIES= comms tk82
MASTER_SITES= http://www.NeoSoft.com/tcl/ftparchive/sorted/comm/tkhylafax-3.0b2/
MASTER_SITES= ftp://ftp.hylafax.org/contrib/tkhylafax/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
MAINTAINER= ports@FreeBSD.org
@ -17,7 +18,7 @@ RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82 \
gs:${PORTSDIR}/print/ghostscript-gnu \
gv:${PORTSDIR}/print/gv
WRKSRC= ${WRKDIR}/tkhylafax-3.0
WRKSRC= ${WRKDIR}/tkhylafax
MAN1= tkhylafax.1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (tkhylafax-3.0b2.tar.gz) = 69b349ff7c6509769d17080109d2c765
MD5 (tkhylafax-3.2beta.tar.gz) = ee9e0fd2df2cb9f8c07a25f46f7083ca

View File

@ -1,60 +1,87 @@
--- Makefile.orig Sun Dec 29 13:26:39 1996
+++ Makefile Thu Sep 14 18:07:32 2000
@@ -14,10 +14,10 @@
TCLMAN_DEST = /usr/local/man/man1
# The full path to tclsh
-TCLSH = /usr/local/bin/tclsh
+TCLSH = tclsh8.2
# The full path to wish.
-WISH = /usr/local/bin/wish
+WISH = wish8.2
### DON'T EDIT ANYTHING BELOW THIS LINE ###
TCLLIB_FILES = \
@@ -40,35 +40,36 @@
TCLPRG_FILE = tkhylafax
TCLMAN_FILE = tkhylafax
-all: lib install.man tkhylafax
+all:
+
+install: lib install.man tkhylafax.inst
echo 'auto_mkindex $(TCLLIB_DEST) *.tcl *.t' | $(TCLSH);
$(TCLLIB_DEST):
if [ ! -d $(TCLLIB_DEST) ]; then mkdir -p $(TCLLIB_DEST); fi
- chmod 775 $(TCLLIB_DEST)
+ chmod 755 $(TCLLIB_DEST)
lib: $(TCLLIB_DEST)
@echo "Installing tkhylafax library..."
-for i in $(TCLLIB_FILES) ; do \
cp $$i $(TCLLIB_DEST)/$$i ; \
- chmod 664 $(TCLLIB_DEST)/$$i ; \
+ chmod 644 $(TCLLIB_DEST)/$$i ; \
done
@echo "Done"
$(TCLPRG_DEST):
if [ ! -d $(TCLPRG_DEST) ]; then mkdir -p $(TCLPRG_DEST); fi
- chmod 775 $(TCLPRG_DEST)
+ chmod 755 $(TCLPRG_DEST)
-tkhylafax: $(TCLPRG_DEST)
+tkhylafax.inst: $(TCLPRG_DEST)
@echo "Patching tkhylafax..."
mv tkhylafax tkhylafax.unpatched
sed -e 's|XXX_TKHYLAFAX_XXX|$(TCLLIB_DEST)|g' \
tkhylafax.unpatched > tkhylafax
@echo "Done"
@echo "Installing tkhylafax command..."
- cp $(TCLPRG_FILE) $(TCLPRG_DEST)/$@
- chmod 775 $(TCLPRG_DEST)/$@
- mv tkhylafax.unpatched tkhylafax
+ cp $(TCLPRG_FILE) $(TCLPRG_DEST)/tkhylafax
+ chmod 755 $(TCLPRG_DEST)/tkhylafax
@echo "Done"
install.man:
*** Makefile.orig Sat Mar 14 20:57:48 1998
--- Makefile Thu Jan 16 21:12:09 2003
***************
*** 5,11 ****
### EDIT THE NEXT LINES ONLY ###
! PREFIX = /usr/local
# The directory where the tkhylafax library will be installed
TCLLIB_DEST = $(PREFIX)/lib/tkhylafax-3.2
--- 5,11 ----
### EDIT THE NEXT LINES ONLY ###
! #PREFIX = ${PREFIX}
# The directory where the tkhylafax library will be installed
TCLLIB_DEST = $(PREFIX)/lib/tkhylafax-3.2
***************
*** 17,29 ****
TCLMAN_DEST = $(PREFIX)/man/man1
# The full path to tclsh
! TCLSH = /usr/bin/tclsh
# The full path to wish.
! WISH = /usr/bin/wish
# The full path to your postscript viewer
! GHOSTVIEW = /usr/X11/bin/gv
### DON'T EDIT ANYTHING BELOW THIS LINE ###
--- 17,29 ----
TCLMAN_DEST = $(PREFIX)/man/man1
# The full path to tclsh
! TCLSH = tclsh8.2
# The full path to wish.
! WISH = wish8.2
# The full path to your postscript viewer
! GHOSTVIEW = ${X11BASE}/bin/gv
### DON'T EDIT ANYTHING BELOW THIS LINE ###
***************
*** 52,58 ****
all:
$(MAKE) build
- $(MAKE) install
build: Makefile
@echo "Patching tkhylafax..."
--- 52,57 ----
***************
*** 66,78 ****
$(TCLLIB_DEST):
if [ ! -d $(TCLLIB_DEST) ]; then mkdir -p $(TCLLIB_DEST); fi
! chmod 775 $(TCLLIB_DEST)
install.lib: $(TCLLIB_DEST)
@echo "Installing tkhylafax library..."
-for i in $(TCLLIB_FILES) ; do \
cp $$i $(TCLLIB_DEST)/$$i ; \
! chmod 664 $(TCLLIB_DEST)/$$i ; \
done
@echo "Done"
--- 65,77 ----
$(TCLLIB_DEST):
if [ ! -d $(TCLLIB_DEST) ]; then mkdir -p $(TCLLIB_DEST); fi
! chmod 755 $(TCLLIB_DEST)
install.lib: $(TCLLIB_DEST)
@echo "Installing tkhylafax library..."
-for i in $(TCLLIB_FILES) ; do \
cp $$i $(TCLLIB_DEST)/$$i ; \
! chmod 644 $(TCLLIB_DEST)/$$i ; \
done
@echo "Done"

View File

@ -1,19 +1,35 @@
--- tkhylafax.orig Tue Dec 31 02:49:43 1996
+++ tkhylafax Sun Jun 8 12:34:58 1997
@@ -1,6 +1,6 @@
#!/bin/sh
#\
-exec wish "$0" ${1+"$@"}
+exec wish8.2 "$0" ${1+"$@"}
#
#
@@ -291,7 +291,7 @@
proc previewCover { args } {
- set faxcmd "[mkCover] | ghostview -"
+ set faxcmd "[mkCover] | gv -"
# Exec it
if {[catch {eval exec $faxcmd &} err]} {
*** faxIt.t.org Thu Jan 16 21:08:00 2003
--- faxIt.t Thu Jan 16 21:10:58 2003
***************
*** 66,80 ****
$Th_Info(notifyOnRetry)
if {[string length $Th_Info(name)]} {
- # This MUST appear.
- regsub -all {["'$\\]} $Th_Info(name) {\\&} name
- append options " -d \"$name@$Th_Info(phone)\""
-
# Make an ID string for later usage
regsub -all {["'$\\]} $Th_Info(company) {\\&} company
append options " -i \"$name@$company\""
} else {
! # This MUST appear.
append options " -d $Th_Info(phone)"
}
--- 66,80 ----
$Th_Info(notifyOnRetry)
if {[string length $Th_Info(name)]} {
# Make an ID string for later usage
+ regsub -all {["'$\\]} $Th_Info(name) {\\&} name
regsub -all {["'$\\]} $Th_Info(company) {\\&} company
append options " -i \"$name@$company\""
+
+ # This MUST appear last.
+ append options " -d \"$name@$Th_Info(phone)\""
} else {
! # This MUST appear last.
append options " -d $Th_Info(phone)"
}

View File

@ -1,18 +1,21 @@
bin/tkhylafax
lib/tkhylafax-3.0/entryDialog.t
lib/tkhylafax-3.0/extract.t
lib/tkhylafax-3.0/faxIt.t
lib/tkhylafax-3.0/fileSelect.t
lib/tkhylafax-3.0/listBatches.t
lib/tkhylafax-3.0/mkCover.t
lib/tkhylafax-3.0/mkWidgets.t
lib/tkhylafax-3.0/options.t
lib/tkhylafax-3.0/preferences.t
lib/tkhylafax-3.0/rolodex.t
lib/tkhylafax-3.0/searchEntries.t
lib/tkhylafax-3.0/sendBatch.t
lib/tkhylafax-3.0/svrStatus.t
lib/tkhylafax-3.0/tkhylafax.xbm
lib/tkhylafax-3.0/viewBatch.t
lib/tkhylafax-3.0/tclIndex
@dirrm lib/tkhylafax-3.0
lib/tkhylafax-3.2/entryDialog.t
lib/tkhylafax-3.2/extract.t
lib/tkhylafax-3.2/faxIt.t
lib/tkhylafax-3.2/fileSelect.t
lib/tkhylafax-3.2/listBatches.t
lib/tkhylafax-3.2/mkCover.t
lib/tkhylafax-3.2/mkWidgets.t
lib/tkhylafax-3.2/options.t
lib/tkhylafax-3.2/preferences.t
lib/tkhylafax-3.2/rolodex.t
lib/tkhylafax-3.2/searchEntries.t
lib/tkhylafax-3.2/sendBatch.t
lib/tkhylafax-3.2/svrStatus.t
lib/tkhylafax-3.2/trace.t
lib/tkhylafax-3.2/viewBatch.t
lib/tkhylafax-3.2/tclIndex
lib/tkhylafax-3.2/tkhylafax.xbm
lib/tkhylafax-3.2/dn.xbm
lib/tkhylafax-3.2/up.xbm
@dirrm lib/tkhylafax-3.2