- Support CFLAGS properly
- HAS_CONFIGURE -> GNU_CONFIGURE - Support NOPORTDOCS PR: 24543 Submitted by: Ports Fury
This commit is contained in:
parent
7f5eab6107
commit
f229e46916
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37472
@ -7,18 +7,24 @@
|
||||
|
||||
PORTNAME= snooper
|
||||
PORTVERSION= 1999.12.02
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= ftp://ftp.foretune.co.jp/pub/tools/snooper/
|
||||
DISTNAME= snooper-19991202
|
||||
MASTER_SITES= ftp://ftp.foretune.co.jp/pub/tools/snooper/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
|
||||
MAINTAINER= ports@freebsd.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/snooper/build
|
||||
HAS_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}/build
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
post-extract:
|
||||
@${RM} -f ${WRKSRC}/.depend
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/share/doc/snooper
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/snooper
|
||||
${INSTALL_DATA} ${WRKSRC}/../README ${PREFIX}/share/doc/snooper
|
||||
${CAT} ${PKGMESSAGE}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,38 +0,0 @@
|
||||
--- .depend.orig Sun Apr 25 23:37:14 1999
|
||||
+++ .depend Sun Apr 25 23:37:47 1999
|
||||
@@ -6,7 +6,7 @@
|
||||
/usr/include/errno.h /usr/include/limits.h /usr/include/machine/limits.h \
|
||||
/usr/include/sys/syslimits.h /usr/include/signal.h \
|
||||
/usr/include/sys/signal.h /usr/include/machine/signal.h \
|
||||
- /usr/include/machine/trap.h /usr/include/stdlib.h /usr/include/string.h \
|
||||
+ /usr/include/stdlib.h /usr/include/string.h \
|
||||
/usr/include/unistd.h /usr/include/sys/unistd.h ../include/extern.h \
|
||||
/usr/include/sys/ioctl.h /usr/include/sys/ttycom.h \
|
||||
/usr/include/sys/ioccom.h /usr/include/sys/filio.h \
|
||||
@@ -19,7 +19,7 @@
|
||||
/usr/include/limits.h /usr/include/machine/limits.h \
|
||||
/usr/include/sys/syslimits.h /usr/include/signal.h \
|
||||
/usr/include/sys/signal.h /usr/include/machine/signal.h \
|
||||
- /usr/include/machine/trap.h /usr/include/stdlib.h /usr/include/string.h \
|
||||
+ /usr/include/stdlib.h /usr/include/string.h \
|
||||
/usr/include/unistd.h /usr/include/sys/unistd.h ../include/extern.h \
|
||||
/usr/include/sys/ioctl.h /usr/include/sys/ttycom.h \
|
||||
/usr/include/sys/ioccom.h /usr/include/sys/filio.h \
|
||||
@@ -32,7 +32,7 @@
|
||||
/usr/include/errno.h /usr/include/limits.h /usr/include/machine/limits.h \
|
||||
/usr/include/sys/syslimits.h /usr/include/signal.h \
|
||||
/usr/include/sys/signal.h /usr/include/machine/signal.h \
|
||||
- /usr/include/machine/trap.h /usr/include/stdlib.h /usr/include/string.h \
|
||||
+ /usr/include/stdlib.h /usr/include/string.h \
|
||||
/usr/include/unistd.h /usr/include/sys/unistd.h ../include/extern.h \
|
||||
/usr/include/termios.h /usr/include/sys/ttycom.h /usr/include/sys/ioccom.h \
|
||||
/usr/include/sys/ttydefaults.h
|
||||
@@ -44,7 +44,7 @@
|
||||
/usr/include/limits.h /usr/include/machine/limits.h \
|
||||
/usr/include/sys/syslimits.h /usr/include/signal.h \
|
||||
/usr/include/sys/signal.h /usr/include/machine/signal.h \
|
||||
- /usr/include/machine/trap.h /usr/include/stdlib.h /usr/include/string.h \
|
||||
+ /usr/include/stdlib.h /usr/include/string.h \
|
||||
/usr/include/unistd.h /usr/include/sys/unistd.h ../include/extern.h
|
||||
uucplock.o : ../src/uucplock.c config.h /usr/include/sys/file.h \
|
||||
/usr/include/sys/fcntl.h /usr/include/sys/types.h \
|
20
comms/snooper/files/patch-ab
Normal file
20
comms/snooper/files/patch-ab
Normal file
@ -0,0 +1,20 @@
|
||||
--- Makefile.in.orig Wed Aug 12 23:31:56 1998
|
||||
+++ Makefile.in Thu Jan 18 02:54:00 2001
|
||||
@@ -2,7 +2,7 @@
|
||||
srcdir=@srcdir@/..
|
||||
CC= @CC@
|
||||
OPTFLAG=@OPTFLAG@
|
||||
-CFLAGS= -c $(OPTFLAG) -I. -I$(srcdir)/include @CFLAGS@
|
||||
+CFLAGS= -c -I. -I$(srcdir)/include @CFLAGS@
|
||||
LDFLAGS=@LDFLAGS@
|
||||
INSTALL=@INSTALL@
|
||||
|
||||
@@ -26,7 +26,7 @@
|
||||
uucplock.o: ../src/uucplock.c
|
||||
|
||||
depend:
|
||||
- mkdep ${CFLAGS:M-[ID]*} $(srcdir)/src/*.c
|
||||
+# mkdep ${CFLAGS:M-[ID]*} $(srcdir)/src/*.c
|
||||
|
||||
install:
|
||||
[ -d $(bindir) ] || (mkdir $(bindir))
|
14
comms/snooper/files/patch-ac
Normal file
14
comms/snooper/files/patch-ac
Normal file
@ -0,0 +1,14 @@
|
||||
--- ../src/uucplock.c.orig Thu Dec 2 12:12:46 1999
|
||||
+++ ../src/uucplock.c Thu Jan 18 02:57:30 2001
|
||||
@@ -38,7 +38,11 @@
|
||||
#include "config.h"
|
||||
|
||||
#include <sys/file.h>
|
||||
+#ifdef HAVE_DIRENT_H
|
||||
+#include <dirent.h>
|
||||
+#else
|
||||
#include <sys/dir.h>
|
||||
+#endif
|
||||
#include <errno.h>
|
||||
|
||||
#include "pathnames.h"
|
@ -1,2 +0,0 @@
|
||||
snooper has been installed.
|
||||
Documents can be found at: /usr/local/share/doc/snooper
|
@ -1,3 +1,3 @@
|
||||
bin/snooper
|
||||
share/doc/snooper/README
|
||||
@dirrm share/doc/snooper
|
||||
%%PORTDOCS%%share/doc/snooper/README
|
||||
%%PORTDOCS%%@dirrm share/doc/snooper
|
||||
|
Loading…
Reference in New Issue
Block a user