- Remove patchfile and remove autotools

- Strip installed binary
- Adopt port
- Bump portrevision
This commit is contained in:
Johan van Selst 2014-11-15 20:13:35 +00:00
parent ea26d4fe7a
commit f22787e7e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372613
2 changed files with 13 additions and 22 deletions

View File

@ -3,27 +3,30 @@
PORTNAME= xclip
PORTVERSION= 0.12
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
MAINTAINER= johans@FreeBSD.org
COMMENT= Interface to X selections ("the clipboard") from the command line
LICENSE= GPLv2
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env
USE_XORG= x11 xmu
USES= gmake
USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_header_X11_Xmu_Atoms_h=yes \
ac_cv_header_X11_Intrinsic_h=yes \
ac_cv_lib_Xmu_XmuClientWindow=yes
PLIST_FILES= bin/xclip bin/xclip-copyfile bin/xclip-cutfile bin/xclip-pastefile man/man1/xclip.1.gz man/man1/xclip-copyfile.1.gz
pre-configure:
cd ${WRKSRC}; ./bootstrap
PLIST_FILES= bin/xclip bin/xclip-copyfile bin/xclip-cutfile \
bin/xclip-pastefile \
man/man1/xclip.1.gz man/man1/xclip-copyfile.1.gz
post-patch:
${REINPLACE_CMD} 's,mktemp,mktemp -t xclip,' \
${WRKSRC}/xclip-copyfile
${REINPLACE_CMD} 's,mktemp,mktemp -t xclip,' ${WRKSRC}/xclip-copyfile
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xclip
.include <bsd.port.mk>

View File

@ -1,12 +0,0 @@
--- configure.ac.old 2009-11-02 22:15:13.000000000 +0200
+++ configure.ac 2009-11-02 22:15:18.000000000 +0200
@@ -12,9 +12,6 @@
AC_HEADER_STDC
AC_PATH_XTRA
AC_CHECK_TOOL(STRIP, strip, :)
-AC_CHECK_HEADER([X11/Xmu/Atoms.h], [], AC_MSG_ERROR([*** X11/Xmu/Atoms.h is missing ***]))
-AC_CHECK_HEADER([X11/Intrinsic.h], [], AC_MSG_ERROR([*** X11/Intrinsic.h is missing ***]))
-AC_CHECK_LIB(Xmu, XmuClientWindow, [], AC_MSG_ERROR([*** libXmu not found ***]))
AC_OUTPUT(Makefile)