- Fix build on 9.0-CURRENT

Submitted by:	Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2011-07-24 17:27:35 +00:00
parent 3682dca767
commit f224bc38cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278247
2 changed files with 26 additions and 1 deletions

View File

@ -16,10 +16,17 @@ MAINTAINER= m.tsatsenko@gmail.com
COMMENT= IPv6 network diagnostic tools
LICENSE= GPLv2
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-suid-install
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 900000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rdnssd-rdnssd.h
.endif
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
.else
@ -43,4 +50,4 @@ post-install:
.endfor
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,18 @@
--- rdnssd/rdnssd.h.orig 2011-07-23 01:03:38.000000000 +0400
+++ rdnssd/rdnssd.h 2011-07-23 01:03:56.000000000 +0400
@@ -32,15 +32,6 @@
/* Belongs in <netinet/icmp6.h> */
#define ND_OPT_RDNSS 25
-struct nd_opt_rdnss
-{
- uint8_t nd_opt_rdnss_type;
- uint8_t nd_opt_rdnss_len;
- uint16_t nd_opt_rdnss_resserved1;
- uint32_t nd_opt_rdnss_lifetime;
- /* followed by one or more IPv6 addresses */
-};
-
# ifdef __cplusplus
extern "C" {
# endif