- Update nDPI to 3.2.d20200324
- Update ntopng to 4.0.d20200326 Reported by: Victor Hooi <victorhooi@yahoo.com>
This commit is contained in:
parent
3a4aba51ec
commit
f1c467ec5d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=529260
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ndpi
|
||||
PORTVERSION= 3.0.d20191021
|
||||
PORTVERSION= 3.2.d20200324
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
|
||||
@ -28,7 +28,7 @@ INSTALL_TARGET= install-strip
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ntop
|
||||
GH_PROJECT= nDPI
|
||||
GH_TAGNAME= 2ce4223
|
||||
GH_TAGNAME= cd4f805
|
||||
|
||||
PLIST_SUB= MAJOR_VER=${PORTVERSION:R:R} VER=${PORTVERSION:R}
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575659254
|
||||
SHA256 (ntop-nDPI-3.0.d20191021-2ce4223_GH0.tar.gz) = 7732ed792457a4f8b7e48649e2e43e13daa10670a389053729e71fd559a0fe33
|
||||
SIZE (ntop-nDPI-3.0.d20191021-2ce4223_GH0.tar.gz) = 26902394
|
||||
TIMESTAMP = 1585258208
|
||||
SHA256 (ntop-nDPI-3.2.d20200324-cd4f805_GH0.tar.gz) = 049e30ae3e8ad2be860cf52f1e76ba42852fe156d99b2e7252bd98c903b75d6f
|
||||
SIZE (ntop-nDPI-3.2.d20200324-cd4f805_GH0.tar.gz) = 29586575
|
||||
|
@ -1,22 +1,28 @@
|
||||
--- example/Makefile.in.orig 2019-10-21 13:36:38 UTC
|
||||
--- example/Makefile.in.orig 2020-03-24 12:39:12 UTC
|
||||
+++ example/Makefile.in
|
||||
@@ -5,6 +5,7 @@ LIBNDPI=../src/lib/libndpi.a
|
||||
LDFLAGS=$(LIBNDPI) @PCAP_LIB@ -lpthread -lm @LDFLAGS@
|
||||
OBJS=ndpiReader.o reader_util.o
|
||||
@@ -8,11 +8,12 @@ HEADERS=intrusion_detection.h reader_util.h $(SRCHOME)
|
||||
$(SRCHOME)/include/ndpi_typedefs.h $(SRCHOME)/include/ndpi_protocol_ids.h
|
||||
OBJS=ndpiReader.o reader_util.o intrusion_detection.o
|
||||
PREFIX?=@prefix@
|
||||
+EXAMPLESDIR?=share/examples/ndpi
|
||||
|
||||
all: ndpiReader @DPDK_TARGET@
|
||||
|
||||
@@ -16,10 +17,10 @@ ndpiReader: $(OBJS) $(LIBNDPI)
|
||||
EXECUTABLE_SOURCES := ndpiReader.c
|
||||
-COMMON_SOURCES := $(filter-out $(EXECUTABLE_SOURCES),$(wildcard *.c ))
|
||||
+COMMON_SOURCES=intrusion_detection.c reader_util.c
|
||||
|
||||
libndpiReader.a: $(COMMON_SOURCES:%.c=%.o) $(LIBNDPI)
|
||||
ar rsv libndpiReader.a $(COMMON_SOURCES:%.c=%.o)
|
||||
@@ -25,10 +26,10 @@ ndpiReader: libndpiReader.a $(LIBNDPI) $(EXECUTABLE_SO
|
||||
|
||||
install:
|
||||
mkdir -p $(DESTDIR)$(PREFIX)/bin/
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/sbin/ndpi
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/share/ndpi
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/$(EXAMPLESDIR)/
|
||||
cp ndpiReader $(DESTDIR)$(PREFIX)/bin/
|
||||
- cp protos.txt $(DESTDIR)$(PREFIX)/sbin/ndpi/ndpiProtos.txt
|
||||
- cp mining_hosts.txt $(DESTDIR)$(PREFIX)/sbin/ndpi/ndpiCustomCategory.txt
|
||||
- cp protos.txt $(DESTDIR)$(PREFIX)/share/ndpi/ndpiProtos.txt
|
||||
- cp mining_hosts.txt $(DESTDIR)$(PREFIX)/share/ndpi/ndpiCustomCategory.txt
|
||||
+ cp protos.txt $(DESTDIR)$(PREFIX)/$(EXAMPLESDIR)/ndpiProtos.txt
|
||||
+ cp mining_hosts.txt $(DESTDIR)$(PREFIX)/$(EXAMPLESDIR)/ndpiCustomCategory.txt
|
||||
[ -f build/app/ndpiReader.dpdk ] && cp build/app/ndpiReader.dpdk $(DESTDIR)$(PREFIX)/bin/ || true
|
||||
|
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ntopng
|
||||
PORTVERSION= 3.8.d20191111
|
||||
PORTVERSION= 4.0.d20200326
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
|
||||
@ -36,7 +36,7 @@ PLIST_SUB= NTOPNGUSER="${USERS}" NTOPNGROUP="${GROUPS}"
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ntop
|
||||
GH_TAGNAME= 2c6a3fe
|
||||
GH_TAGNAME= 6d3ebbc
|
||||
|
||||
CPE_VENDOR= ntop
|
||||
|
||||
@ -51,11 +51,14 @@ USE_RC_SUBR= ntopng
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
|
||||
${WRKSRC}/configure.seed
|
||||
@${REINPLACE_CMD} -e 's/bind(/::bind(/' \
|
||||
${WRKSRC}/src/SyslogCollectorInterface.cpp
|
||||
cd ${WRKSRC} && ${SH} autogen.sh
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ntopng
|
||||
${MKDIR} ${STAGEDIR}/var/db/ntopng
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/ntopng-geoip2update.sh ${STAGEDIR}${PREFIX}/bin
|
||||
${RM} ${STAGEDIR}${DATADIR}/httpdocs/misc/ntopng-utils-manage-updates
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575661746
|
||||
SHA256 (ntop-ntopng-3.8.d20191111-2c6a3fe_GH0.tar.gz) = 498d276a948e0efe36f5e69a2564110f0729c930004ce700a5a7c0efa1ae13b9
|
||||
SIZE (ntop-ntopng-3.8.d20191111-2c6a3fe_GH0.tar.gz) = 33914472
|
||||
TIMESTAMP = 1585258827
|
||||
SHA256 (ntop-ntopng-4.0.d20200326-6d3ebbc_GH0.tar.gz) = a3239e08fbbe4493a0c95c05210a7e454d2192a17acfe1f3944c0bb07e2e2d64
|
||||
SIZE (ntop-ntopng-4.0.d20200326-6d3ebbc_GH0.tar.gz) = 43233771
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.seed.orig 2018-12-21 18:58:17 UTC
|
||||
--- configure.seed.orig 2020-03-26 13:52:23 UTC
|
||||
+++ configure.seed
|
||||
@@ -53,33 +53,8 @@ fi
|
||||
@@ -67,33 +67,8 @@ fi
|
||||
# On CentOS 6 `git rev-list HEAD --count` does not work
|
||||
#
|
||||
#
|
||||
@ -35,16 +35,34 @@
|
||||
SHORT_MACHINE=`uname -m | cut -b1-3`
|
||||
|
||||
GIT_RELEASE="@GIT_RELEASE@"
|
||||
@@ -131,7 +106,7 @@ fi
|
||||
@@ -134,7 +109,7 @@ AC_ARG_WITH(ndpi-includes,
|
||||
PKG_CHECK_MODULES([NDPI], [libndpi >= 2.0], [
|
||||
NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`/libndpi
|
||||
NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`
|
||||
# Use static libndpi library as building against the dynamic library fails
|
||||
- NDPI_LIB="-Wl,-Bstatic $NDPI_LIBS -Wl,-Bdynamic"
|
||||
+ NDPI_LIB="$NDPI_LIBS"
|
||||
NDPI_LIB_DEP=
|
||||
], [
|
||||
AC_MSG_CHECKING(for nDPI source)
|
||||
@@ -530,18 +505,6 @@ GMAKE=`which gmake`
|
||||
@@ -202,8 +177,15 @@ else
|
||||
SSL_INC="-I/usr/local/opt/openssl/include"
|
||||
SSL_LIB="-L/usr/local/opt/openssl/lib -lssl"
|
||||
else
|
||||
- echo "Please install openssl-dev(el) package prerequisite"
|
||||
- exit -1
|
||||
+ dnl Workaround for FreeBSD
|
||||
+ if test -f "/usr/lib/libssl.so"; then
|
||||
+ AC_DEFINE_UNQUOTED(NO_SSL_DL, 1, [has openssl])
|
||||
+ SSL_INC="-I/usr/include"
|
||||
+ SSL_LIB="-L/usr/lib -lssl"
|
||||
+ else
|
||||
+ echo "Please install openssl-dev(el) package prerequisite"
|
||||
+ exit -1
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -607,18 +589,6 @@ GMAKE=`which gmake`
|
||||
if test x$GMAKE = x
|
||||
then
|
||||
GMAKE="make"
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- scripts/lua/examples/sqlite.lua.orig 2018-12-21 18:58:17 UTC
|
||||
+++ scripts/lua/examples/sqlite.lua
|
||||
@@ -26,7 +26,7 @@ if (query == nil) then
|
||||
<div class="alert alert-warning alert-dismissible" role="alert">
|
||||
<button type="button" class="close" data-dismiss="alert"><span aria-hidden="true">×</span>
|
||||
<span class="sr-only">Close</span></button>
|
||||
- <strong>Query Empty!</strong> Example: localhost:3000/lua/examples/sqlite.lua?query=/var/lib/ntopng/0/flows/2014-15-15/07/08/01/45.sqlite
|
||||
+ <strong>Query Empty!</strong> Example: localhost:3000/lua/examples/sqlite.lua?query=/var/db/ntopng/0/flows/2014-15-15/07/08/01/45.sqlite
|
||||
</div>
|
||||
]]
|
||||
|
2126
net/ntopng/pkg-plist
2126
net/ntopng/pkg-plist
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user