Upgrade to 8.3.2.

PR:		ports/25372
This commit is contained in:
Jing-Tang Keith Jang 2001-03-08 05:05:57 +00:00
parent 39c9608b66
commit f18875debd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39230
8 changed files with 56 additions and 54 deletions

View File

@ -6,11 +6,11 @@
#
PORTNAME= tk
PORTVERSION= 8.3.1
PORTVERSION= 8.3.2
CATEGORIES= x11-toolkits tk83
MASTER_SITES= ftp://ftp.neosoft.com/pub/tcl/sorted/packages-8.0/devel/ \
http://www.neosoft.com/tcl/ftparchive/sorted/packages-8.0/devel/
DISTNAME= ${PORTNAME}${PORTVERSION}plus
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_3
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= jseger@FreeBSD.org

View File

@ -1 +1 @@
MD5 (tk8.3.1plus.tar.gz) = bf38b4aed84fc993559a59130ae8cad5
MD5 (tk8.3.2.tar.gz) = 9ea129345575b9a2763c8554f33b20e7

View File

@ -1,6 +1,7 @@
--- Makefile.in.orig Sat May 6 06:40:23 2000
+++ Makefile.in Wed May 10 17:32:06 2000
@@ -58,6 +58,8 @@
--- Makefile.in.orig Tue Aug 8 12:19:31 2000
+++ Makefile.in Sat Feb 24 20:34:02 2001
@@ -57,7 +57,9 @@
SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(TK_LIBRARY)
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
@ -10,7 +11,7 @@
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(mandir)
@@ -205,7 +207,7 @@
@@ -197,7 +199,7 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
LIBS = @LIBS@ $(X11_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@ -lc
@ -19,7 +20,7 @@
# The symbol below provides support for dynamic loading and shared
# libraries. See configure.in for a description of what it means.
@@ -378,8 +380,14 @@
@@ -370,8 +372,14 @@
${TK_LIB_FILE}: ${OBJS}
rm -f ${TK_LIB_FILE}
@MAKE_LIB@
@ -34,16 +35,16 @@
${STUB_LIB_FILE}: ${STUB_LIB_OBJS}
rm -f ${STUB_LIB_FILE}
@MAKE_STUB_LIB@
@@ -455,7 +463,7 @@
@@ -439,7 +447,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
-install-binaries: $(TK_LIB_FILE) $(TK_STUB_LIB_FILE) $(TK_BUILD_EXP_FILE) wish
+install-binaries: $(TK_LIB_FILE) $(TK_STUB_LIB_FILE) $(TK_BUILD_EXP_FILE) libtk${SHORT_TK_VER}.a wish
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) $(SCRIPT_INSTALL_DIR); \
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -473,14 +481,20 @@
@@ -457,12 +465,18 @@
fi
@echo "Installing $(TK_LIB_FILE) to $(LIB_INSTALL_DIR)/"
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@ -54,8 +55,6 @@
+ @$(INSTALL_DATA) libtk${SHORT_TK_VER}.a $(LIB_INSTALL_DIR)/libtk${SHORT_TK_VER}.a
+ @(cd $(LIB_INSTALL_DIR); $(RANLIB) libtk${SHORT_TK_VER}.a)
+ @chmod 555 $(LIB_INSTALL_DIR)/libtk${SHORT_TK_VER}.a
@echo "Installing pkgIndex.tcl"
@$(INSTALL_DATA) pkgIndex.tk $(SCRIPT_INSTALL_DIR)/pkgIndex.tcl
@echo "Installing wish as $(BIN_INSTALL_DIR)/wish$(VERSION)"
@$(INSTALL_PROGRAM) wish $(BIN_INSTALL_DIR)/wish$(VERSION)
@echo "Installing tkConfig.sh to $(LIB_INSTALL_DIR)/"
@ -65,7 +64,7 @@
@if test "$(TK_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TK_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TK_BUILD_EXP_FILE) \
@@ -494,6 +508,7 @@
@@ -476,6 +490,7 @@
install-libraries:
@for i in $(INCLUDE_INSTALL_DIR) \
@ -73,26 +72,27 @@
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -507,10 +522,16 @@
@@ -489,9 +504,18 @@
chmod +x $(UNIX_DIR)/install-sh; \
fi
@echo "Installing header files";
- @for i in $(GENERIC_DIR)/tk.h $(GENERIC_DIR)/tkDecls.h ; \
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
@for i in $(INSTALL_HDRS) ; \
do \
- $(INSTALL_DATA) $$i $(INCLUDE_INSTALL_DIR); \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ j=`basename $$i` ; \
+ ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/$$j $(INCLUDE_INSTALL_DIR)/$$j ; \
done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tkDecls.h $(INCLUDE_INSTALL_DIR)/tkDecls.h
@echo "Installing library files to $(SCRIPT_INSTALL_DIR)";
@for i in $(SRC_DIR)/library/*.tcl $(GENERIC_DIR)/prolog.ps \
$(SRC_DIR)/library/tclIndex $(UNIX_DIR)/tkAppInit.c; \
@@ -576,7 +597,6 @@
@@ -558,7 +582,6 @@
chmod 444 $(MAN1_INSTALL_DIR)/$$i; \
done;
@echo "Cross-linking top-level (.1) docs";
@ -100,15 +100,15 @@
@echo "Installing C API (.3) docs";
@cd $(SRC_DIR)/doc; for i in *.3; \
do \
@@ -586,7 +606,6 @@
@@ -568,7 +591,6 @@
chmod 444 $(MAN3_INSTALL_DIR)/$$i; \
done;
@echo "Cross-linking C API (.3) docs";
@echo "Cross-linking top-level (.3) docs";
- @$(UNIX_DIR)/mkLinks $(MAN3_INSTALL_DIR)
@echo "Installing command (.n) docs";
@cd $(SRC_DIR)/doc; for i in *.n; \
do \
@@ -596,7 +615,6 @@
@@ -578,7 +600,6 @@
chmod 444 $(MANN_INSTALL_DIR)/$$i; \
done;
@echo "Cross-linking command (.n) docs";

View File

@ -24,6 +24,8 @@ include/tk%%TK_VER%%/generic/tkSelect.h
include/tk%%TK_VER%%/generic/tkText.h
include/tk%%TK_VER%%/tk.h
include/tk%%TK_VER%%/tkDecls.h
include/tk%%TK_VER%%/tkInt.h
include/tk%%TK_VER%%/tkIntXlibDecls.h
include/tk%%TK_VER%%/unix/tkUnixDefault.h
include/tk%%TK_VER%%/unix/tkUnixInt.h
include/tk%%TK_VER%%/unix/tkUnixPort.h
@ -118,7 +120,6 @@ lib/tk%%TK_VER%%/msgbox.tcl
lib/tk%%TK_VER%%/obsolete.tcl
lib/tk%%TK_VER%%/optMenu.tcl
lib/tk%%TK_VER%%/palette.tcl
lib/tk%%TK_VER%%/pkgIndex.tcl
lib/tk%%TK_VER%%/prolog.ps
lib/tk%%TK_VER%%/safetk.tcl
lib/tk%%TK_VER%%/scale.tcl

View File

@ -6,11 +6,11 @@
#
PORTNAME= tk
PORTVERSION= 8.3.1
PORTVERSION= 8.3.2
CATEGORIES= x11-toolkits tk83
MASTER_SITES= ftp://ftp.neosoft.com/pub/tcl/sorted/packages-8.0/devel/ \
http://www.neosoft.com/tcl/ftparchive/sorted/packages-8.0/devel/
DISTNAME= ${PORTNAME}${PORTVERSION}plus
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_3
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= jseger@FreeBSD.org

View File

@ -1 +1 @@
MD5 (tk8.3.1plus.tar.gz) = bf38b4aed84fc993559a59130ae8cad5
MD5 (tk8.3.2.tar.gz) = 9ea129345575b9a2763c8554f33b20e7

View File

@ -1,6 +1,7 @@
--- Makefile.in.orig Sat May 6 06:40:23 2000
+++ Makefile.in Wed May 10 17:32:06 2000
@@ -58,6 +58,8 @@
--- Makefile.in.orig Tue Aug 8 12:19:31 2000
+++ Makefile.in Sat Feb 24 20:34:02 2001
@@ -57,7 +57,9 @@
SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(TK_LIBRARY)
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
@ -10,7 +11,7 @@
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(mandir)
@@ -205,7 +207,7 @@
@@ -197,7 +199,7 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
LIBS = @LIBS@ $(X11_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@ -lc
@ -19,7 +20,7 @@
# The symbol below provides support for dynamic loading and shared
# libraries. See configure.in for a description of what it means.
@@ -378,8 +380,14 @@
@@ -370,8 +372,14 @@
${TK_LIB_FILE}: ${OBJS}
rm -f ${TK_LIB_FILE}
@MAKE_LIB@
@ -34,16 +35,16 @@
${STUB_LIB_FILE}: ${STUB_LIB_OBJS}
rm -f ${STUB_LIB_FILE}
@MAKE_STUB_LIB@
@@ -455,7 +463,7 @@
@@ -439,7 +447,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
-install-binaries: $(TK_LIB_FILE) $(TK_STUB_LIB_FILE) $(TK_BUILD_EXP_FILE) wish
+install-binaries: $(TK_LIB_FILE) $(TK_STUB_LIB_FILE) $(TK_BUILD_EXP_FILE) libtk${SHORT_TK_VER}.a wish
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) $(SCRIPT_INSTALL_DIR); \
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -473,14 +481,20 @@
@@ -457,12 +465,18 @@
fi
@echo "Installing $(TK_LIB_FILE) to $(LIB_INSTALL_DIR)/"
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@ -54,8 +55,6 @@
+ @$(INSTALL_DATA) libtk${SHORT_TK_VER}.a $(LIB_INSTALL_DIR)/libtk${SHORT_TK_VER}.a
+ @(cd $(LIB_INSTALL_DIR); $(RANLIB) libtk${SHORT_TK_VER}.a)
+ @chmod 555 $(LIB_INSTALL_DIR)/libtk${SHORT_TK_VER}.a
@echo "Installing pkgIndex.tcl"
@$(INSTALL_DATA) pkgIndex.tk $(SCRIPT_INSTALL_DIR)/pkgIndex.tcl
@echo "Installing wish as $(BIN_INSTALL_DIR)/wish$(VERSION)"
@$(INSTALL_PROGRAM) wish $(BIN_INSTALL_DIR)/wish$(VERSION)
@echo "Installing tkConfig.sh to $(LIB_INSTALL_DIR)/"
@ -65,7 +64,7 @@
@if test "$(TK_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TK_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TK_BUILD_EXP_FILE) \
@@ -494,6 +508,7 @@
@@ -476,6 +490,7 @@
install-libraries:
@for i in $(INCLUDE_INSTALL_DIR) \
@ -73,26 +72,27 @@
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -507,10 +522,16 @@
@@ -489,9 +504,18 @@
chmod +x $(UNIX_DIR)/install-sh; \
fi
@echo "Installing header files";
- @for i in $(GENERIC_DIR)/tk.h $(GENERIC_DIR)/tkDecls.h ; \
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
@for i in $(INSTALL_HDRS) ; \
do \
- $(INSTALL_DATA) $$i $(INCLUDE_INSTALL_DIR); \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ j=`basename $$i` ; \
+ ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/$$j $(INCLUDE_INSTALL_DIR)/$$j ; \
done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tkDecls.h $(INCLUDE_INSTALL_DIR)/tkDecls.h
@echo "Installing library files to $(SCRIPT_INSTALL_DIR)";
@for i in $(SRC_DIR)/library/*.tcl $(GENERIC_DIR)/prolog.ps \
$(SRC_DIR)/library/tclIndex $(UNIX_DIR)/tkAppInit.c; \
@@ -576,7 +597,6 @@
@@ -558,7 +582,6 @@
chmod 444 $(MAN1_INSTALL_DIR)/$$i; \
done;
@echo "Cross-linking top-level (.1) docs";
@ -100,15 +100,15 @@
@echo "Installing C API (.3) docs";
@cd $(SRC_DIR)/doc; for i in *.3; \
do \
@@ -586,7 +606,6 @@
@@ -568,7 +591,6 @@
chmod 444 $(MAN3_INSTALL_DIR)/$$i; \
done;
@echo "Cross-linking C API (.3) docs";
@echo "Cross-linking top-level (.3) docs";
- @$(UNIX_DIR)/mkLinks $(MAN3_INSTALL_DIR)
@echo "Installing command (.n) docs";
@cd $(SRC_DIR)/doc; for i in *.n; \
do \
@@ -596,7 +615,6 @@
@@ -578,7 +600,6 @@
chmod 444 $(MANN_INSTALL_DIR)/$$i; \
done;
@echo "Cross-linking command (.n) docs";

View File

@ -24,6 +24,8 @@ include/tk%%TK_VER%%/generic/tkSelect.h
include/tk%%TK_VER%%/generic/tkText.h
include/tk%%TK_VER%%/tk.h
include/tk%%TK_VER%%/tkDecls.h
include/tk%%TK_VER%%/tkInt.h
include/tk%%TK_VER%%/tkIntXlibDecls.h
include/tk%%TK_VER%%/unix/tkUnixDefault.h
include/tk%%TK_VER%%/unix/tkUnixInt.h
include/tk%%TK_VER%%/unix/tkUnixPort.h
@ -118,7 +120,6 @@ lib/tk%%TK_VER%%/msgbox.tcl
lib/tk%%TK_VER%%/obsolete.tcl
lib/tk%%TK_VER%%/optMenu.tcl
lib/tk%%TK_VER%%/palette.tcl
lib/tk%%TK_VER%%/pkgIndex.tcl
lib/tk%%TK_VER%%/prolog.ps
lib/tk%%TK_VER%%/safetk.tcl
lib/tk%%TK_VER%%/scale.tcl